GPSFileDepot Forums

General Category => Map Making Support => Topic started by: vt.flatlander on May 10, 2016, 11:09:35 AM

Title: cGPSmapper hangs
Post by: vt.flatlander on May 10, 2016, 11:09:35 AM
I recently completed a map of New Hampshire and was not happy with the contour data so I went ahead and created my own 20ft vector data from the National Map DEM files using QGIS. 

For what ever reason cGPSmapper gets to 34% of processing through the "lines" elements (109,557ea.) of the first Final_MP file(566KB size) then just hangs there. Granted the file sizes have grown but the entire map is under 2 gig which I suspect would take approx 2 hrs to process.

What did I miss in creating my own contour data that cGPSmapper is having trouble with?
All that remains in the attribute table of my new vector file is NAME and MP_TYPE so no extra fields for the .exe to have to process through.
Title: Re: cGPSmapper hangs
Post by: Boyd on May 10, 2016, 11:52:02 AM
Are you creating just one 2gb .img file? Or does the map consist of multiple tiles? I have found cgpsmapper, and the gps itself, is happier with much smaller .img files. I use the standard USGS 24k quads as my tile size, and that usually results in .img files in the range 1 to 2mb each. There about 280 of these in my old map of NJ, which is about 9,000 square miles - similar to NH. The total mapset is less than 200MB. And this is an old version with very complex contours at 5 ft intervals in Southern NJ from 1/9 arc second LIDAR DEM. The mapset also contains landcover data for the entire state.

This map is rather sluggish on the GPS, and a new, optimized version using 1/3 arc second countours is less than 100mb. So 2gb sounds like a pretty large file for a state about the same size as NJ. And if this is just one big file, I'm not surprised that cgpsmapper isn't happy. ;)

You probably need to re-sample the contours so that the lines are less complex. This is trivial in globalmapper, but I don't know how to do it in Qgis.
Title: Re: cGPSmapper hangs
Post by: Boyd on May 10, 2016, 12:12:11 PM
Just as another point of reference, Garmin's own 24k Topo Northeast is 3.4gb, there are about 1000 tiles and the largest is about 10mb. And their map also contains routable roads and DEM data for shaded terrain. This is the coverage for the Garmin map, so I would say that 2gb is definitely out of line for a little state like NH. ;)

Title: Re: cGPSmapper hangs
Post by: jolly47roger on May 10, 2016, 12:18:26 PM
When I was building the UK topo, problems with CGPSMapper made me cut the country into tiles 15' high by 30' wide. The largest (as .MP) is 276MB which compiles to 3.6MB.
Title: Re: cGPSmapper hangs
Post by: vt.flatlander on May 10, 2016, 05:38:30 PM
Sorry everyone
I need to offer some clarification on this. My first map build was my home state of Vermont which is a 38MB file in BaseCamp.
My second map build is New Hampshire . Version 1 ended up at 28MB.
However if you look at the Split folders before compilation my VT Split folder is almost 1GB. The NH Split folder is 1.4GB.
 Both maps ended up with only six tiles total. Both maps work perfectly in BaseCamp.
I dont know enough about what is happening during the compilation process that causes the final map to be 38MB for VT and 28MB for NH.
Version 2 of my NH map is identical to version 1 except I am using contour data that was derived from the DEM files as previously mentioned.  The contour shapefile grew in size to 1.31GB as compared to my original contour shapefile in version 1 of 345MB. I was expecting the file to grow but not by 1GB
Am I somehow over my limit in tile size ? What info is available to explain how far you can go before you have to reduce the tile size.  My NH total Final_MP files under 2GB  before compilation.


Title: Re: cGPSmapper hangs
Post by: popej on May 11, 2016, 12:57:14 AM
I'm able to compile tiles, which are about 100MB. Resulting img are about 20MB.

I think the exact limit depends on many variables, for example on objects types or layers configuration, map features like routing or addresses.
Title: Re: cGPSmapper hangs
Post by: vt.flatlander on May 12, 2016, 12:45:35 PM
How long did it take to compile a tile with a resultant .imp of 20MB??

My first map project of the state of Vermont has 6 tiles . The total Final_mp files before compilation are 1.17GB . It take cGPSmapper approx. 2 hrs to compile. My next map project of the state of New Hampshire is also 6 tiles with a total Final_mp files of 1.9GB. It takes 3 times as long to compile.  Both have a max resulting .img of 12KB for any one tile.   
Title: Re: cGPSmapper hangs
Post by: jolly47roger on May 13, 2016, 02:50:02 AM
I have a map that starts as 16GB over 400 tiles. It takes about 5 hours to compile these using a 3.4GHz i7 and it ends up as 900Mb

When I tried running several streams in parallel (it is an 8-core machine)  cGPSMapper crashed. I'm guessing that is because there is some clash of temporary file usage.
Title: Re: cGPSmapper hangs
Post by: popej on May 13, 2016, 03:15:15 AM
On my PC compilation of 100MB mp takes about 4 minutes. This is a routable topo map.

My whole map is about 2.7GB divided into 49 tiles, final img size is about 580MB. I run compilation in 8 tasks simultaneously with temporary files on ramdisk. It takes about 20 minutes to compile it all. I have to assign a separate core for each task, otherwise cgpsmapper sometimes crashes.

I use I7 CPU running at 3.7-3.9GHz.
Title: Re: cGPSmapper hangs
Post by: Boyd on May 13, 2016, 04:34:18 AM
Had a quick look at a couple of my maps. For a topo map there are 133 .mp files that average about 4MB (442 MB total). They each compile in just a few seconds. My landcover map is very complex but contains only polygons. It has 445 .mp files average 9MB (3.98 GB total). They also compile in just a few seconds each. I am using Windows 7 on an i5 machine.