Welcome to GPSFileDepot!

Main Menu

Difficulty Opening an ".rar" file

Started by byrond, January 22, 2010, 01:16:50 PM

Previous topic - Next topic


In a few weeks I am traveling to the Virgin Islands.  I downloaded the appropriate maps and placed them into my Garmin Folder.  Then I used MapSource to open the file named "US TerritoriesProtectorates.rar."  When I tried to open the file in MapSource I get the message "XXX.RAR is not a valid MapSource file and could not be opened."  Once I get it opened, I want to download it to my 60CSX.  That part I know how to do.  It appears that I need to convert the file to a different extension.  Can anyone help me with this?

Byron Robertson


Mapsource can't "open" any kind of map files. The maps need to be installed into mapsource and that is not trivial.

A .rar file could be almost anything... see:

QuoteWhat is a RAR file

RAR is the native format of WinRAR archiver. Like other archives, RAR files are data containers, they store one or several files in the compressed form. After you downloaded RAR file from Internet, you need to unpack its contents in order to use it.

You will need to first extract the contents of the file, then maybe we can tell you whether it's something which can even be installed on your GPS. Where did you find these maps?


   Thanks for your reply.  The link you suggested is the same one that I used.  The files that were installed from that link were: 40641798.img, mti_vi.img and mti_vi.TDB.  When I try to use MapSource to open those files I get the message, "XXX is not a valid MapSource file and could not be opened."  If I cannot open the files in MapSource, I am unsure how I can load them into my 60CSX.

   Thanks for the info on RAR files.  The link you provided was very informative.



What version of MapSource and Windows are you using?

MapSource will use the mapset - not 'open' the files.  The mapset should appear in the narrow box in the upper left.  See:


   Wow, do I feel like an idiot.  The files were there all along I just did not look in the right place!  I needed to look at "The mapset should appear in the narrow box in the upper left."  Everything is fine now.  Thanks for all the support.


 ;) Don't fell bad.  The first time I tried to open a mapset I thought file/open was the method as I was doing that for tracks, etc.  Someone had to tell me that small one line box would 'pull-down' and show the installed mapsets.  Enjoy.