Welcome to GPSFileDepot!

Main Menu

Garmin eTrex Venture HC - Maps don't display

Started by chuckhubbert, August 13, 2009, 05:21:56 AM

Previous topic - Next topic


Hi, my name is Chuck, and I'm a noob...

Bottom line - I don't see any maps besides basemap on my GPSr.

I've downloaded Michigan Topo and have them displaying in Mapsource.  I've selected segments (or a single segment) and uploaded them to the GPSr with what appears to be no problems several times.

On the GPSr, I have selected the segment(s) from the Map - Setup Information menu.  I have toggled all sorts of show/hide settings in the contextual menu for Map display.

And the GPSr display never show anything but basemap.  I can show/hide the basemap and that make the difference that I would expect, but I cannot make any difference with the topo maps.

What am I missing?


Indrid Cold

You might not be zoomed in enough for the TOPO map to display.


I hate to ask the obvious here. But have you uploaded a segment where the GPS is at so that it has a TOPO segment to display?

Also I try to upload as big as a file that the GPSr will hold, just so I can have edge coverage.


I'm having the same problem, I've downloaded the area I live in... Willard MO. and I shows in Mapsource, transfers fine, shows in my Maps area on my HCx, but all I see is the Basemap... I've zoomed in and out, but it's not displaying.  I'm sill searching these threads to see if someone else has a fix. I hve a 4gig Card installed, I'm curious if the HCx is looking at the wrong "Directory"?  Chow 4 Now...


On the HCX, what brand/model of micro card are you using?  Many months ago there were posts on the forums that some micro cards were incompatable with Garmin GPSrs - it may have been the 4Gb SD high speed.

In Mapsource, do you see additional detail when you zoom-in?  When you select a quad/tile it will go from a yellow rectangle around it to a pink box, and will be listed in the box on the left side in Mapsource?

Besides being in the area you sent to the GSSr, and being zoomed in (everything should be showning at the 800' bar scale zoom level), have you changed any settings on the GPSr? 
Map/Menu/setup map/general/auto zoom = on
"                       "               "  /detail = normal
"                       "               "  /lock on road = off
"                       "      /points/map points = auto
"                       "      /points/land cover = auto
"                       "      /information - each of the quds should be listed and have a check in the show box
"                       "      /information/menu - 'hide' indicates the mapset is currently showing
                                                              'show' indicates the mapset is curretly hidden - selecting (highlighting the mapset) and pressing 'enter' will activate the mapset and change the verbage to 'hide mapset'
"                        "     /marine/marine colors = off - this might not be available on you units.

On the HCx, when you are in mass transfer mode, do you see a gmapsupp.img file in the garmin folder on the GPSr?
Your posts indicate one or both of you have done some of the above, however I have spent hours trying to trouble-shoot just to find something which sounded like it was done had not been done.


I finally got mine to load, not sure what I did, but Garmin has a Prg that it said I needed to load and when I did, things came together.  I need to see now how to load maps without the intaller :-)
Thanks 4 your help  :)


Which program did Garmin say you needed to load? I'm having the same problem.