Welcome, Guest. Please login or register.

Login with username, password and session length
Forums Search:  


Author Topic: Display problem with new GPS  (Read 2035 times)

431cruiser

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
Display problem with new GPS
« on: September 30, 2009, 08:15:47 PM »
I received today a Garmin etrex Venture HC, installed some AA batteries in it, turned it on, and it was cool for a few minutes.  Now, I think I have a display problem and not sure if it is a certain combination of buttons that I am pressing or a faulty unit or maybe old batteries (although they are fresh out of the wrapper).  If you can imagine the screen divided into four quadrants, the menu (or any other page) is appearing in each of the bottom two quadrants.  Same image, side by side, and whatever I do to one occurs on the other.  The top half of the screen is white with no images.

I took the batteries out, turned it off for awhile, and then turned it back on and it was okay again.  Flipped through some pages, pressed the buttons, just trying to get familiar with everything and being careful to only press one button at a time, and it did it again.

I have owned this GPS for about 4 hours.  It is fresh off the truck and out of the box.  What do you think?  I can't find anything in the manual that says this is a "feature" and I can't figure out how I got there!

Thanks.

Indrid Cold

  • Moderator
  • Expert Advisor
  • *****
  • Posts: 919
  • Karma: 20
    • View Profile
Re: Display problem with new GPS
« Reply #1 on: September 30, 2009, 09:38:28 PM »
That doesn't sound right, might want to exchange the unit for an other one.