Welcome to GPSFileDepot!

Main Menu

Fail installing GPSFileDepot maps

Started by LostNoMore, August 28, 2021, 06:32:00 PM

Previous topic - Next topic


So lots of frustration trying to install a map from GPSFileDepot. I've followed the tutorials to the letter, but when MapInstall opens from BaseCamp there are no maps shown. I am using a new 32GB microSD card in a reader/writer on a USB-C port, Win10 machine.

The map install suggests installation to C:\Program Files. Do they need to be installed elsewhere? Trying to open a map directly into BaseCamp isn't working either. When I point Basecamp to the folder where the installed files reside, it sees nothing.

The micro SD card was initially installed in my GPSmap 64SX, and BaseCamp accurately showed 2 drives, one SD card and one GPSmap 64. When the map install failed, I reformatted the SD card to see if that would help - it didn't.

Thoughts are welcome!


Quote from: LostNoMore on August 28, 2021, 06:32:00 PMTrying to open a map directly into BaseCamp isn't working either. When I point Basecamp to the folder where the installed files reside, it sees nothing.

Basecamp doesn't work like that. You can't "open a map directly" or "point it to a folder". You should run the installer for the map. That's all you need to do. See step 3 of the tutorial here

After running the installer, the name of the map should appear in the dropdown menu such as "Arizona Topo" in this example.

If the name of the map is not shown in the menu, something is wrong with the installer. But make sure Basecamp is not open when you install the map, if it is then you won't see the map name until you quit and re-open Basecamp.

Also, make sure you are using the newest version of Basecamp, there is an older version that does not work with most of the maps on this site.


No idea why, but BaseCamp just started seeing the maps, and succeeded in transferring to the micro SD card. However, with the card installed in the 64sx, Map Setup shows no additional maps...?

Sorry to be such a newb, I'm migrating to Garmin from a DeLorme PN40 which is a totally different animal. Thanks for any suggestions.


OK, I loaded 3 maps on the micro SD card. One is now visible to the 64sx and can be enabled. The other two are AWOL.


A variety of things might cause that, could be a problem with MapInstall, a conflict between maps from different authors, etc. Garmin devices also have a "tile limit" that is completely unrelated to the size of the map in megabytes. It is about 4000 on most newer devices, old devices are typically around 2000 tiles. You will hit that limit LONG before filling a 32gb card. Typically, around 4gb of maps will max it out, but there is no standard tile size so you can't generalize.

Try these two programs, the author stopped development due to health problems so they may have compatibility issues unfortunately. But they are very helpful at diagnosing problems. They will show you the number of tiles.


My efforts to install 3 GPSFileDepot maps directly to the 32gb micro SD card in a reader/writer had largely failed, except for 1 map which showed up in Map Setup with the card in the GPSr (still not sure it actually changed the displayed map when enabled).

This morning I connected the GRSr with the micro SD card installed and then tried to install one of the maps to the internal GPSr memory. This succeeded. Is this the process for installing maps? And if so, what good is the SD card?


You can install on the card or internal memory, it should work the same. Is your card formatted as FAT32? If not, then it will work in your computer but the GPS will not recognize it.


Well this is all very odd. I repeated my attempt to install a map to the SD card in a reader/writer and it succeeded. Seems like I need to do everything twice for it to stick. Regardless, good end result, thanks for your help!