General Category > Using The Maps/Garmin Software

Mississippi Topo for Garmin 35 Touch


Mississippi Garmin:
Just joined and installed the Mississippi Topo map to my new Garmin 35 Touch.  When tethered to the Garmin BaseCamp the map is there and all of the detail.  The garmin reflects the map is loaded and enabled.  However, none of the detail is shown. The garmin needed a software update and that was installed.  Any help would be appreciated.  If i am in the wrong sub forum please direct me to the correct one.  Thank you for your time!

Some troubleshooting ideas in this thread:

Mississippi Garmin:
Thank you for the response.  A little more info after reading the trouble shooting.

I installed on the internal storage and then tried the 1GB micro card. The BaseCamp installer is for Microsoft. Neither will show the map detail. It will state that the maps were successfully installed.  I uninstalled the maps on my PC and on the garmin.  The install using BaseCamp seem simple and steps worked like the examples.  The weird thing is, when the garmin is tethered to the PC the Mississippi Topo maps will NOT show up as a loaded file on the BaseCamp Explore window on the left.  That is the part that bothers me.  The map will show up on the Garmin Configure map page and is enabled.  Like I am not completing a task.  Plus, the memory on the garmin is hardly being used when the maps are "successfully" loaded.   Dazed and confused.

From the thread I linked to - you should be able to make the map on the GPS visible in Basecamp using Javawa Device Manager

--- Quote from: Boyd on August 16, 2020, 03:59:58 PM ---do you want to uninstall the map from your computer, but still be able to access it in Basecamp when the GPS is connected, like a "real" Garmin map? GPSFileDepot maps typically can't do that. But that other Javawa program can do this. There is a option called something like "visible in Basecamp" that you can set for each map with that program.

--- End quote ---

How large is the map file on the GPS? I'd suggest downloading a different map and see if that works. If so, maybe there's just a problem with the map you downloaded?

Sorted out your issue?


[0] Message Index

Go to full version