Welcome to GPSFileDepot!

Main Menu

Correct file format for Basecamp - etrex20x ?

Started by raferguson, September 11, 2020, 09:59:49 AM

Previous topic - Next topic


I am going around in circles trying to load the Nebraska topo onto my computer and Etrex20x.  I have Windows 10 with Basecamp. I downloaded the Nebraska topo as an exe file, and when executed it created the directory netopo11.   When I looked in the directory of netopo11 on my computer, there are a series of disk images.   I believe when I have loaded maps in the past, I got a single .img file.   Basecamp does not seem to know what to do with disk images, so I have not succeeded in getting the Nebraska topo onto Basecamp.   

Please tell me what I am missing.  Thanks.



It is not a "disk image". I know that Windows claims it is, but (unfortunately) there are more than one kind of .img file. In this case, .img files are Garmin-format maps.  :)

Not personally familiar with that map, but unless something is very wrong then Basecamp will "know what to do" with it but you are not looking in the right place. You should not be concerned with .img files and where they are stored, Basecamp handles all of that for you.

This tutorial may be a little out of date, but the basics are all there. You need to choose the map from the drop down menu, as shown in step 3 here

After verifying that the map is there, use this tutorial for installation.


No luck so far.   As you said, the tutorial does not match up very well with the current Basecamp.

When I clicked on "Maps" in the top line, it did not show the Nebraska Map.   I tried "Install Maps", but it said "No unlocked maps were found for this device."  Was I supposed to see the Nebraska map there?

I had tried earlier clicking on "File" and then "Import into my collection."  I found the directory, but it said "No items match your search."   C:\Program files (x86)\netopo11 is the directory.



You keep searching for files on the computer. That has nothing to do with how to use Garmin maps. Basecamp/Mapinstall should do everything for you. If that is not happening and you don't see the map in the dropdown menu then something must be wrong with the map or the installer. If that doesn't work, try a different map.

You don't "open" or "import" Garmin maps. The installer that you downloaded (.exe file) puts them in the right place for Garmin's software and you don't need to do aything else.

Why don't you try using Mapsource, Garmin's older software? It is much more straightforward and the tutotial is correct.


One other possible issue... if Basecamp was running when you installed the map, then it will not appear. Completely close Basecamp and open it again if that happens.