Welcome to GPSFileDepot!

Main Menu

Oregon 300 now giving 'memory full' message

Started by maps4gps, February 25, 2021, 08:06:35 AM

Previous topic - Next topic


I have hardly used my Oregon 300 in the past 6 years.  Last fall started making experimental layers with the current data from USGS, Census and OSM.  I did many hundreds of uploads to the Or300 using sendmap2; some without a custom type file, others with.  The .img file(s) were deleted from the Or300 after every one or two file were uploaded.  Three days ago I stated to get a 'memory full' message almost every time the Or300 was connect to my computer USB port.  Initially a file sent using sendmap2 was OK; then after a few uploads the Or300 would not show the file on the map select menu (it would show with the proper upload/build time using edge).  The Or300 now goes into USB access mode about 6-7 seconds after the 'memory full' message appears whether 'OK' is pressed or not.

There are no waypoints, tracks nor geocashes on the Or300 nor on the microSD card.  The OR300 has the Garmin basemap and the MicroSD has my state map from a decade ago.
Free space on the OR300 is 900Mb of 1Gb and on the microSD is 3.7Gb of 4.0Gb.  Neither removing the microSD card nor using another changes anything, nor does trying two other USB cables.  The 'memory full' message also appears when in 'battery mode'.  Also tried another computer, transferring the sendmap2 gmapsupp.img file via edge to the microSD and transferring other .img files made years ago - none work.

Any suggestions?
   Wore out unit?
   A corrupt file?  I have done a 'factory reinstall' twice.


Sounds like you have checked everything out. I had an Oregon 400t (same series as your 300) but gave it to a friend many years ago. It was a great unit in its day, but the screen was just terrible and processor really slow.

Only other thing that occurs to me is whether you have used it with a Macintosh, because that will create invisible files that can fill the memory. I'm assuming that isn't the case, since you are seeing so much free space. I also wonder exactly what "memory" means in that error message. Could it be a problem with the device's RAM instead of flash memory? Or perhaps the NVRAM that isn't user-accessible and holds the system firmware?

The segment limit could be a problem, IIRC that device has a limit of 4000 map tiles total (including internal memory and card). If you have removed all the maps, I don't see how that could be an issue however.

I'd say it's time to give it a decent burial and move on.  :(


Check all folders for GPX files.

If not the Mac issue give it a master reset.  That should fix the issue.


Using Windows 10 on a dedicated laptop not connected to the web (nor having and updates for the past 1 1/2 years).  By 'wore out unit' I was thinking that 12 years ago when the Or300 was new thumb drives were often not lasting much more than a year, so maybe the Or300's internal memory might be failing. 

Definitely not a segment limit as the data map file and test 8 x 16 square polygon file are each only one 'segment'.  Many maps with 10's to 100's of map segments each were removed  before starting testing with the new data last fall.  Each of the new files was removed before starting on the next test.

There is an .xml file on the Or300 whose file date gets changed to the most recent time the unit was turned on.  I have not checked it for internal changes.  There did not appear to be anything in it related to the maximum number of 'uploads' the unit might be limited to.   
The recent testing has been mostly on the test polygon file assigning different RGB color codes to the different mp_types (Garmin feature codes) to determine usable shades of color on the unit.   I am working on a geologic map of a 2x1 degree area.  The paper maps have more than 150 different units, each in a different shade of color.  No way to get that many on the OR300 and even less easily distinguishable in outdoor changeable lighting.  At times I have been using sendmap2 to combine the .img and changed .typ file and send the result to the micoSD card on the Or300 as many as fifty+ times a day.  Thus the 'question' of a hidden install limit on the unit(s)?

In 'battery mode' the OR300 will display the 'dashboard' after pressing 'OK option' on  the  'Memory Full screen'.  The topo map on the microSD card and the Garmin world map and an early version of the geologic map (with polygons and lines) on the OR300's internal memory can be display.  No additional map .img file (nor a .gpx file) added to either will display.

Thanks for the info and stay safe.



Used the Windows command prompt window and used the attrib command to check the root folder and all subfolders on the Or300 and the microSD card - no .gpx file anywhere. 
There is a small hidden file in the Or300's Garmin folder named fs_image.ver with a data back in 2009.  Found a second .xml file in the Garmin folder, system.xml (22285 bytes) and GarminDevice.xml (10244 bytes), both have the file date of the most recent time the Or300 was turned on.

I did another 'Setup' - 'Reset' - 'Restore Defaults To Factory Settings' .  Factory settings were again restored to when the Or300 was new; however still have the 'memory full' message on startup, then goes into USB mode if the USB cable is connect; and does not recognize any .img map file sent via sendmap2 nor transferred via Microsoft Edge.
Is the 'master reset' you suggest different than the RDtoFS I have done?  If so how do I do it?



I assume you also have the newest firmware as this was known problem with early firmware.


A firmware update and master reset fixed the 'Memory Full' message.
While in mass storage mode, files can now be upload and be displayed on the GPSr.

However, the unit is still going directly into mass storage mode when the USB cable in plugged into a computer USB port.  No screen with 'USB cable detected  - do you want to go into mass storage mode - Yes/No ?'  I have again tried three cables, on various USB ports on two computers.  The Or300 does go to the dashboard screen when plugged into the automobile USB port.

I will try calling Garmin on Monday if a solution is not be found by then.  It appears that at the cost of a few AA batteries I can continue to develop my multicolored geologic map and reference topo data.

Thanks for your help and suggestions


There is a setting on the unit to go directly to mass storage mode or to ask. You need to change that setting.


That fixed it.   In trying to solve the 'memory full' issue I had not noticed that doing a 'Reset' / 'Restore Defaults to Factory Settings'  changed the 'System' /Interface' to 'Garmin Serial'.

Many thanks.