Topo maps don't work anymore on my Garmin GPSMAP 62s

Started by jomadaFIN, October 07, 2019, 04:14:29 AM

Previous topic - Next topic


I'm having a really strange problem that I've tried to solve for quite a while now. I have six years old GPSMAP 62s and all that time it has worked perfectly. For some reason, some time ago I temporarily removed the topo map (that had come with the SD-card) from the memory card. When putting it back, it didn't work anymore, and neither would any other map that worked before. It doesn't help to install the map to the actual device instead of the SD-card. It doesn't help changing the SD-card. It doesn't help master resetting the device. GPX-waypoints still work normally. I'm working on Mac if that gives any necessary info.

Can you guys help me out with this, I'm really confused and quite upset already?


Are talking about a "real" Garmin map? Those should never be removed from a card, they are copy protected. Theoretically you can remove the map and put it back on the same card, but various things might have gone wrong there. And that map will definitely not work on another card.

Also, on the Mac, be sure that your card is formatted as windows FAT-32.

Try copying your maps to internal memory on the GPS and see if they work. If so, then there problem has to do with the card.


Thanks for the reply. Copying maps (old or new ones) to the internal memory doesn't help.

The probable copy protection was something I was thinking about afterwards. The weird thing is that it didn't cause only the protected map not to work, but the same goes with the free OSM maps I've always used when traveling abroad.

The internal memory is FAT-32 so it should work... The memory card (2GB) is FAT-16 but I'm unable to reformat that as FAT-32 (there is no such option when choosing format).


For protected Garmin maps, there should be three files. If the map file is named gmapsupp.img there should also be a file named gmapsupp.unl and gmapsupp.gma. If those two files are missing, the map won't work. But you should see an error message such as "can't unlock maps".

Maps should always work from internal memory. Try downloading another map as a test.
If this works, then perhaps you did something to corrupt the other maps that don't work?

[edit] I may have give the wrong impression above. 3rd party maps should always work in internal memory. Official Garmin maps in download format should also work. However, if you purchased a Garmin memory card with a pre-installed map, then that map will ONLY WORK ON THE ORIGINAL CARD. It will not work in internal memory.


Fair enough, it seems clear that the original map is corrupted forever since I don't have the other files.

That's perfectly fine if I just could get any other map to work. I mean I have downloaded dozens of new OSM maps and tried putting them on the SD-card, another SD-card or the internal memory, and nothing works out.

I won't get any error messages and the maps don't show up in the device in map settings either. I'm pretty sure the problem is in the device itself and I'm wondering if there is even deeper "reset" for that, than master reset.


A possible source of problems when using the Mac is the invisible MacOS files that are created. For example, if you copy a map to the card, then delete it on a Mac, it is not actually deleted, it's just moved to an invisible "trash" folder.

Try the free Javawa Device Manager program, it will ask if you want to delete these hidden files and also check for a variety of other problems.

There's also this small program from the same author, just for removing hidden files

The problems you describe don't sound like a hardware issue with the GPS.


Wow. Javawa Device Manager helped me to realize the map on the internal memory was saved in wrong folder and now it works!

No idea why they still don't work on the SD-card, but I don't care since I have now some maps back on my device. Finally, thanks a lot for help!!


Cool!  8)

SD cards can and do fail - I've had it happen to me more than once. And a 2gb card is certainly an antique. So you might try a new card (do NOT get a 64gb card). Another possibility is that the contacts are corroded or damaged on the GPS, so you should look carefully at these.