Welcome to GPSFileDepot!

Main Menu

GPS60CSx Loading Maps But Maps Dont Work

Started by ozarque, May 28, 2019, 07:20:45 PM

Previous topic - Next topic


I have a Garmin 60CSX that used to work fine with topo maps I made and loaded onto it from gpsfiledepot/mapsource/basecamp. Then I did a manual cleanup of some of the small files "cluttering " up the internal memory. Now even though I can easily load maps onto the GPS and they can be selected in map setup, they do not work. and I did not back up. I updated firmware but no help. Have I deleted some required supporting files?


The 60csx doesn't have any "internal memory", maps are stored on a micro SD card. But it sounds like you have the same problem as everyone else. The current version of Basecamp/MapInstall just doesn't work. This has been discussed extensively - Garmin broke the software a year ago, and then discontinued it. They don't care about the problem.

But there are ways to get around it. The simplest is to just use Mapsource, Garmin's old software. This is really what you should use with an old device like the 60csx anyway. The other solution is to downgrade to an old version of Basecamp/MapInstall.

See this thread:


I will try that, but i have older maps that were created in the old Mapsource software and they do not work any more either.

When using the BaseCamp software, I see the GPS data storage and it shows two different directories of which one is the SD card and the other appears to be an internal memory of the GPS60CSX. That is where I did the seemingly bad deletions of important files.

SO, there are no necessary files held in the GPS60csx?

The problem is not loading the maps, but that they don't work after loading..


There's no user-accessible internal memory on the 60csx - I have one too and the screenshot below is what I see in Basecamp. The things that are shown in "internal storage" are just your user data (waypoints, tracks, routes), there are no system files. These aren't "files" at all, it is data that Basecamp retrieves from the device using Garmin's old protocol.

The 60csx is not like newer Garmin devices, it is not file-based. Everything that is needed to operate the GPS is included in the firmware. There's just nothing that you can do to mess with that - either it works, or it doesn't. ;)

So I have no idea what might be wrong, maybe a problem with your memory card? Is it formatted as FAT32? Maybe try a different card? How large is the card? There are limits to how big a card these old devices can use.

There are also limits to how many map segments you can access. If you load too many maps, some of them won't work. This is actually very restrictive, so if you have a bunch of maps loaded, try removing all but one and see if that works.


Boyd is correct.  I have a 60csx and have been trying for two days to load portions of the map of California using BaseCamp to no avail.  After reading this post, I tried it with MapSource and it worked!  Now if I can just figure out a way of loading multiple maps at once on the SD card.  ;D


Quote from: GLN on June 04, 2019, 08:34:02 AM
Now if I can just figure out a way of loading multiple maps at once on the SD card.  ;D

You choose all of the map tiles you want first and then send them to the GPS.