Welcome to GPSFileDepot!

Main Menu

GPSMAP 60CSx advice...

Started by synclavier, March 17, 2019, 12:11:21 AM

Previous topic - Next topic


OK Folks...

I have a Garmin GPSMAP 60CSx. This post is for other 60CSx owners who need to load a topo map like I did. Hopefully, I can spare you an entire day of trial-and-error, web scouring, video-watching, manual reading, map-loading and hair-pulling, if you're having the same problems I've had.

I have literally spent a day and a half trying to get a basic topo map loaded onto this thing. I tried to load a Tennessee Topo map from this site, which seemed to load properly, except there were never any contour lines, trails, POI's, or secondary roads displayed on the GPS.


I would advise you to use MAPSOURCE instead of BASECAMP. This difference is basically what did the trick. I did everything else (firmware updates on the 60CSx, updates for Basecamp, map updates, etc...). After I downloaded Mapsource, all of my maps I had downloaded were already populated in the drop-down menus (a nice tidbit). I clicked on the map sections I wanted to load from the main map, selected my device, hit the transfer button and waited with baited breath. VOILA! I don't know why it worked, and I frankly don't give a rats'. I just know it worked.

Good Lordy, what a melodrama this has been. I got it, though...  ;)


Glad you got it working. But if you just read through some recent threads here you would have learned the problem is that MapInstall is broken and the current version cannot send a map to your gps properly. This problem has existed since Garmin's last update in May 2018, and now they have discontinued it. However, recently there has been a sign that they are going to do one final update to fix this problem.

See this thread for discussion of the issues:

And yes, Mapsource is the easiest fix IMO and that is the solution that I and others have been suggesting. I think Mapsource has always been the best software to use with an old device like the 60csx in fact.