Welcome to GPSFileDepot!

Main Menu

Mapwel and Garmin 66s

Started by Perry, February 03, 2019, 06:36:06 PM

Previous topic - Next topic


Here's some information for anyone potentially using Mapwel with a Garmin 66s.

I have Mapwel 2017 build 17.0 and a Garmin 66s.

In Mapwel I created a transparent map using my tracks.  I used File > Upload map to GPS.  In the upload dialog I checked the box to Add to existing maps.  That worked.  Later I decided that I did not want the two maps combined on the GPS.

I then used Tools > Erase Specific maps to remove the one I'd created in Mapwel.  That seemed to work.  But after that the GPS would not start.  It would initiate the startup process but then within a few seconds shut down.  The same thing happened when I tried to connect it to my PC.
My guess is that the 66s did not like something about the way Mapeel modified the gmapsupp.img file and refused to start.

Garmin support spent about an hour with me trying to get the GPS to function.  They ended up saying that I needed to return it for repair/exchange. 


The GPSMap 66 is evidently a very buggy new device, so I would not automatically assume that Mapwel was the problem. Some discussion of the problems here