Welcome to GPSFileDepot!

Main Menu

Topo Map loaded but won't display detail

Started by Lloyd S, September 03, 2018, 09:30:55 AM

Previous topic - Next topic

Lloyd S

Brand new here and obviously don't know what I'm doing.
- I have a Garmin GPSmap 76CSx.
- From this site, I downloaded the Arizona Topo map, and installed it on the device through BaseCamp, using the excellent tutorials here.
- From the "Setup map" "Information" page, I turned off all maps except "Arizona Topo 2, Arizona Topo, Sep 2018". (box is show WITH a check mark).
- On the Setup > Map > Max Zoom page, all are shown as "AUTO"
- The Setup > Map > Detail is set to "Most"

When I go to the Map page, I can zoom in to see the Arizona data OK, but no matter what zoom level I'm at, I never see the contour line details, which are readily apparent in the BaseCamp display.



Sounds like the same problem everyone is having. Just look, there are many threads here on this topic, but this is probably the best:

Basecamp will either auto-update or nag you forever to update (depending on your pref setting). And in May Garmin release a Basecamp/MapInstall update that simply doesn't work. Still an open question as to whether they were intentionally trying to prevent you from using third party maps, or if it's just a bug. Most likely, it's a bug but that doesn't help much since they appear to have no interest in correcting it.  >:(

The problem is exactly as you describe, everything seems to go fine but when you enable the map on the GPS there is no detail.

Lloyd S

OK, thanks Boyd.
Is it just the maps from GPSFileDepot that won't display detail?
I have a set of CDs of "MapSource United States TOPO" but I was hoping to just use the GPSFileDepot Arizona Topo map, as that's the only area I'm really interested in.

I guess I could try to load my CDs into BaseCamp if that's an option, and then transfer AZ to my unit IF they will display detail there.



I have seen inconsistent reports. Some people have said that you cannot send ANY maps from your computer to the GPS, including Garmin products. Others have said it's only third party maps. I have not tested it personally.

But the solution is very simple, as described in the link I posted. Just use Mapsource, that is the software that originally came with your old maps anyway. Or if you must use Basecamp, revert to an earlier version.

Lloyd S


Ok, here's my plan.
- I have MapSource on a different PC, not connected to the 'net
- I take this file aztopo_v3_install-1.exe and loaded to that PC and run it
- The map data will then be available in MapSource, same as it was available in BaseCamp
- I use MapSource to transfer AZ Topo to my GPSmap 76CSx

I assume I'll need to delete the existing AZ Topo (the one that won't show the detail) from the unit first.

Does that plan sound logical?
Thanks for your help!

Lloyd S

Well, my plan worked almost as expected.
I didn't have to delete the existing AZ Topo first because, as expected, the new data overwrote it.
Also, MapSource couldn't "see" the micro SD card in my GPS unit (which is where I wanted the new maps to reside), so I took the card out of the unit, inserted it into a card reader, then MapSource recognized it and transferred the map data to it.

So I'm now "good to go".
Thanks again for your help!


Great, glad it worked! Garmin should either fix this MapInstall problem or else admit that they just don't care.


I patched my firmware and blew my warranty, unlocked my commercial map product, which is legitimately purchased (Australia & NZ Topo V5) because Garmin's site consumed the product key, but it didn't actually unlock the maps for either viewing on the PC or using on my GPS.

I still don't know of a solution to get it working any other way.

Furthermore, I registered on Garmin's forum to get help, and the registration worked.
My nickname is in the top right hand corner when I'm logged in and all, but I can't post threads
in any forum section to ask for help :rolleyes:

Furthermore, Garmin's phone service hours are business hours, so how does that work if you have a job?

I remember telling myself ten years ago when I was way into GPS and hiking, to avoid using Garmin's Windows software as far as possible.
If anything has changed since then, I think it's gotten worse.