MapInstall 4.2 (May 2018 update) won't install third party maps

Started by 93ToyTruck, June 09, 2018, 10:21:38 PM

Previous topic - Next topic


I'm trying to analyse exactly what is happening.

As I understand it, Registry-based maps show correctly in Basecamp but lose detail when installed on the device.

Garmin provide a converter to make GMAP from Registry-based files - and JaVaWa offer one too (which works for me).

If Basecamp installs GMAP files correctly then the conversion is a simple way to get round this issue. Or am I missing something?


I think that is right, but am not interested in testing Garmin's broken software so I don't know for sure. And it's expecting a lot for a user to figure that out.

But - regardless - this problem has existed for a year now, and there is no mention of it here at GPSFileDepot, except from users like us who discuss it in the forum. So, somebody comes here, downloads a map, follows all the instructions, and then it doesn't work. Not a very good user experience IMO....


I just updated/uploaded the 2019 version of my Montana topo maps as a (zipped) compiled .img file with the MS version set to "0" in the header. This way the user can get the maps loaded onto their device/card AND view them in BaseCamp. I put a text instruction file in the zip folder.

What's wrong with this approach? Why would anyone feel the desire to use clunky BaseCamp to transfer the maps to their device? I just market it as a "better" way to download and install maps (drag-n-drop map files), cutting out the broken, tedious software middleman. Dragging and dropping a map file onto an SD card is easier for luddites than installing through BaseCamp anyway.


I agree. The main attraction of using Mapsource/MapInstall is that you can choose the exact portion of the map you want to send to the device. This was important when GPS units had small amounts of memory. Today.... not so much.

By "MS version set to 0", do you mean that this enables the map to be seen in Basecamp when the GPS (or a flash drive) is connected to the computer? I think that is rather limiting, I prefer to have the map permanently installed so that it can be accessed all the time in both Mapsource and Basecamp. So I provide both options with my own maps.


Yeah, setting the MS version to "0" allows BaseCamp to read the map files from the GPS. The process takes a while since Garmin has never really gotten the USB transfer protocols right.

You're right, it does limit the user to some degree. Thanks to you and a map user who was having trouble waiting for the map files to transfer into BaseCamp via the GPS, I've decided to offer installers (with the "wow6432node" removed from the registry values) so users don't have to go through the pain of connecting the device to their computers. I'll provide a strong disclaimer not to use the installed version to transfer maps to the device. I want those who use my maps to have as pleasant experience as possible given the circumstances Garmin forces developers to deal with. I don't spend weeks and weeks updating and tweaking my maps each year just to have users frustrated with their functionality.

Best regards


So, I just came across this problem this week. Although it's typically my mode to NOT install updates arbitrarily, I did allow BaseCamp to update never knowing I'd have an issue with 3rd party maps.

So, worked my way around the Net, and finally came across this thread. Big shoutout to Boyd for your detailed instructions. It was a huge help.

I uninstalled BaseCamp, Mapsource and MapInstall. Then tried to install BaseCamp 4.6.2. Still had the issue, so I uninstalled and went with version 4.5.2. Worked like a charm and now my maps can be previewed on my Garmin handhelds.

Thanks to all the others who've posted with their suggestions too!


Glad you finally got it working. FWIW, there was no reason to uninstall Mapsource. That program was discontinued long ago and it still works fine.


It seems, the new version 4.2.1 MapInstall (October 30, 2019) in Basecamp  4.7.1 works correctly.


Wow! Garmin actually updated Basecamp? If so... good for them! Took them a long time, but at least they fiinally fixed this major problem.


Hi Everyone, new forum member here but long time user of GPSFileDepot files. I'm having this same problem loading the GPSFileDepot NE USA Topo map to my Rino 650.

My info: BaseCamp Version 4.7.2, Windows 10 Pro.

My question: should I use the mapsource solution found in this thread even though the last couple of posts indicate the 4.7.2 Basecamp fixes the problem?

The reason I'm trying to use the Rino is that I lost my Montana 650 out of my motorcycle sidecase last weekend.  :'( Yes, I'm curretly going through the grieving process but have reached the acceptance stage. I'm reviewing options for how to move forward but in the meantime, I pulled my Rino out as an interim gps solution.   

Background: I've had this NE USA Topo map downloaded/installed for about 8 years, on a progression of pc's, and it displays in Basecamp without a gps connected. I had reviously installed it to my Montana 650 memory card, and to the Rino 650 memory card, but don't see the map now. Actually, I recall that I couldn't see it on the Montana recently. I may have updated the Montana before I noticed the issue. I did update the Rino upon pressing it into service this past weekend.

So, I pulled the memory card and tried to reinstall the map to the Rino 650 units memory using Basecamp. It takes about 15 minutes to install, returns a message that the map was installed successfully, but the topo and roads don't show even though I've enabled it on the unit. I do see hydrologic data but don't know what the source of that is. After not seeing the map on the unit, I deleted the file from the unit and reinstalled, but still don't see the map.

I went for an adventure motorcycle ride following some uploaded tracks, and between the tracks and my iphone I was able to navigate successfully. But this takes me back to the old days in the nineties when a gps would show you where you were on the screen but without the benefit of a basemap!

I'm open to any suggestions, thanks much.


Not familiar with this problem and don't use that map. But I wonder if it could be related to the GPS firmware? Do you know how recently you updated the device? It is possible to download old firmware here and downgrade if needed.

You might also try using Javawa's tools to see if they find any problems. Unfortunately, he has stopped development of these excellent programs due to health problems.

Aside from that, I don't see any reason not to try using Mapsource. If it doesn't work, that would imply the problem is related to the device firmware.


Thanks for the quick response, Boyd. 

I did update the Rino upon pressing it into service this past weekend, so the device firmware is current.

I'll give the Mapsource a shot and see what happens. I never worked with the Mapsource, jumped right into Basecamp when it became available. It will be interesting to see if the Mapsource will install with Windows 10 Pro.

Thanks much.


FYI: I was unsuccessful using the MapSource.  To repeat, the GPSFileDepot map: NE USA Topo roads and contours will not display on my Rino 650 per my message above.

This is what I did:
1) I downloaded/installed the MapSource 6163 per the instructions above. The installed MapSource 6163 (Help > About Mapsource > MapSource Version 6.16.3) does recognize all the maps I have on the pc in BaseCamp including: 1) Global Map; 2) City Navigator; 3) NE USA Topo Parts 1, 2 & 3; 4) Topo Canada V4.
2) I referenced the MapSource Tutorial: selected about half of the map segments (ME to the PA-OH border), received the message that the data was successfully sent.
3) the device shows a "gmapsupp.img" file with todays date/time of size 336,856 KB n the Garmin folder.
4) disconnected the device from the PC and powered it up.
5) in Setup > Map > Select Map > choose to "Enable" the Map. Exit out to the main menu.
6)  in Map, zoom to about a 500 ft display level. I can see the Hydro data displayed, i.e.: Lakes, Ponds, Rivers, Marshes. I can see waypoints and tracks. But, no roads or contours.

For those not familiar with the GPSFileDepot NE USA Topo map, it is a non-routeable map consisting of roads, contours, etc., possibly compiled from DEM data or a similar source. It's been a great basemap for use when off-road. I've used it for several years with my Montana 650 and this Rino 650, but it does not display on the device now.

Perhaps it's a lost cause trying to use this great map some 10+ years after it was developed. My next step is to contact Garmin Tech Support to see if they will allow an install of the City Navigator to this unit because of the loss of the licensed version on the lost Montana...


You did not try my suggestion to downgrade the firmware on your Rino. Since you know the map file is there, and you have reason to believe that it used to work, then this suggests incompatibility with newer firmware. Connect your Rino and see if you can find a file named gupdate.gcd. This would be the installer from the most recent firmware update. Copy this file to your computer for a backup, then delete it from the GPS (this file is no longer needed after installing the firmware). The gupdate.gcd file will probably be in the Garmin folder on the Rino, but this may vary on different devices.

Now find and download the previous version of the firmware here

Change the name of the downloaded file to gupdate.gcd, copy it to the same location as the old installer, disconnect the device and restart it. Make sure you have good batteries in the device, or connect it to external power. If the GPS batteries die during a firmware update, it could "brick" your GPS.

It will probably tell you that you're trying to install an older version of the firmware and ask whether you want to continue. After the update completes, see if the map works.

If not... well, maybe that old map just isn't compatible with your GPS. Good luck getting Garmin to move your City Navigator map, I'd be surprised if they did this but it never hurts to ask. Typically, they would only allow this if you also purchased a replacement for the lost GPS directly from them.