MapInstall 4.2 (May 2018 update) won't install third party maps

Started by 93ToyTruck, June 09, 2018, 10:21:38 PM

Previous topic - Next topic


On May 22/23, Garmin released updates for Basecamp and MapInstall. There's a bug in the new software that prevents third party maps from being installed.  It wasn't intentional, they just didn't test for it.

The solution is to uninstall Basecamp 4.7 and MapInstall 4.2, then install a previous version of the apps. Both apps need to be uninstalled. If you update to BaseCamp 4.7, it breaks the older version of MapInstall.

After you install MapInstall, you need to turn off automatic updates.

BaseCamp 4.2.5 can be downloaded from Garmin here
I couldn't find a download page for 4.6.2 or an older version of MapInstall. I have version 4.0.4 and it worked for me.  Does anybody know where they can be downloaded from?


Some related threads:

As noted by zhrd, there is an archive of pretty much all of Garmin's software and firmware here. Anyone who owns a Garmin product should bookmark this site! :)


Thanks for sharing. got my unit yesterday and have been basically cursing up a storm and bashing my head against the wall trying to find out why i could not load maps at all for about 3 hours! then low and behold i luckily found the forums!
Thanks So much. Hoping by downloading this i can now load my maps so i can get out and learn my etrex before my big trek.

Edit. Downloaded the Beta 4.2.04 and still cant load any maps from this site.


The links in my post above should provide info on where to find old versions of Basecamp and MapInstall. But one more time....

Windows software is archived here:

Mac software is archived here:

Why were you using the beta version? The broken version is dated May 2018. Try one of the previous versions from 2016 if you are on Windows.

On the Mac, I'm not sure if the same problem exists. If so, then you will need to download both Basecamp and MapInstall/MapManager - they are separate files.


Boyd, i was up until 3am messing with it so i think thats where the Beta version came in. Finally got one of the old ones to load and work. Had to use Basecamp 452 from the list. Finally am getting maps loaded on my 30x. the reason it takes so long for me is I am at the end of the data stream so its basically one step above dial up. Tried 462. My system didnt like it for some reason. Thanks for all the help! bookmarked this page and downloaded some of the list and put it on a portable HDD and a stick. Not going through this again  :)


The problem doesn't exist on Mac. I had my friend test it with the updated versions of BaseCamp and MapInstall/MapManager.


What's the latest good version of MapSource that still works with 3rd party maps?
MapSource_6163.exe ?
I can't figure out the versioning convention.


AFAIK the final version of Mapsource is the one that's still available on Garmin's website:

Garmin made some changes to map rendering style quite awhile ago, and some "old timers" used to prefer the old version. But it's really old, and if you go back too far Mapsource will not recognize newer .gmap maps. A number of maps are GPSFileDepot (including mine) are provided as .gmap files.

I can't think of any reason not to use the version in my link above. Garmin discontinued mapsource in 2011 and does not support it anymore. However, IMO they will continue making it available because Basecamp does not support their older products that have RS232 serial ports.


Ah, OK, thanks! That's what I figured. MapSource software version 6.16.3 which is has an installer with the file name MapSource_6163.exe


I created an account just to say thank you!  I was struggling for hours to understand why my GPSMap 64s wasn't showing any detail.  I even went as far as resetting the device.  I just wish I found this thread sooner!


Everybody impacted by this issue should submit a support request to Garmin. They aren't going to fix it unless customers demand it.


After performing some testing, this is what I have learned:

MapInstall 4.0.4 will work fine with BaseCamp 4.7 installed. It just needs to be installed after BaseCamp 4.7 because...

BaseCamp 4.7 installs MapInstall 4.2.  It doesn't update the Windows program list with uninstaller details for MapInstall 4.2. The only way to get rid of 4.2 is to delete the "C:\Program Files (x86)\Garmin\MapInstall" directory. (The BaseCamp 4.7 installer doesn't update any registry information for MapInstall 4.2).

MapInstall 4.2 standalone installer does update the Windows program list with uninstaller details BUT it does not delete any files when the uninstaller is run. You must run the uninstaller to remove registry details then manually delete the "C:\Program Files (x86)\Garmin\MapInstall" directory. If you only delete the directory, the 4.0.4 installer throws an error when it sees the 4.2 registry values.

To roll back to 4.0.4 from 4.2:
1) Open the Windows program list and look for Garmin MapInstall 4.2. If it's there, run the uninstaller.
2) Delete the "C:\Program Files (x86)\Garmin\MapInstall" directory.
3) Run MapInstall 4.0.4 installer.


Thank you a lot for disposing your time to explain the procedures and the links!
Its a shame Garmin treat the users like that. but thanckfully the comunity is there!

I downgraded Basecamp and mapsource with the procedures and now I can install my maps again!

:) :D ;D 8)