Welcome to GPSFileDepot!

Main Menu

Downloaded Map Not Complete

Started by pilotdane, June 01, 2018, 07:19:39 AM

Previous topic - Next topic


Garmin Oregon 600

I have downloaded a map for Alaska from GPS File Depot.  The map on the GPS File Depot website is titled Alaska Topo and the file name for the map is mti_ak.  Unfortunately this forum will not allow me to link to the site so it's   www dot

I download and installation this map onto my Oregon using Base Camp and the download and install seemed to work properly with no errors.  I have all other maps in my Oregon disabled and only the new map mti_ak active.  When I zoom in on Alaska in my Garmin there is almost no data there.  Just extremely crude map data for Alaska.  When I view the mti_ak map in Base Camp all the data and detail is there.  Any idea what I have done wrong with this map?

When installing the file I select "customize" and Base Camp default shows a partial install of 1.36 mb.  I change it to "full install" and is shows a install of 252 mb.  But the installation goes way to fast and only 1.36 mb ends up installed on my Oregon???


Quote from: pilotdane on June 01, 2018, 07:19:39 AMI have all other maps in my Oregon disabled and only the new map mti_ak active.

How many other maps are installed on your Oregon? If you have a bunch, it's possible that you've exceeded the segment limit. See my final post in this thread:


Quote from: pilotdane on June 01, 2018, 07:19:39 AMBut the installation goes way to fast and only 1.36 mb ends up installed on my Oregon???
Isn't it the recent BaseCamp/MapInstall at work?

If you have installed BaseCamp 4.70, then downgrade it to previous version, it will transfer maps to GPS correctly (You will return to version, which sends reports to Garmin though).


There have been several other posts here that imply there's a problem with the newest version of MapInstall. See this for another possible solution:


Thank you for the replies.

I only have a couple maps saved on my Oregon.  There is 1.8 gig free on the Garmin and 3.8 free on the removable card.

I tried Map Source and I can view the map on my computer but get an error that I must select a map before I can upload it to my device.  In the upper left I can select mti_ak map and view it.  I can even save the map with another name but cannot find a way to select it for uploading to my Oregon.  I can find no way to get mti_ak or any map to appear in the big box with the map tab.

I have been trying with Base Camp 4.7.  I uninstalled 4.7 and found version beta.  A few words of caution.  Going under the device tab and selecting "send to device" didn't work as I could never find a way to select the map.  But... it does work if you go under the maps tab and select "install maps".  The install proceeded at the pace I expected and the map got onto my Oregon properly.

Thank you for everyone's help.


Turns out that there is a known problem with the current version of Basecamp/MapInstall. See this thread on Garmin's support forum:

Mapsource works fine but you did not understand how to use it. You must use the map tool (the icon that looks like a polygon with a yellow outline) to select the area of the map that you want to send to the GPS. See this GPSFileDepot tutorial:

You actually don't need BaseCamp at all to install maps, that is done with a separate program called MapInstall. When you select a map to install in Basecamp, it just transfers you to MapInstall. I wrote some instructions for using MapInstall by itself here:


Just got hit with this. Any idea where to find older versions of BaseCamp/MapInstall? Other solutions?



Solution that worked for me, using old version of mapinstall with new version of basecamp

1. Install old version of basecamp.
2. Go into the C:\Program Files (x86)\Garmin directory and change de MapInstall directory name
3. Install new version of BaseCamp
4. Go back to C:\Program Files (x86)\Garmin and delete new MapInstall directory.
rename directory form step 2 back to MapInstall

Now you will be using the new BaseCamp but when you go to install maps it will be using the old MapInstall version

It worked for me!!!!


Garmin needs to fix this, it's a disgrace. It has been almost a year since they broke MapInstall.