Welcome, Guest. Please login or register.

Login with username, password and session length
Forums Search:  


Author Topic: Maps on MicroSD card will not show up on eTrex20  (Read 912 times)

purplebird7

  • Jr. Member
  • **
  • Posts: 5
  • Karma: 0
    • View Profile
Maps on MicroSD card will not show up on eTrex20
« on: February 03, 2017, 08:35:17 PM »
I downloaded and installed more than 40 state topo maps from this website - thank you very much!  All of them appear in BaseCamp under the Maps tab on my PC running Windows 7.

From BaseCamp, I transferred as many maps as I could to my eTrex20.  It filled 2.39 GB out of  3.63 GB of internal memory before it ran out of enough space for another complete map.  All of these maps appear in the eTrex20 under Menu>Setup Map>Map Information Select Map where they can be enabled or disabled. 

I  bought a 32GB Sandisk Ultra PLUS Micro SDHC card from Best Buy.  The rest of the maps transferred to this card, using 6.21 GB of the 29.7 GB of space.  The process created a folder on the card named Garmin which contains the maps and a document named Id.txt.  The Garmin folder also contains a folder named GPX which is empty.

None of the maps on the MicroSD card appear on the eTrex20 under Setup Map>Map Information Select Map.

Any suggestions?  I searched the Knowledge Base here, but most people had the problem of using a 64 GB cards that was solved by reformatting it to FAT32.  That is not the case for me because my 32 GB card is already supposed to be FAT32.  One of the answers suggested that the user copy the GarminDevice.xml file to the MicroSD card, which I tried, but it failed to make the maps appear. 




Boyd

  • Expert Advisor
  • *****
  • Posts: 3530
  • Karma: 38
    • View Profile
Re: Maps on MicroSD card will not show up on eTrex20
« Reply #1 on: February 04, 2017, 04:45:05 AM »
Not clear on what your exact problem is, but what you are trying to accomplish is not going to work anyway. Garmin's devices have an important limitation that is not very well known. It relates to the number of segments in a map - the smaller tiles that make up the whole map.

Your GPS can only access a total of 4000 map segments. This limit is completely unrelated to the size in megabytes/gigabytes. There are no standards for how much area a segment covers, that is up to the mapmaker. So it's impossible to generalize about how many maps you can load before hitting the limit. However, there is no way that 40 topos are going to work on the GPS. The segment limit applies to all maps that you have installed on the card and internal memory, it doesn't matter whether or not you enable the maps on the GPS.

There is just no point in using a 32gb card for maps in an eTrex. You will probably hit the limit somewhere between 4gb and 8gb of maps. Garmin does not make it very easy to determine how many segments you have loaded unfortunately. I don't use Basecamp very often and can't recall whether it will tell you this when you use MapInstall. You could use Garmin's older Mapsource software though, it will show the total number of segments when you select an area on a map.

If you try to load too many segments, bad things will happen. It is specific to the maps you are using, so again you cannot generalize. To troubleshoot, you could go back to your original 2.39gb collection of maps and start adding one at a time to see if it works. Like I said, you will probably hit problems somewhere after installing 4gb or so.
« Last Edit: February 04, 2017, 04:46:48 AM by Boyd »

purplebird7

  • Jr. Member
  • **
  • Posts: 5
  • Karma: 0
    • View Profile
Re: Maps on MicroSD card will not show up on eTrex20
« Reply #2 on: February 04, 2017, 08:06:36 AM »
A limit on the number of segments?  You're right:  That certainly isn't well-known.  Thank you for that information.

I also have talkytoaster's British Contours map in the eTrex20 internal memory.  Perhaps it pushed the limit on segments.   Let me move it to the MicroSD card and see if that helps. 

Do I understand this correctly?  If the maps in internal memory on the device don't exceed the limit for segments (or size) then the maps on the MicroSD card SHOULD be visible and accessible on the device.

Please correct me if I assume wrongly.  Otherwise, what is the use for a MicroSD card if the eTrex20 must be connected to BaseCamp on a computer to change maps that don't fit into its internal memory?

Question:  Does Garmin design their US topo maps (24K or 100K) sold by region in a such way that all of the regions in the US are able to appear on the device at the same time?




 
 


Boyd

  • Expert Advisor
  • *****
  • Posts: 3530
  • Karma: 38
    • View Profile
Re: Maps on MicroSD card will not show up on eTrex20
« Reply #3 on: February 04, 2017, 04:45:49 PM »
Sorry, you don't have it quite right. It doesn't matter whether you have installed maps in internal memory, a card or both. The segment limit applies to all maps regardless of where you put them. So the problem is that you have too many maps, moving them to a card makes no difference.

The US 24k topos are an even bigger problem. In most cases, you cannot even load two of those products without hitting the segment limit. We had a thread where some somebody was very upset to learn this because they had spent like $600 on Garmin's 24k topos.

Usually when you exceed the limit some maps don't show or portions of them are blank. It's a bit strange that nothing shows from your card. But maybe you already exceeded the limit with the map in internal memory?

You might try Garmin's older Mapsource program (Windows only), it will show the number of segments in each map if you select them all.

purplebird7

  • Jr. Member
  • **
  • Posts: 5
  • Karma: 0
    • View Profile
Re: Maps on MicroSD card will not show up on eTrex20
« Reply #4 on: February 04, 2017, 10:44:17 PM »
I cleared all maps from internal memory (except for the Global map that came with the device).  I also cleared all maps from the MicroSD card. 

I successfully installed one map from my PC onto the internal drive using MapInstall, which clearly did not exceed any size or segment limits.  I moved another small map onto the MicroSC card, but the eTrex could not access it.  MapInstall will only move maps onto the card is if the internal memory of the device is already too full.

So, what is the purpose of having a MicroSD card when all maps must be installed on the internal memory of the device?



Boyd

  • Expert Advisor
  • *****
  • Posts: 3530
  • Karma: 38
    • View Profile
Re: Maps on MicroSD card will not show up on eTrex20
« Reply #5 on: February 05, 2017, 03:42:50 AM »
You said "my 32 GB card is already supposed to be FAT32". Do you know for a fact that it is formatted as FAT32? Because what you describe would be caused by a card that is formatted with another filesystem.

Not sure what is going on, it should not matter whether you put a map on the card or internal memory. The eTrex should treat them exactly the same.

Is there a directory named Garmin at the root level of the card? If not then create one and copy the map file from internal memory to that folder. Now delete the map from internal memory. Does that work?

Hard to tell what is going on here, but this is clearly not the way the eTrex is supposed to work.

purplebird7

  • Jr. Member
  • **
  • Posts: 5
  • Karma: 0
    • View Profile
Re: Maps on MicroSD card will not show up on eTrex20
« Reply #6 on: February 05, 2017, 06:03:02 AM »
Thank you, Boyd, for hanging in there with me on this.  Of course, this is not how the eTrex is supposed to act.  Garmin SELLS maps on MicroSD cards.  The device is able to access them!

Just as I was ready to give up, I think I figured out what is going on.  Allow me to explain the strange procedure:

I removed the MicroSD card from the device, placed it in a card reader plugged into my PC, and verified that it is formatted FAT32 and has no errors.  No problem with the card.

As a last resort, I put five state maps on internal memory using BaseCamp, and then I added the British Contours map (by talkytoaster) to internal memory via drag-and-drop onto the drive.  I felt as though I could settle for this arrangement  if nothing else worked.

As one last try, I added an OpenStreetMap of the UK to the MicroSD card using drag-and-drop to the drive.  Success!  For the first time, the eTrex was able to access this map from MicroSD and list it in MapSetup>Select Map to enable or disable.

Out of curiosity, I looked into the drives and here is where it gets STRANGE:

The internal memory still contained five state maps, but these same maps got duplicated (automatically) onto the MicroSD card!  I deleted them.  Also, the OpenStreetMap got automatically moved from the MicroSD card to the eTrex internal memory!  Thinking, "Oh, that is why the device could read it," I deleted it.   

I could not stop troubleshooting at this point...

I put the OpenStreetMap back on the MicroSD card.  This time, everything worked as it should:  The eTrex accessed the card, none of the state maps got duplicated, and the OpenStreetMap didn't get moved to internal memory.

Finally, I opened BaseCamp and MapInstall to make sure the eTrex internal memory was represented correctly. 

(I was afraid to breathe on the eTrex at this point.)

So, happy ending.  Boyd, your original suggestion is good:  Remove all maps (except the one that came with the unit) from internal memory and the MicroSD card.  Start loading maps ONE AT A TIME.  Now, KEEP CHECKING the drives to see where the maps go.  Delete or move any maps that end up in the wrong places or are inaccessible.  Keep segment limits in mind, and don't overload either the internal memory or the card.  MapInstall is bossy about where the files go.

Why is this process so glitchy?  My guess is that Garmin never intended anyone to make and install maps of their own.  :)

I hope anyone who has problems with their eTrex will be helped by this thread. 




« Last Edit: February 05, 2017, 09:13:53 AM by purplebird7 »

 

anything