Downloaded map not showing up in BaseCamp - solution Win 10

Started by shimniok, February 06, 2017, 05:45:08 PM

Previous topic - Next topic


In case anyone else is running into issues with a downloaded map not appearing in BaseCamp, here's what worked for me, and an explanation of what is going on under the hood.

Problem: After downloading and installing Colorado Topo 2011 map, BaseCamp did not see the newly installed map listed. My computer is Windows 10, 64 bit. BaseCamp version 4.6.2.

Cause: the cotopo11 installer is broken and does not insert registry keys where BaseCamp expects them*, which is in:


After installing the My Trails map from this site, I found a key, "My Trails" appearing under the Families key. The values and subkey define file locations for this map. No such key appeared corresponding to cotopo11.

Disclaimer: mucking with regedit is dangerous and could wreck your computer.

Using the My Trails hierarchy as a pattern, I created a cotopo11 key. It looks like this:

cotopo11 (Key)
˪ Default (String Value) left as "value not set"
˪ ID (Binary) I didn't know what value to put in so I guessed--more on this in a sec
˪ TYP (String Value) contains the full path to the TYP file
˪ 1 (Key)

Under the 1 key:
1 (key)
˪ BMAP (String Value) full path of the main img file e.g., cotopo11.img
˪ LOC (String Value) full path containing the many img files, the TYP, TDB, etc.
˪ TDB (String Value) full path to the TDB file

In my case, LOC was set to C:\Program Files (x86)\cotopo11; TYP was set to that same path + 12286.TYP, TDB set to path + cotopo11.tdb; BMAP = path + cotopo11.img.

But the maps won't load in BaseCamp until the ID is corrected.

An easy way to fix this is to download and run (as someone suggested), JaVaWa software. It should find your new map registry keys and notify you that the ID doesn't match the one in the map database. Simply click the new map in the list and click the repair (+) button to fix the bad ID.

After doing this, BaseCamp saw my new map just fine.

The harder way would be to find the ID in the TDB file using a hex editor (HxD, etc.), at bytes 5 and 6. In cotopo11.tdb, those bytes are 68 and 22. You would enter them into the binary ID value as 68 22.

I tried the Utah Topo 2011 map. In the uttopo11.tdb, bytes 5 and 6 were 91 and 22, respectively, and the ID in the registry was set to: 91 22. Though I didn't enter the ID manually (and in fact uttopo11 installed and appeared in basecamp with no intervention), I'm sure this would work.

* I later found that the cotopo11 installer is broken because it creates the registry keys under:
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\WOW6432Node\Garmin\MapSource\Families\cotopo11 -- note the duplicate WOW6432Node key. Oops.


I'm using Javawa map convertor and distributing maps as .gmap folder that go into
/programdata/garmin/maps with no need for registry entries.


For a number of years I have urged mapmakers to switch to Garmin's new gmap format which does not use the registry. I have had very little success in convincing others to do this. ;)

The problem that @shimniok describes is well known here. Many mapmakers used an installer script template that broke when Windows 7 64 bit was introduced. That script was eventually updated, but there are still many old map with this issue.

However there's a really easy fix that does not require messing with the registry. Simply install a newer map (any map) that has an installer without this problem. For example, uninstall the problem map and just install this map:

You don't actually need to "use" this map, just install it. It will create the needed registry keys, and after that you can install any of the "broken" maps and they will work. In other words, after you have installed one "good" map, all the "bad" maps will work properly. :)


Quote from: Boyd on February 07, 2017, 04:52:35 AM
For a number of years I have urged mapmakers to switch to Garmin's new gmap format which does not use the registry. I have had very little success in convincing others to do this. ;)

I think there was even an additional advantage at that time that was never mentioned.
*However*, as I understood it at the time, there would have been an additional step PC users would need to do on there own, unless someone with the necessary programing skills found a way to include it).  Since no-one did and about 90% of my mapset downloads were PC versions (with some even having trouble installing a working 32-bit .exe file) it did not seam user friendly change to me.   


Quote from: maps4gps on February 15, 2017, 05:09:18 PM*However*, as I understood it at the time, there would have been an additional step PC users would need to do on there own

Not sure what you are getting at here. PC users just had to double-click an installer - the same as with a registry based map. Now there was the "extra step" that the map was distributed in a .zip file and the user had to un-zip it, then click the installer. I don't think that would be a problem for most people. :)


With OZ's installer for the registry being about 130+- lines long and having no understanding of installers, etc., it was something I was hoping someone would make available - which did not happen. 

Agreed, for most people likely not.  We did have a few that had problems simply clicking on the .exe file and using the defaults.  Even one or two the kept insisting the install process should be done the way they wanted and not how Garmin required it - and helping those can take a lot of time away from creating/updating mapsets.


For me, the main advantage for gmap format is that it works on Mac. And installation process is as easy/complicated as on Windows. In both cases it needs manual unpacking. Is there any better way to support both system with single installer?


I'm wondering if something similar happened to me. I had nhtopo11 and a few other GPSFileDepot maps installed in basecamp. I grabbed the OSM for Northeast and installed it. Now basecamp does not see any of my maps even after I removed OSM map. I'm going to try the JaVaWa software and see if it finds any errors. Everything was fine until I installed that map. Thanks for posting your info.