Welcome, Guest. Please login or register.

Login with username, password and session length
Forums Search:  


Author Topic: NSIS Compile Error  (Read 2398 times)

Mrbamboo

  • Jr. Member
  • **
  • Posts: 7
  • Karma: 0
    • View Profile
NSIS Compile Error
« on: June 24, 2016, 01:08:52 PM »
I have downloaded the new template and edited the info including converting and flipping my 4100 family id, and got an error just like below.  I then copied the files from the release folder to E:\Maptemp folder and still received the same error.

   Processing script file: "E:\Maptemp\map_install_x64-x86.nsi"
   Invalid command: ;--------------------------------
   Error in script "E:\Maptemp\map_install_x64-x86.nsi" on line 1 -- aborting creation process


To me line 1 is a comment line, but somehow it is not reading it like one.  I am using the most current version of the nsi file and version 2.3 of the Makensisw compiler.  What am I doing wrong?

I am running Windows 10, and the first line is ;------------------------

I tried deleting the first line and is still gave me this error

   Processing script file: "E:\Maptemp\map_install_x64-x86.nsi"
   Invalid command: ;
   Error in script "E:\Maptemp\map_install_x64-x86.nsi" on line 1 -- aborting creation process



« Last Edit: June 27, 2016, 07:06:12 AM by Mrbamboo »

kc

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
Re: NSIS Compile Error
« Reply #1 on: July 07, 2016, 08:43:13 AM »
Hiya, did you manage to solve this issue? I'm having the same problem and would like to know how this was resolved.

Many thanks

popej

  • Expert Advisor
  • *****
  • Posts: 332
  • Karma: 30
    • View Profile
Re: NSIS Compile Error
« Reply #2 on: July 07, 2016, 06:00:21 PM »
Looks like UTF-8 BOM at the beginning of the script. See for example:
http://wiki.simplemachines.org/smf/How_do_I_get_rid_of_a_Byte_Order_Mark

Mrbamboo

  • Jr. Member
  • **
  • Posts: 7
  • Karma: 0
    • View Profile
Re: NSIS Compile Error
« Reply #3 on: July 08, 2016, 06:19:32 AM »
Yes, I did find the issue,

 1. Download the NSIS compiler 3.01-rc-1 (earlier versions have the error)
 2. Turn off all virus scanners (I also disconnected from the net.)

I also found that it did not register correctly for mapshare (Basecamp), so I am in the process of trying to duplicate the installation (registry entry's) that JaVaWa MapConverter uses when it converts and installs the maps.

Mrbamboo

GeoH

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
Re: NSIS Compile Error
« Reply #4 on: July 29, 2016, 05:33:24 AM »
Same issue, fixed by editing the script in Notepad ++ and changing the Encoding to UTF-8 vs UTF-8-BOM and saving it out.

 

anything