Welcome, Guest. Please login or register.

Login with username, password and session length
Forums Search:  


Author Topic: Questions regarding Part 9 Setup Files  (Read 4534 times)

vt.flatlander

  • Mapper
  • ***
  • Posts: 79
  • Karma: 2
    • View Profile
Questions regarding Part 9 Setup Files
« on: March 11, 2016, 08:11:47 AM »
I'm making my way through the final step of my first map and need some guidance.

 I'm unsure about how to address MAP_URL,MAP_EMAIL,MAP_COPYRIGHT ?

For the time being I left the default info as is and tried to compile the setup files but I received an error:
Processing script file: "C:\MapTemp\map_install_x64-x86.nsi"
Invalid command: ;--------------------------------
Error in script "C:\MapTemp\map_install_x64-x86.nsi" on line 1 -- aborting creation process.

I moved all the files to a more Root location as suggested (C:\MapTemp\ if it didn't compile the first time-which it did not) but it still did not work ?
« Last Edit: March 11, 2016, 12:35:33 PM by vt.flatlander »

-Oz-

  • Map Maker!
  • Administrator
  • Expert Advisor
  • *****
  • Posts: 1577
  • Karma: 27
    • View Profile
    • GPSFileDepot
Re: Questions regarding Part 9 Setup Files
« Reply #1 on: March 11, 2016, 08:39:27 PM »
What does line 1 say. It seems like the nsi file was opened in something like Microsoft word rather than notepad and it added formatting.

The map URL should be where it'll be posted (like here) the email and copyright should be you.
Dan Blomberg
Administrator - GPSFileDepot
GPS Units: Garmin Dakota 20, Garmin GPSMap 60csx, Nuvi 255W, Nuvi 250W, ForeRunner 110, Fenix 2, Tactix Bravo, Foretrex 401
See/Download My Maps!

vt.flatlander

  • Mapper
  • ***
  • Posts: 79
  • Karma: 2
    • View Profile
Re: Questions regarding Part 9 Setup Files
« Reply #2 on: March 12, 2016, 05:27:01 AM »
As you can see line one is a semi colon followed but a string of dashes ;-----------------------------------
I cannot tell where these other three incorrect characters ()are coming from in the Invalid command statement.
The map_install_x64-x86.nsi file automatically opens in Notepad.
When I reopen the file it looks exactly like it should on line one. One semi colon followed by the dashes.

Also if it has any bearing I am using NSIS 2.5
« Last Edit: March 12, 2016, 05:49:25 AM by vt.flatlander »

-Oz-

  • Map Maker!
  • Administrator
  • Expert Advisor
  • *****
  • Posts: 1577
  • Karma: 27
    • View Profile
    • GPSFileDepot
Re: Questions regarding Part 9 Setup Files
« Reply #3 on: March 12, 2016, 06:22:35 AM »
Just try deleting line 1 completely and see if it compiles
Dan Blomberg
Administrator - GPSFileDepot
GPS Units: Garmin Dakota 20, Garmin GPSMap 60csx, Nuvi 255W, Nuvi 250W, ForeRunner 110, Fenix 2, Tactix Bravo, Foretrex 401
See/Download My Maps!

vt.flatlander

  • Mapper
  • ***
  • Posts: 79
  • Karma: 2
    • View Profile
Re: Questions regarding Part 9 Setup Files
« Reply #4 on: March 12, 2016, 08:09:46 AM »
Deleted line one but the error now is Invalid command :   line one. These three characters I cannot seem to be rid of? ?

-Oz-

  • Map Maker!
  • Administrator
  • Expert Advisor
  • *****
  • Posts: 1577
  • Karma: 27
    • View Profile
    • GPSFileDepot
Re: Questions regarding Part 9 Setup Files
« Reply #5 on: March 12, 2016, 12:06:54 PM »
Create a new text file and copy and paste all the content into it. Save that then rename it as a .nsi file and try to compile. It sounds like an encoding error. I'd attach a new one but I can't do it from this device so that won't be until Monday.
Dan Blomberg
Administrator - GPSFileDepot
GPS Units: Garmin Dakota 20, Garmin GPSMap 60csx, Nuvi 255W, Nuvi 250W, ForeRunner 110, Fenix 2, Tactix Bravo, Foretrex 401
See/Download My Maps!

vt.flatlander

  • Mapper
  • ***
  • Posts: 79
  • Karma: 2
    • View Profile
Re: Questions regarding Part 9 Setup Files
« Reply #6 on: March 12, 2016, 02:49:29 PM »
Used Notepad++ to make the copy. This time I did not drag and drop the .nsi file into the NSIS window but rather clicked File,Load Script.... It then worked.
Thank you for your assistance.
Moving forward......

-Oz-

  • Map Maker!
  • Administrator
  • Expert Advisor
  • *****
  • Posts: 1577
  • Karma: 27
    • View Profile
    • GPSFileDepot
Re: Questions regarding Part 9 Setup Files
« Reply #7 on: March 15, 2016, 06:43:49 PM »
Note: There is a new map install file. You definitely want to re-compile with the new version. Updated version here.
Dan Blomberg
Administrator - GPSFileDepot
GPS Units: Garmin Dakota 20, Garmin GPSMap 60csx, Nuvi 255W, Nuvi 250W, ForeRunner 110, Fenix 2, Tactix Bravo, Foretrex 401
See/Download My Maps!

vt.flatlander

  • Mapper
  • ***
  • Posts: 79
  • Karma: 2
    • View Profile
Re: Questions regarding Part 9 Setup Files
« Reply #8 on: March 18, 2016, 07:24:38 AM »
Thanks  Dan
I will give this a go.



   

vt.flatlander

  • Mapper
  • ***
  • Posts: 79
  • Karma: 2
    • View Profile
Re: Questions regarding Part 9 Setup Files
« Reply #9 on: March 22, 2016, 06:35:56 AM »
Dan
Just to let you know running the new map install files resulted in the same line one error I was having before.

Indrid Cold

  • Moderator
  • Expert Advisor
  • *****
  • Posts: 919
  • Karma: 20
    • View Profile
Re: Questions regarding Part 9 Setup Files
« Reply #10 on: March 22, 2016, 09:47:24 PM »
Deleted line one but the error now is Invalid command :   line one. These three characters I cannot seem to be rid of? ?
that is a BOM for UTF-8 in CP1252.

http://stackoverflow.com/questions/1755958/how-can-i-remove-the-bom-from-xmltextwriter-using-c

-Oz-

  • Map Maker!
  • Administrator
  • Expert Advisor
  • *****
  • Posts: 1577
  • Karma: 27
    • View Profile
    • GPSFileDepot
Re: Questions regarding Part 9 Setup Files
« Reply #11 on: March 24, 2016, 06:03:14 PM »
It is still whatever you are opening it in most likely? I open and edit all these nsi files in notepad++. If you copy/past it to a new text document it should go away.
Dan Blomberg
Administrator - GPSFileDepot
GPS Units: Garmin Dakota 20, Garmin GPSMap 60csx, Nuvi 255W, Nuvi 250W, ForeRunner 110, Fenix 2, Tactix Bravo, Foretrex 401
See/Download My Maps!

vt.flatlander

  • Mapper
  • ***
  • Posts: 79
  • Karma: 2
    • View Profile
Re: Questions regarding Part 9 Setup Files
« Reply #12 on: March 25, 2016, 05:06:04 PM »
Down-loaded the setup template files to my Downloads folder.
 Right clicked then "extracted all" to the folder where my map is located.
Opened the file with Notepad++. Made the appropriate edits and saved the file. Opended NSIS and ran the script. Same error. Line one.
 I reopened the script, Clicked Edit-Select all,Control C to copy. Then opened another Notepad++ window clicked Edit-Paste. Saved as a copy in the same folder as original.
Ran the script copy. Now I get an error that it cannot find the license.txt file located in c:gps_map.
So I create a folder named gps_map in C directory then move the license.txt created by MapsetToolkit to that folder.
Ran the set-up script again. Now it completes and puts the install.exe in my release folder.
I test the .exe set up which loads the files to the C directory: Program Files(x86) by default.
Opened BaseCamp --No map ??? Looked in C:Program Files(x86) and my Vermont Topo files are there.
Wish I knew how to figure out what I'm doing wrong here.
Included is a copy of the result of the install script in Notepad
« Last Edit: March 26, 2016, 07:43:18 AM by vt.flatlander »

-Oz-

  • Map Maker!
  • Administrator
  • Expert Advisor
  • *****
  • Posts: 1577
  • Karma: 27
    • View Profile
    • GPSFileDepot
Re: Questions regarding Part 9 Setup Files
« Reply #13 on: March 26, 2016, 12:31:04 PM »
Open regedit  (start>run>regedit or on windows 10 just hit start then type regedit

Now bury down to: HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Garmin\Mapsource\Families\Vermont Topo

Is it there? If so, does is have ID as 2B03? Now go on more "folder" (called 1) and make sure BMAP, LOC, and TBD (if you have it) are all pointing at the right location.  This would also be a good time to make sure Vermont Topo isn't the only thing in the families folder.

Let me know the status of that? Are you running Windows 10 64-bit?
Dan Blomberg
Administrator - GPSFileDepot
GPS Units: Garmin Dakota 20, Garmin GPSMap 60csx, Nuvi 255W, Nuvi 250W, ForeRunner 110, Fenix 2, Tactix Bravo, Foretrex 401
See/Download My Maps!

vt.flatlander

  • Mapper
  • ***
  • Posts: 79
  • Karma: 2
    • View Profile
Re: Questions regarding Part 9 Setup Files
« Reply #14 on: March 26, 2016, 04:57:41 PM »
Windows 7 Pro 64bit

Vermont Topo is there but the ID is 2b03 not 2B03.

BMAC and LOC is in folder"1" but no TBD

I have only one other map in the Families folder. It is an OSM generic routable .