Welcome to GPSFileDepot!

Main Menu

Etrex 20x not displaying Arizona Topo

Started by SL, June 22, 2018, 01:13:26 PM

Previous topic - Next topic


Help please.  I am trying to use the Arizona Topo on a Garmin Etrex 20x.  I cannot get it to display.  I even uninstalled it from BaseCamp and reinstalled prior to uploading it to the 20x.  I have had it installed on my Etrex 20 for years without issue.  I just cannot make it work on  this 20x.  I would appreciate any help with this issue.  I am just trying to load the map into Internal Memory as it will be the only map used on the 20x.  TIA


Most likely this is the same bug in Garmin's software that is affecting many people. The newest version of Basecamp (4.7) and MapInstall (4.2) are broken and will not install third party maps. See this:


I tried to download and install an earlier version of BaseCamp  and am seeing a window that says Install Failure.  I am getting very much frustrated.  I am also no longer able to open BaseCamp on my computer either. 


Don't know, have not tried this myself. But did you read the last post in the thread I linked to? It discusses the proper way to uninstall Basecamp/MapInstall.

But since this is the same map you have on your eTrex 20, why not just copy the map file to the 20x?

Or you could use Mapsource, as discussed in that thread.

And it would be a good idea to express your frustation to Garmin. ;)


TY I will reread your post.  This stuff is not my forte'.  I am a gold prospector and need this to work and I do not want to lose all my accumulated data on Base


Quote from: SL on June 22, 2018, 04:59:12 PMI do not want to lose all my accumulated data on Basecamp

The best insurance for that is to make sure you have multiple backup copies of BOTH your computer AND GPS units. :)


TY all for the assist.  I somehow managed to get it working again without losing my data.  so now I am backing up, the 20 and 20x as suggested.  Many thanks for the help