Welcome to GPSFileDepot!

Main Menu

Garmin Montana 610, Basecamp, can't load US Topo Maps (Garmin)

Started by n2stitch, December 12, 2015, 06:43:12 AM

Previous topic - Next topic


I have a new Garmin Montana 610.  Previously I had a 60CSx and then one of the Oregon units, I forget which.  I've always used Mapsource to transfer data back and forth, no problem.  Obviously, newer units don't talk to Mapsource the same so I bit the bullet and installed Basecamp (hate it).

Basecamp and Mapsource both show all of my maps, which includes Garmin's US Topo (100k) plus several custom maps from this site and that I've made myself.  I can load all of my custom maps to the Montana, but not any of the US Topo.  I've tried several times.  The only thing I haven't tried is a partial load of just some segments instead of an entire region (ie East or West).

Am I running into a map segment limitation?  The file sizes are all well under 4 GB.  I'm installing them to the micro SD card, which is 32 GB.  Total maps if all are selected (including full US Topo East, West, Alaska, and Hawaii) is about 3 GB.

I'm not very knowledgeable but I find it ironic that the only product that I can't get to work with a Garmin unit is the Garmin map product!



The Montana has a limit of about 4000 map segments according to this:

Actually, that surprises me. I have a Montana 600 and always thought the limit was 3000 segments. Maybe they changed this with newer firmware? Anyway, IIRC, the old topo US 2008 had something like 4500 total segments, so it still wouldn't all fit. And the segment limit includes the total of ALL maps on the device, not a single map. So if you have loaded other maps, you will not be able to use as much of the US Topo map.

FWIW, you can still use Mapsource to manage the maps on your Montana, it's fully compatible. You can also use it to send waypoints, etc to the Montana. The incompatibility is in the way the newer models store waypoints. They are stored in multiple files - a new file is created each day that you use the device. Mapsource doesn't know where to find these files, so "receive from device" will not find your tracks, waypoints and routes. Aside from that, go ahead and use Mapsource if you prefer.

Each time you send a map from Mapsource to the Montana, it will be named gmapsupp.img. Change the name of that file to something descriptive, like georgiatopo.img, then send the next map and repeat as needed until all your maps are installed.

BTW, Garmin has a new version of the 100k topo maps that have been squeezed into something like 400 segments IIRC. I believe that is what you get if you purchase by download. The old version with 4500 segments was created to be compatible with really old devices... remember when internal memory was measured in MB instead of GB? :)


Thank you so much for that very helpful information!  Now that you mention it, I do recall hearing about the "new" 100k Topo and it being less segments.  I'm out of the loop these days -  I took about a 3 year hiatus from hiking and horseback riding (got my master's degree and some family health issues), but I'm going to start back up.  The 24k maps from this site have always been very good, so I may not bother with the Garmin ones.

FYI, I looked at the file structure and the latest MapInstaller through Basecamp did actually send each map as it's own img file.  For instance, motopo was installed as motopo.img. 

Thanks again!


Yes, mapinstall will create separate files if it can determine that your GPS supports that. Otherwise it will create a gmapsupp.img file. For example, if you used a memory card in USB reader, that's what it would do because it wouldn't know what type of GPS you had.


AHA! :) That makes sense then.  I could have used a card reader, but I just let it run overnight while I was sleeping, so I left the card in the GPS. 

Thanks again for your help.


Interesting, but I also just bought a Montana 610 and I just tried to load 3 maps on it, with a total of 637 segments.  I loaded portions of garmins SW 24k topo and W 24k topo, plus the Desert Southwest topo from here (gpsfiledepot).  I was using my Mapsource.  Everything appeared to be going well during the loading, with success message after each download.  Now,  I went to the gps and went to enable the maps, and none of them appear on the enabled/disabled list.  There were several maps enabled, but most were world maps that I would rather not have enabled.  I disabled all the maps that showed as enabled, but still none of the three maps I just loaded show up on the enabled/disabled list.

Where to go from here?



I have found that the old Mapsource techniques of sending multiple maps often doesn't work correctly with newer devices. With the old technique, you choose the portions of all the maps you want and then send them all together. This creates a single file named gmapsupp.img that contains multiple maps. This seems to confuse newer devices for some reason.

If you want to use mapsource with your Montana, use the method I described above:

Each time you send a map from Mapsource to the Montana, it will be named gmapsupp.img. Change the name of that file to something descriptive, like georgiatopo.img, then send the next map and repeat as needed until all your maps are installed.