Welcome to GPSFileDepot!

Main Menu

Route-able data issues

Started by dleblanc2546, January 12, 2016, 02:36:01 PM

Previous topic - Next topic


So after much consultation with other members of this forum, issues with programs and personal effort, I have another issue with generating route-able map data for newer and older model Nuvi units.   >:(

I am currently using a route-able version of cGPSmapper, Sendmap20, SDLock and GPSMapEdit to generate mapping data for a Nuvi 700 series.  And it works great.  BUT, when I try to put the same data on a Nuvi 1000 series, after editing the information before generating data, it won't read my data.  So I tried a new direction to solve my new issue.

After asking questions and getting feedback I downloaded Mapsource, MapsetToolkit, and another version of cgpsmapper (for solution issues).

"Now" when I try to use the MapsetToolkit to change my .img file to a .tbd file, to open with Mapsource, it tells me that I have to use the GMapTool program, so I then downloaded gmaptool.  Now it tells me I have a locked map so checked my source data against the new file I'm trying to create.  I matched the FID thinking that maybe this could be the issue but to no avail it won't budge.

Please, I know this looks like a catastrophe, so I can try to clarify more, but can someone help me untie this knot I've created for myself.

Feeling kind of at wits end so to speak.  I believe I am over complicating the heck out of this.

Thanks in advance.


There is not much reason for nuvi 1xxx to behave differently than nuvi 7xx, maybe you use wrong directory for your map? Try \Map on nuvi 1xxx

IMHO proper toolchain is following:
- GPSMapEdit to edit your data (not exclusive, many other tools too),
- cGPSmapper to compile maps,
- cpreview (part of cGPSmapper) to create mapset,
- regedit to install map for BaseCamp/MapInstall
- cgpsmapperKey to create unlock key for BaseCamp/MapInstall
- MapInstall to create img for device or SD,
- SDLock to create protection on SD card.

Some of these task are a bit complicated, when done manually. This is where tools like MapSetToolKit or GMapTool can help. For example MapSetToolKit is good to install a map for BaseCamp, but you better know, what it is doing in registry. to use it correctly.

A good source of information is cGPSmapper manual.


So I downloaded the manual and found a bunch of useful information I was unaware of before.  Thank you.

I have gotten everything to work all the way til I finished creating the mapset with MapsetToolkit but now I cannot open the find a file that Mapsource will open.  I tried the .mp, .tbd. and .img files but I keep getting the message saying none of these file formats are supported by Mapsource.

A little more confusion on my end.  Thank you for your patience.


You don't "open" maps in Mapsource. MapsetToolkit installs the maps and they should then be available on the dropdown menu in Mapsource. If your map doesn't appear on the dropdown menu, it's not properly installed.


It worked!

Thanks guys.

But I made this version after compiling the image without the data being locked.  When I lock the file, compile an .img then process it through MapsetToolkit I get an error message and it tells me I need to unlock it through a website?  I have a program to unlock the data but it won't let me use that one to open the newly created image.  Any ideas or suggestions about this issue?


You should unlock map for BaseCamp and Mapsource. Use tool from BaseCamp or Mapsource, menu Maps (Utilities in Mapsource) -> Manage Map Products...

Got to tab "Unlock Regions" and use button "Add" to insert unlock code for your map. It can be any valid unlock key that you can generate for your map with cGPSmapper tools.

A note: Mapsource is a discontinued product which contains some bugs, some related to routing on maps created with cGPSmapper. These bugs are corrected in BaseCamp, which works correctly. While Mapsource can be very handy for developing, I suggest you to recommend only BaseCamp to users of your map.