Welcome to GPSFileDepot!

Main Menu

GPSFileDepot Map Breaks Basecamp

Started by PhotoMechanic, July 12, 2015, 02:06:39 PM

Previous topic - Next topic


I've got a Windows 8.1 ultrabook, and I had installed Basecamp and was starting to download maps for my Oregon 600.  I went to GPSFileDepot and picked NJ Topo, and I didn't notice a warning that the installer caused a problem.  Well, I should have!  When I ran the installer everything looked OK but the result was that Basecamp would not run, even when the map was uninstalled and when Basecamp was uninstalled and reinstalled.  I had to run system restore to get things back.


Which map? Almost 2500 downloads and no complaints with my New Jersey topo: . Am working on a major update now, and I also have a number of other NJ maps available:

You probably would not have needed to do a system restore to fix things, there are some utility programs that help to manage maps. Next time you have a problem, try running GMTK, it can diagnose and often automatically fix map problems:

Guessing that this is the map you installed:

The issue with that map should not have caused any problems with Basecamp crashing (unless this is a new glitch with a basecamp update). The only issue there is that the map may not show up in Basecamp. Have not seen any other reports of it causing a crash. My guess is that your download may have been corrupted, we see that kind of problem from time to time. Could also have been a corrupt download of Basecamp, have seen that problem before also.


That looks like the map.  WHat happened was that once I installed that map, Basecamp didn't load when it was clicked on.  There was a flash of some message and then nothing.  This is the latest Basecamp off the Garmin site, Windows 8.1 64-bit ultrabook.  I uninstalled the map and Basecamp and reinstalled basecamp, and it didn't fix the problem.  Only Restore got Basecamp back.  It's possible there's something quirky in the new release or even with this particular computer (Lenovo Yoga 2 Intel I7) but it will take a bit of time for me to diagnose this further.  I had a problem with the Southern Africa map from the site too, but that was after I'd already had an issue (and thought I'd fixed it) with NJ.  I'm going to try to sneak up on this and set restore points at verifiably good places so I don't lose any regular work.


You can interact directly with the Basecamp developers on Garmin's support forum:

If you contacted Garmin support directly, I'm sure they would just tell you that they don't support GPSFileDepot maps. However things are a bit more informal on their forum and many people seem to find help there.


Yesterday I was able to load the Africa map from this site (through a third-party source) and this time I didn't use the batch-file install but instead did a manual install of the directory with the maps, as the site owner suggested.  That seemed to work fine.

The problem with Basecamp always shows up as a Windows Application Error Event on a .NET module.  I can try the Basecamp forums as you suggest.  Thanks!