Welcome to GPSFileDepot!

Main Menu


Started by bghon, May 21, 2015, 02:09:45 PM

Previous topic - Next topic


I'm trying to download basecamp, mapsource and even the my trails map and when I click on the links, I get the following error message every time "This WebPage is Not Available  ERR_CONNECTION_RESET  The connection to ... was interrupted.
Check your Internet connection
Check any cables and reboot any routers, modems, or other network devices you may be using.
Allow Chrome to access the network in your firewall or antivirus settings.
If it is already listed as a program allowed to access the network, try removing it from the list and adding it again.
If you use a proxy server...
Check your proxy settings or contact your network administrator to make sure the proxy server is working. If you don't believe you should be using a proxy server: Go to Applications > System Preferences > Network > Advanced > Proxies and deselect any proxies that have been selected."  My internet connection is fine as it's working on all other pages.  I have my firewall turned off and I'm not using a proxy server.  Any suggestions????


Just to be clear.... here is the link to download Basecamp directly from Garmin

What happens when you click on this? Do you get the same errors? If so, there is definitely something wrong on your end. Sorry, I don't use Chrome, so no idea what might be wrong there. But I have never heard any other reports of this kind of problem downloading Garmin software, either here or on several other GPS related websites that I frequent.


Yes I get the same message.  I tried to open the link in Safari but I got this message "Safari can't open the page bc the server unexpectedly dropped the connection. This sometimes occurs when the server is busy.Wait a few  minutes and try again." I've tried several times and it still won't open?


So you are on a Mac? I have no problems opening that link in Safari on my Mac and the download starts right up.

BTW, you mentioned Mapsource earlier. That is a Windows program that won't run on the Mac. The link I posted was also for the Windows version of Basecamp. This is the Mac version of Basecamp.

I don't think the issue has anything to do with Garmin or GPSFileDepot, it is some kind of issue with your computer or internet connection. However, I would suggest posting to Garmin's Mac Basecamp support forum. You are more likely to find help there than here...


I attached a screen shot of the error message I'm getting.  I get the message if I use Chrome OR Safari.  I don't see how it can be an Internet issue bc I can load other pages just fine but any link on GPS file depot won't load?

Indrid Cold

do a ping and traceroute for the site with the computer you are having issues with and post the results here. If you do not know how to do either, then provide us with the OS you are using and we will inform you how to do this.


Quote from: bghon on May 31, 2015, 06:45:27 PMI don't see how it can be an Internet issue bc I can load other pages just fine but any link on GPS file depot won't load?

Based on what you have said, that's not true. You couldn't download Basecamp using the link I posted above. That is a link to Garmin's site and has nothing to do with GPSFileDepot.


What anti virus are you running. Is it avast?  If so may want to try disabling that temporarily.
Dan Blomberg
Administrator - GPSFileDepot
GPS Units: Garmin Dakota 20, Garmin GPSMap 60csx, Nuvi 255W, Nuvi 250W, ForeRunner 110, Fenix 2, Tactix Bravo, Foretrex 401
See/Download My Maps!