Welcome, Guest. Please login or register.

Login with username, password and session length
Forums Search:  


Author Topic: Why do some .img layers make others not display  (Read 1895 times)

wicks_10

  • Jr. Member
  • **
  • Posts: 8
  • Karma: 0
    • View Profile
Why do some .img layers make others not display
« on: October 09, 2014, 08:28:33 AM »
I have been making a number of img files that when they are turned on, my OSM layer will not display. There is no overlap. It is like the OSM layer is just turned off. I am at a loss of what to do to fix this. Have played with draw priority, FID numbers, Transparency settings, etc. and still get nothing. It is not unique to lines or polygons either. A layer that is strictly one or the other will still do it. Hope someone around here has an idea. Thanks for your help.

popej

  • Expert Advisor
  • *****
  • Posts: 328
  • Karma: 29
    • View Profile
Re: Why do some .img layers make others not display
« Reply #1 on: October 09, 2014, 12:25:57 PM »
Do your maps have unique map ID? "ID" is a parameter from cgpsmapper mp format, for mkgmap this is "mapname".

wicks_10

  • Jr. Member
  • **
  • Posts: 8
  • Karma: 0
    • View Profile
Re: Why do some .img layers make others not display
« Reply #2 on: October 09, 2014, 04:50:59 PM »
I believe so if you are asking if they have a specified name that shows up under the layer list. I did come across something that has somewhat fixed it but has created a new problem. I am dealing with state wide date for the state of Utah. I have created a statewide land ownership layer with no issues but the layers that aren't working now are across the state but cover at most %10 of the state. When I broke the file into smaller sections by removing some polygons, the new file works fine. I am not sure why this is. Like I said, I have made the land ownership layer with no issues. Any ideas about this? I am using these programs in this order: Global Mapper, GPSMapedit (for proofing), cGPSmapper, TYPViewer, then compiling with Gmaptool.

popej

  • Expert Advisor
  • *****
  • Posts: 328
  • Karma: 29
    • View Profile
Re: Why do some .img layers make others not display
« Reply #3 on: October 10, 2014, 05:19:32 AM »
Map ID is a number assigned to each tile of a map. This should be unique for all maps you are using. If you export mp file form Global Mapper, then map ID is described as "Image ID". In GPSMapEdit you can view map ID in Files->Map properties->Header->ID.

I'm not sure if map ID is your problem. If you have repeated map ID in tiles, then GPS will show only one of these tiles and ignore duplicates.

Note: better use cpreview form cgpsmapper package instead of GMapTool to create a mapset for PC. You wil get a proper preview map and search index.

wicks_10

  • Jr. Member
  • **
  • Posts: 8
  • Karma: 0
    • View Profile
Re: Why do some .img layers make others not display
« Reply #4 on: October 16, 2014, 06:52:29 AM »
I checked map ID as well as changed it to other random number but still get the same issue. The layer shows but turns off the OSM layer. When I turn the layer off, the OSM layer displays again. I have played with about everything I can think of and still cant get it to work.
« Last Edit: October 16, 2014, 07:03:34 AM by wicks_10 »

 

anything