Welcome, Guest. Please login or register.

Login with username, password and session length
Forums Search:  


Author Topic: Help merging custom .typ file with .img  (Read 5938 times)

wicks_10

  • Jr. Member
  • **
  • Posts: 8
  • Karma: 0
    • View Profile
Help merging custom .typ file with .img
« on: September 11, 2014, 08:11:53 PM »
I am sure that this has been covered somewhere on these forms but I can't seems to find anything that can help me. So what I have is some mp/img files that I created with Global Mapper. These files are functioning on my Garmin but I want to use a custom typ file to use specific colors instead of the basic Garmin pallet. I think I have created the typ files correct and to verify I have loaded the mp files into gpsmapedit and loaded the typ file as a custom skin. Everything looks great but I cant get the changes in the typ file to merge with the image file. Any ideas on what I am doing wrong? I have tried to export the 2 files from gpsmapedit through cgpsmapper. I tried to make it work with mkgmap but I am bad with the cmd aspect so I cant get it to export a map. I looked to see if there was an option to do it in Global Mapper but cant see it. I would love to do everything in GM but am willing to do whatever I need to do. Any thoughts, ideas, step by step guides are appreciated. Thanks for the help.

popej

  • Expert Advisor
  • *****
  • Posts: 328
  • Karma: 29
    • View Profile
Re: Help merging custom .typ file with .img
« Reply #1 on: September 12, 2014, 12:01:51 AM »
GPSMapEdit uses skins as a text file. This kind of file should be compiled to create a valid TYP file for Garmin devices. Compilation could be done with many tools, including cgpsmapper and mkgmap. I prefer a dedicated tool for creating and editing of TYP files, it is TYPViewer:
https://sites.google.com/site/sherco40/

TYP file should have the same FID/PID numbers as your map.

To use TYP file in Mapsource or BaseCamp you should modify some keys in registry (or edit xml file in case of new "gmap" installation). This can be done with a tools like MapSetToolKit:
https://sites.google.com/site/cypherman1/

Merging or replacing a TYP file in img created for a device can be done with GMapTool:
http://www.gmaptool.eu/en/content/gmaptool


wicks_10

  • Jr. Member
  • **
  • Posts: 8
  • Karma: 0
    • View Profile
Re: Help merging custom .typ file with .img
« Reply #2 on: September 12, 2014, 05:09:46 AM »
Thanks for the info popej. I have used typviewer to make a text file as well as a compiled .typ file to merge. I didn't know that gpsmapedit would not compile the files on export. Problem #1 I guess. I did try to make it work with cgpsmapper and I believe I ran cmd correct so I am wondering if my fid/pid are not correct. I know where to change that in the .typ file but where do I change it or even find it on my .img files?

babj615

  • Expert Advisor
  • *****
  • Posts: 266
  • Karma: -4
  • The cache is a lie!
    • View Profile
    • Garmin Oregon 6xx Wiki
Re: Help merging custom .typ file with .img
« Reply #3 on: September 12, 2014, 05:29:09 AM »
Try googling 'TYPChanger'. :)
Garmin GPSMap 60cs, Dakota 20, Colorado 400t, Oregon 300/400t/450/550t/650/650t, Montana 650, Lowrance Endura Sierra, nuvi 3790, iPhone 3G/4/4s
Geocaching ID: Atlas Cached
OpenCaching.com Ambassador

popej

  • Expert Advisor
  • *****
  • Posts: 328
  • Karma: 29
    • View Profile
Re: Help merging custom .typ file with .img
« Reply #4 on: September 12, 2014, 06:53:27 AM »
I know where to change that in the .typ file but where do I change it or even find it on my .img files?
If you are compiling unlocked maps with cgpsmapper or mkgmap, then there is no FID/PID inside img. These values are added when installing maps on PC and then transferred to device.

For mkgmap FID/PID is an execution option (--family-id, --product-id). For cgpsmapper you add FID/PID inside configuration file for cpreview, see manual.


wicks_10

  • Jr. Member
  • **
  • Posts: 8
  • Karma: 0
    • View Profile
Re: Help merging custom .typ file with .img
« Reply #5 on: September 15, 2014, 07:55:54 PM »
Alright, so I have tried gmaptools and like the interface but I get an error when I try to do a change option to exchange the typ file in the img file. This is what I get. Any ideas about what header length not even means and how to fix it?

====================================================================

Write into selected maps.
Input file: G:/Garmin/Map_Data/Utah_LS_GM.typ.
Input file: C:/Users/Jolleys/Desktop/Utah_LS2.img.
Reading file G:/Garmin/Map_Data/Utah_LS_GM.typ.
Reading file C:/Users/Jolleys/Desktop/Utah_LS2.img.
Header length not even, file C:/Users/Jolleys/Desktop/Utah_LS2.img.
Write: data file G:/Garmin/Map_Data/Utah_LS_GM.typ.

== Warning: typ file was not replaced.

Write: map file C:/Users/Jolleys/Desktop/Utah_LS2.img.

There were warnings, result can be faulty.

popej

  • Expert Advisor
  • *****
  • Posts: 328
  • Karma: 29
    • View Profile
Re: Help merging custom .typ file with .img
« Reply #6 on: September 15, 2014, 08:20:31 PM »
TYP file is replaced only when FID/PID for new and old TYP are the same.

You can find FID/PID numbers with command "Info" on file tab. And you can change FID/PID inside TYP file using "Write" tab and option "Correct TYP".

If there is no TYP file inside img, then use "Join" tab to merge img with a TYP file.

wicks_10

  • Jr. Member
  • **
  • Posts: 8
  • Karma: 0
    • View Profile
Re: Help merging custom .typ file with .img
« Reply #7 on: September 16, 2014, 06:44:33 PM »
Thanks for the help. I got it to work but have a new problem that probably just needs some simple explaining. I have 3 layers I want to use. One is an OSM street layer with a draw priority 20. The next layer I want displayed is a contour line file that is transparent with a draw priority of 16. The last layer that I want on top is a land ownership layer that is transparent with a draw priority of 25. So the order I want to see them in is this:

Top
Ownership
Contour lines
Street layer
Bottom

When I turn them all on, I can see the two transparent layers just fine but cant see the street layer. I can see that layer if only one of the transparent layers is on but not both it seems. I have a Garmin Monterra if that makes any difference. Is the answer in the draw priority or somewhere else. Thanks again.

popej

  • Expert Advisor
  • *****
  • Posts: 328
  • Karma: 29
    • View Profile
Re: Help merging custom .typ file with .img
« Reply #8 on: September 17, 2014, 02:04:52 AM »
It should work as you described.

Well, Garmin Monterra can make a difference. I remember it displayed labels upside-down on some firmware.

wicks_10

  • Jr. Member
  • **
  • Posts: 8
  • Karma: 0
    • View Profile
Re: Help merging custom .typ file with .img
« Reply #9 on: September 17, 2014, 11:25:52 AM »
Maybe the device is the problem. I have it up to date and have had no issues with it yet. I am wondering now about the img file still. I tried a few different draw priority numbers with no luck. For the heck of it, I went back to the typ file in TYPViewer. When setting a color for a particular hex code, there is a checkbox to make it transparent. When that is checked, there is no color. Just 100% see through. I figured that would make it something like 50% opacity. Guess not. Either way, I made one polygon color transparent and recompiled the image. This made it so you could see everything underneath the land ownership layer for that particular polygon. So my thinking is that even though the img file is set to transparent, it really is not. I don't understand why it wouldn't be. I did double check that and it is set to transparent. Does opaque/semi-transparent option do something different? Can you not make the polygons "see through?" I noticed that user jbensman set the colors to a dotted matrix in his typ file. I figured that with the option to set transparency, you wouldn't need to do that. Any ideas. Thanks.

popej

  • Expert Advisor
  • *****
  • Posts: 328
  • Karma: 29
    • View Profile
Re: Help merging custom .typ file with .img
« Reply #10 on: September 17, 2014, 05:02:59 PM »
Transparent layer should have only lines and points, setting transparency flag doesn't make polygons transparent.