Welcome to GPSFileDepot!

Main Menu

MapSource transfer to BaseCamp

Started by trailsprinter, November 17, 2013, 07:13:30 AM

Previous topic - Next topic


New here, so I'm not sure if this question has been posted before.

I've got hundreds of saved routes and waypoints from hikes in 2012 using MapSource.  However, I've gone from a PC to a Mac and from what I can tell the Mac does not recognize MapSource data.  Is there a way to convert those MapSource routes, etc., to BaseCamp?

Thanks in advance,



Basecamp should recognize your data with no problem. But I'm not sure if it will open a Windows .gdb file (haven't tried). It can certainly open .gpx files though, so you might have to go back to Mapsource and save everything as .gpx.


I have opened GDB files with BaseCamp in the past.
Garmin GPSMap 60cs, Dakota 20, Colorado 400t, Oregon 300/400t/450/550t/650/650t, Montana 650, Lowrance Endura Sierra, nuvi 3790, iPhone 3G/4/4s
Geocaching ID: Atlas Cached Ambassador


Yep, I just did a test myself. I saved about 600 waypoints to both a .gdb and a .gpx file using Mapsource on Windows. Copied the files to a flash drive and then to my Mac. Basecamp was able to import both the .gdb and .gpx file with no problem.

So nothing is needed to "convert" your mapsource data. Just transfer all the files to your Mac and you can open them in Basecamp.

Indrid Cold

Quote from: trailsprinter on November 17, 2013, 07:13:30 AM
However, I've gone from a PC to a Mac and from what I can tell the Mac does not recognize MapSource data.
You can impost these into BaseCamp for Macintosh. You don't say where you are running into trouble but I would guess that you are double clicking the MapSouce files and they are not opening with BaseCamp, is this correct? If so, the easist way for you to get them into BaseCamp for Macintosh is to open BaseCamp, hold down the key and press the O key and you will get a window that asks you to Select a GPX, GDB or LOC file to import, where you do just that. The data will get imported into BaseCamp.


When I re-read the OP, I couldn't quite tell if he had even tried to import data on the Mac, or if he had just heard that it wasn't compatible.  ;)