Welcome to GPSFileDepot!

Main Menu

I can't reach the website

Started by rmcbeath, November 12, 2013, 12:01:48 PM

Previous topic - Next topic


Sorry for such a basic, basic question, but I can't reach the gpsfiledepot website from my computer.  My cellphone browser can reach the site, but on my laptop, I can't get to the site.  I have tried both IE and the Google Chrome browser with no success. 

I am not having any internet connectivity issues and can reach all other site, including this one of course.  Is the site having problems today or last night?

Any suggestions?

Addendum - Wednesday morning, November 13, 2013
Thanks for checking.  I can reach the site this morning now as well.


The same for me, can read and post on but for I get: 503 Service Temporarily Unavailable.


Same problem here. My browser (Safari) just hangs.



It's working for me now at 7:22 AM Eastern time. :)


I just tried "www dot gpsfiledepot dot com" and several map sublinks.  Still getting:

  "503 Service Temporarily Unavailable" after at least 40 seconds of delay.



Still having trouble with it tonight.  So, what is causing it to be down?


That is very weird since I am not having any issues. (aka hard to diagnose)
Dan Blomberg
Administrator - GPSFileDepot
GPS Units: Garmin Dakota 20, Garmin GPSMap 60csx, Nuvi 255W, Nuvi 250W, ForeRunner 110, Fenix 2, Tactix Bravo, Foretrex 401
See/Download My Maps!

Indrid Cold

I thought I ran into some DNS issue on Wednesday evening but it looks like it is working fine here now.


A few times this week it has worked in the morning and then was unavailable for the rest of the day.


Having problems again now - the forums work but not So the tutorials are not accessible either, as mentioned here:,3581.msg20775.html