Welcome to GPSFileDepot!

Main Menu

etrex 30 / 32GB sd card issue

Started by weavejd, September 14, 2013, 09:30:20 PM

Previous topic - Next topic


I bought a 32GB sd card for my etrex 30, copied everything off the 8GB card that was in the unit, slapped the 32GB card in and ... no maps show up in the unit.  :-* All the maps - all free topos from - work perfectly when they're on the smaller data card, but on the larger card, nada. The unit just shows the base map available. First 32GB card I tried was a generic, so I then bought and tried a genuine Sandisk, but same result.  >:(
Any thoughts from anyone? I've tried reformatting the card, re-copying the maps onto them, but no luck, no maps seen by the unit. I put the 8GB card back in and voila!, maps are seen by the gps.
Very frustrating!



yes, formatted to fat32. i downloaded an sd card formatter from with the gpsr in usb mode, card inserted in unit, both show as usb drives and the map files are visible in the garmin folder. it's just that the unit itself cannot see any maps. only with a 32gb sd card tho. 8gb works fine.
So i bought a 16gb card (sandisk) and it works as expected. it's just the 32s that don't work.


I have used a SanDisk Ultra 32GB micro SD HC-I in my OR300 for over a year without a problem.  I have nearly 8GB of vector mapset data on it.  I do not remember if I had to format it; however, if I did it would have been using the format program in Windows 7.


So I contacted Garmin support via email, here's the reply (very helpful - I say sarcastically):

"Thank you for contacting Garmin International.

I am happy to assist you with this today.

I sorry to hear that the 32GB Micro SD card(s) aren't working properly in your device. The only 32GB Micro SD card we have tested to see if it will work is the SanDisk 32GB Micro SD HC card. We can't speak for every card made by every manufacturer but that is the only one we know works for sure. We usually don't advise to use a card that large though. For most people a 4GB-16GB will work for almost everything. Sorry for any problems that this may have caused.

With Best Regards,

David 6310

Customer Care - Outdoor Team

Garmin International"

I am trying to use a Sandisk 32GB card (one brand mentioned on their website and in their reply).
I'm thinking there's a firmware problem with the larger cards, but Garmin is not acknowledging the fact.


What operating system are you using when you format the 32GB uSD card to FAT32?
Garmin GPSMap 60cs, Dakota 20, Colorado 400t, Oregon 300/400t/450/550t/650/650t, Montana 650, Lowrance Endura Sierra, nuvi 3790, iPhone 3G/4/4s
Geocaching ID: Atlas Cached Ambassador


"What operating system are you using when you format the 32GB uSD card to FAT32?"

Tried both my linux netbook and my wife's Win7 notebook. As I stated previously I used the format program (exe) from after trying GParted on linux and the built-in Win7 format program.
The files are visible on the card with the unit in usb mode. It can't read or see them apparently when in normal 'use' mode. When I go to 'set up map', the only map listed is the base map.
I think it's an etrex 20/30 firmware issue.
Other than this problem, I really like the etrex30. I had a 60CSx before, but it didn't survive being shut in a car door  :'(