Welcome to GPSFileDepot!

Main Menu

Force google earth to true 2D?

Started by hwstock, July 11, 2013, 01:12:50 PM

Previous topic - Next topic


It used to be easy to force google earth to true 2d view.  For example, if you uploaded a rectangular grid, the 2d view would show perfect rectangles, so it was easy to make tiles for a larger jpeg map. 

The current release of GE insists on showing you the rectangles distorted by perspective.  Is there any way to force true 2D?  Do I have to roll back my installation -- how far?


You should be aware that Google's terms of service forbid the use of their imagery in any form other than their own interface. In the past, this site has always frowned on discussion of any techniques that violate commercial software licenses...

I'm not saying that you shouldn't do this, just thinking that GPSFileDepot may not be the proper place to discuss it.  :)


Good point.  I wonder how that applies to GPSMapEdit, which displays googleMaps data in its own interface?

"8.3 Content License. Subject to these Terms (including but not limited to Section 9 (License Requirements) and Section 10 (License Restrictions)), Google gives you a personal, worldwide, royalty-free, non-transferable, non-assignable, and non-exclusive license to access, use, publicly perform and publicly display the Content in your Maps API Implementation, as the Content is provided in the Service, and in the manner permitted by the Terms. Specifically, you understand the following:

(a) Content (including but not limited to map data, traffic, directions, and places) is provided for planning purposes only. You may find that weather conditions, construction projects, closures, or other events may cause road conditions or directions to differ from the results depicted in the Content. You should exercise judgment in your use of the Content.
(b) Certain Content is provided under license from third parties, including Tele Atlas B.V. ("Tele Atlas"), and is subject to copyright and other intellectual property rights owned by or licensed to Tele Atlas and/or such third parties. You may be held liable for any unauthorized copying or disclosure of this content. Your use of Tele Atlas map data and certain other Content (including certain business listings Content) is subject to additional restrictions located in the Legal Notices page."


Notwithstanding the previous comments regarding the use of GE imagery within KMZ files, which I agree is not appropriate, the comment / issue is still valid when dealing with creating KMZ files using any other image overlay.

Version 7 of GE introduced the 'feature' that when opening KMZ files, the view automatically tilts to a 45 degree angle. I'm not sure if that's what we're talking about here, but there are three work arounds:

1) Press the "R" key on your keyboard and the view resets to overhead and north up. Handy shortcut.

2) When creating the KMZ, use the snapshot feature. It will automatically create the code below in the KMZ file.

3) Include the following code inside the KML file within the KMZ file that you create:
<name>whatever</name>  ***i'm just including this so you can see where the LookAt tag goes
           <longitude>-72.99605633362627</longitude>  ***specify the center point of the view you want
           <tilt>0</tilt>   ***this is the critical thing we're talking about here
           <range>7400</range>  ***this specifies the 'zoom' level
My custom KMZ map collection:


Even the view forced to a perpendicular is not "2D." If I rotate the page to a totally normal view of the earth, if there is any terrain model, the view is as if there were perspective,  so the segments of the grid are now slanted.  I've tried all the clamping options, none seem to make any difference.


ahhh... i think i know what you're talking about. Go to TOOLS, OPTIONS, 3D VIEW tab, then set Elevation Exaggeration to 0.01 (the default is 1). Does that make it better?
My custom KMZ map collection:


Quote from: dbperry on July 12, 2013, 06:25:19 AM
ahhh... i think i know what you're talking about. Go to TOOLS, OPTIONS, 3D VIEW tab, then set Elevation Exaggeration to 0.01 (the default is 1). Does that make it better?

That does the trick!  But this is odd: the lower limit, cited right there in the dialog, is 0.5.  Yet GE didn't complain at all when I typed in 0.001, and the image is truly flat! 

What a contrast to GE's normal obtrusive, over-zealous limit checking! E.g., when you are typing in the lat/lon limits for a bounding box, if you make one error, it resets everything to some bizarre default, rather than give you a chance to edit.