Welcome to GPSFileDepot!

Main Menu

62st not displaying maps?

Started by freediver111, October 18, 2012, 03:04:29 PM

Previous topic - Next topic


So I downloaded a western lands ownership map for my garmin 62ST.
Obviously it already has a topo map on the GPS since it's the topo version of the 62. My issue is that I appear to have successfully loaded the maps, n=but they don't appear to show up on the GPS. I don't have a sim card installed, so do I need one?
Any help or advise on this........


I don't have a 62s, so take this with a grain of salt.

If you sent the maps to the GPS, and the msgbox did not return an error, chances are that they loaded ok.  However, if the maps are not transparent, the built in maps may be "covering" your map.

Find where your 'map info' settings are. In there, you can 'turn on' and 'turn off' a maps visibility. You will be able to check if your maps transferred, and if so, you can turn them and others on/off to suit your desires.

You should only need an SD card if you are using content that is too big to fit in the built in memory. Extra Maps, Tours, and other stuff can go on an SD card, but it's not a requirement.

Hope this helps...


-- Smug
In a nutshell, I get claustrophobic.


Which State?

If you are not at the location of interest, did you pan to the location? 
And zoom in to the 1 mile of less display level?

Are you in the recreational profile?  Even if so, try changing to another profile and then back to recreational. 
Have you made any changes to the profile?

If the 62 is like the OR300; is map \ advanced map setup \ zoom levels \ land cover - set to auto (or not turned off or set to a very small number)?


Sorry about not posting sooner, I was at a wedding this weekend and away from my computer.
I'm going to give your advice a shot and see where it leads.
It is for the state of oregon, and I did zoom in over areas with BLM ground and it did not show up. I'm assuming my pre-loaded maps are being displayed on top of the BLM maps.
I'll take a look in the am and see where it gets me.
More tomorrow......


Western Land Ownership is an overlay/transparent mapset.  It should display/draw after the 'base' type maps.

If it still does not work; provide coordinates for the area.


Ok, so I went into the maps settings and I see the Western Lands overlay maps there and it is enabled, but they overlays are still not appearing on my GPS.
Here are the co-ordintes for one particular area I know is a BLM chunk but it does not appear any different on my GPS.....44 25'46.36 / 119 30'06.52.
I've also checked out other spots 100's of miles from there and still nothing.......
I doubt I did anything wrong since the Western Lands overlay map shows in my maps and is enabled, so I'm wondering what the heck is going on.
Thanks a ton for all the advice thus far.....I'd like to figure this one out!


What profile are you in?  Maps4gps suggested changing it.  If you haven't tried "recreational" try it.  If you have, switch to something else and back to recreational.


My profile is recreational.
Also, when the GPS is hooked up to my Mac and Basecamp is running, I don't see Western Lands Ownership map either, but the base topo map that came with the device is there.
Switching it and then putting it back to recreational didn't change anything.....


Quote from: freediver111 on October 22, 2012, 08:53:01 AM
Also, when the GPS is hooked up to my Mac and Basecamp is running, I don't see Western Lands Ownership map either

If you properly installed this map on your computer, it should be available in Basecamp regardless of whether the GPS is connected. With the device connected, double-click its icon in the Finder and look in the Garmin folder. What files do you see there with an .img extension (you might need to show extensions in the advanced Finder preferences), and what are their sizes?


I do not have a MAC; however, I just download the PC version. Both MapSource and BaseCamp display land ownership data around that area - State, NF & NPS, but no BLM.
An older file of land ownership from a different BLM source shows BLM lands there.

I would guess that either the BLM land did not get into the GPSr file or they were not included in the file BLM sent to Jim.

If there is no land ownership data at all on the GPS, you may not have sent it to the GPSr (see Boyd's previous post), the mapset is not enabled on the GPSr, some setting is set to not display it (see mine and other previous posts), or the GPSr may be defective.

Unless Garmin has recently added the ability to do so; BaseCamp will only display Garmin's mapset(s) which are on the GPSr.


Actually, upon further review, it does show national forest and national park boundaries, but it does not show BLM land very well. I scrolled around and did see a few BLM spots marked, but it was spotty.
I guess it is working, but not exactly what I need.
Do any of you have a good source for BLM land overlays for Oregon? I know where to get one, but I'm looking for a free one preferably.
Thanks for all the help so far, you guys are great!


The State topo maps I made available in May-June, 2011 use the above mentioned land management data from BLM.  It was a national file.  There were differences between it and the files available from the individual BLM state offices.  Also differences between either and info from USGS and/or state sources (and info at the actual on the ground locations). 

The Garmin topo map included with your GPSr is 100k in scale.  The State topos available on this site are usually about 24k in scale.