Welcome to GPSFileDepot!

Main Menu

New Mac User Frustrated

Started by Snosnake, October 07, 2012, 10:39:35 AM

Previous topic - Next topic


I'm a long time Garmin user, currently use a GPSmap 60CSx.  I've used Garmin's Basecamp on the the Mac before to store Tracks and waypoints.  Tried loading a map from GPSFileDepot (wytopo11) and it doesn't appear in the Basecamp, still only have "Global Map" available.  The file appeared to download and extract properly but all files, including a folder wytopo11.gmapi, are sill in my Download folder.  Do they need to be moved somewhere that Basecamp can find them?  I've done everything including reboot with no luck.  This looks like a great resource for maps if it worked, any suggestions? :-\


Check your applications folder to confirm that Basecamp, MapInstall and Mapmanager are all there. If not, then re-install. What version of Basecamp do you have? Current version is 4.0.2 - For some reason, the app store only has version 3.3

If Basecamp is properly installed, then double-clicking the .gmapi file will launch MapManager and it should ask if you want to install the map. If this isn't happening then something must be wrong with Basecamp/Mapmanager on your system. When you say "all the files are there", that is a little puzzling. All you should have is the .gmapi file. If Basecamp was not properly installed, then the .gmapi will probably look like a folder instead of a file.


Hey Boyd, thanks!  The latest Basecamp version on the Mac - App store was 3.2...  Never thought to look at the Garmin site.  I installed the latest Basecamp software, then redownloaded the map and loaded it with Garmin Map Manager.  Loaded it on my 60CSx and I'm ready for Antelope hunting in Wyoming.


Great, glad it worked. Strange that it didn't work before, but the main thing is that you're up and running.  :)


just did this myself and maps loaded straight away,thanks guys :)