Welcome to GPSFileDepot!

Main Menu

Dakota 20 doesn't allow renamed IMG files on SD card?

Started by rivir, August 02, 2012, 03:44:03 PM

Previous topic - Next topic


I had done a lot of reading before I ordered this GPS unit, and I read several people say that you can put multiple IMG map files onto the microSD card using whatever filename you want. However, I seem to be having problems with this.

On my microSD card, I can put a file under /Garmin/ called gmapsupp.img and the GPS will list it and display it with no problems. BUT, if I change the name to anything else, for example: osmontario.img, then suddenly the unit doesn't see it anymore.

I tried various names and locations on the SD card to no avail. The only name that appears to work is /Garmin/gmapsupp.img on the SD card.

I am wondering if I need to edit something somewhere, or if I need an older firmware or what the deal is... Can anyone assist?

Model: Dakota 20
Firmware: 5.20
PC OS: Linux


I think it should work with current firmware, but you can confirm by opening the file named GarminDevice.xml (found on the device in the Garmin directory) in a browser or text editor. Look for a sequence like this:


This means that the unit understands multiple names (NMaps) for .img files located in the Garmin directory.

I wonder if Linux could be causing something strange to happen when you rename the files? I have seen one case where a Windows user was hiding file extensions and created names like osmontario.img.img and that won't work. You could try using a Windows machine or a Mac just for fun and see if that makes a difference.

[edited to add]
You only mentioned the card. Do multiple files work if you put them in the Garmin directory in internal memory? This might be a firmware bug of some sort. You could try contacting Garmin support and see what they say.


Thanks for your reply, Boyd. I appreciate your help and knowledge (I've seen you in other threads I read prior to creating this one).

As far as the internal memory goes, I didn't mention it because I want to keep all of my maps on my SD card. But I did test it and found I need to have the files named very specific names: gmapbmap.img (default world basemap, didn't overwrite it but I assume it would work), gmapprom.img, and gmapsupp.img. I had tried another one or two that didn't, like gmap3d.img and I forget what else. As mentioned before, the only name that seems to work from the SD card is gmapsupp.img.

I found the section you quoted from the GarminDevice.xml file, and it is definitely in there. So now I'm even more confused!

I had also tried editing that file (backed it up, of course) and specifying different BaseNames to see if I could force it to read a different name (or wildcard) instead of, for example, gmapsupp, but that didn't work either. I guess that file is a log of some sort rather than a configuration file.

I actually don't have access to a Windows or Mac machine right now. I work on Linux machines for work, and my local family either has no PC or asked me to convert them to Linux already.. I am fairly confident that the files aren't being renamed something wonky somehow because I believe I am pretty tech savvy, and because I can get the maps to load when I manually rename them to gmapsupp.img.

I had actually contacted Garmin support via email before I posted here, but I don't expect a reply as quickly as I could get from people like you. :) Besides, I didn't know if they would want to actually support me, using free alternatives to their official (and pricy) maps.

EDIT: I just thought of a couple other things to mention. When I first started out, I began with a brand new 4GB SDHC Class 4 card, put my maps on it, as well as a Pocket Query GPX file. The maps weren't showing up, so I tried on an older 2GB SD card I had kicking around, and they still didn't show up... I thought there was something wrong, but then I noticed that the Geocaching stuff was being read with no problems. So I don't think it's the SD card itself, which was my first suspicion. Also, the maps I've been testing are not huge. Maybe 200MB each, max, so I don't believe there is an issue with sizes or something, especially since it doesn't work if I put just one single IMG file on there with a name other than gmapsupp.img.


Yeah, don't waste your time editing GarminDevice.xml. It is not read by the device and is regenerated everytime it starts up.

That really sounds wrong as far as only recognizing specific names. gmap3d.img is never going to work on your device - that name is reserved for 3d buildings that can be rendered by some of the advanced Nuvi series.  :)

I would think that Garmin will help, but not if you say "I'm downloading third party maps and changing the names".  ;D  What you want to do would be perfectly reasonable if you had several Garmin products, like City Navigator, US Topo 100k and one of the 24k Topos.

Lack of a Windows machine could make this harder to troubleshoot. Garmin will probaby tell you to use MapInstall, and it should query the gps (via the xml file), determine what names are valid and act accordingly.

But there may just be a bug in the new firmware. I suppose you could roll it hack to an old version and see what happens. You should be able to install the .gcd versions here by changing the filename to gupdate.gcd:


I am not having this issue with my Dakota 20, running FW 5.20

Very interesting.....
Garmin GPSMap 60cs, Dakota 20, Colorado 400t, Oregon 300/400t/450/550t/650/650t, Montana 650, Lowrance Endura Sierra, nuvi 3790, iPhone 3G/4/4s
Geocaching ID: Atlas Cached Ambassador


I figured Garmin's reply might be to use their Windows software.. I was pretty clear in my email that others on the web have done what I want to do, drag and drop different maps with different names onto an SD card; the OS really shouldn't matter at all for such a task. If they want me to buy ANY of their maps, then they're going to have to tell me how to get more than one on my SD card without having to merge them into a single, slower file (thereby making updates more annoying than need be).

I knew the Dakota didn't support 3D, I just thought it might recognize and load that filename. One extra slot couldn't hurt, right? :) Even though it's not on the SD card.. :\

Anyhow, I downgraded to 4.10, same thing... I don't think there's much reason to go lower than that, as I'm pretty sure I saw others confirm it working with that version or newer. I really am at a loss.

Quote from: babj615 on August 02, 2012, 09:12:25 PM
I am not having this issue with my Dakota 20, running FW 5.20

Very interesting.....
Yeah, interesting is one way to put it...

I should also add, I did try putting maps in various directories I've seen mentioned elsewhere for other devices, to no avail.


I confirm, that maps with changed names work in Dakota when saved in directory \Garmin on SD. This is the configuration I'm using, 4GB SD card, firmware 5.20.

Check your SD for file system problems like for example spaces in names.


Very strange. I consider myself pretty advanced when it comes to using Linux/unix in a command line environment but have no experience with the GUI's that may be included in current Linux distributions. How are you doing all of this? Command line shell or a GUI? If using a GUI, maybe it is creating a bunch of invisible files that are confusing the device? Have you tried doing a ls -al from the a shell prompt to look for hidden files?

When I first saw this thread it made me think of a thread in Garmin's own forums where an Oregon 450 user was having a similar problem. I'd post a link, but Garmin's forum has been down for the past day. Anyway, the OP in that thread was doing something a bit strange and loading a lot of separate map tiles on the device.

Apparently the Oregon didn't like having so many map files on the unit (IIRC there were about 20 .img files). There is also other anecdotal evidence that having too many maps causes problems. But you did not indicate that you're doing this, so I ruled it out.

My only other thought is that it could be related to the maps you are using. Do you know how many tiles are in the map? If you have more than 4000 map tiles, strange things might happen.

Again, I think you need to find a Mac or PC and see if that makes a difference. Surely you know SOMEBODY with one that you can use?  ;)


FWIW, Garmin's site is back online; here's the thread I mentioned:

You know.... pondering this just now, I have another idea. You may not be correctly diagnosing the problem. What are the different maps you're using? Are they all OSM maps maybe? You can load multiple map files and they will all be recognized BUT, if they have the same internal ID numbers the GPS will automatically group them all together into a single menu entry and you can't enable/disable them individually.

Again, it will be hard to diagnose/fix without a Windows machine. If you had one, you could use Popej's excellent gmaptool utility to change the map ID numbers and see if that fixes the problem.


Good point about maps from, Boyd.

JaVaWa GMTK has both Mac and Win versions that should be able to edit FIDs and mapIDs so if you can find a Mac you could use that.  I'm totally ignorant about Linux, but I've read that MapSource works under Wine.  Have you tried that?


Thanks for the replies. I was out of town with the wife. We did some geocaching with the Dakota, worked quite nicely. Anyhow..

I have not tried anything in Wine. I didn't want to have to use any kind of software to manage maps, just drag and drop the files onto the device. Last time I looked into Wine, Debian had removed it from the repos, so I'd have to compile it myself or use some sketchy package from the web.

I have several different IMG files, including the basemap that came with the device, Ibycus v4 (Ontario subset that weighs in around 400MB), and OSM Ontario, etc. As I said before, if I name them gmapbmap.img, gmapprom.img, gmapsupp.img on the device, they work fine and each map shows independently and can be enabled/disabled. I can store a single map on the SD card using the filename gmapsupp.img, and likewise, it can be enabled/disabled. I've tried using just a single map at a time in addition to the basemap, and again, it only works when named one of these specific names.

Before I had left I noticed the issue with Garmin's forums and couldn't search it at all. Now that it's fixed, I read through that thread you linked, Boyd. His problem seemed to be fixed when he removed the dozens of Ibycus tiles.. I did not do such a thing. I used the Ibycus 4.0 ISO, opened up the map set in QLandkarteGT and selected the 94-95 Ontario tiles, then exported that as a single Garmin IMG file. And my Ibycus map works perfectly, and it's probably entirely sufficient for my needs, truth be told.

So, if I can't resolve this problem, then I guess I'll be fine with just the OSM and Ibycus (which is quite good, really). It'd just have been nice to be able to have descriptive names and a higher limit to the number of maps I could store. If I can figure it out, I'd like to look at some of Garmin's offerings, and of particular interest to me is the Backroad Map Books GPS maps.

Here's a listing of all the files and directories on my Dakota:

rivir@jadis:~$ find /media/GARMIN/
/media/GARMIN/Garmin/Filters/Geocache/Quick Filter.gff

I renamed gmapsupp.img to ibycus.img using my GUI and then checked it in the terminal, and it looks right:


But it does not work on the GPS. Renaming it back to gmapsupp.img using the GUI makes it work fine again.


If you haven't already, you should cross post to

Lots of Garmin/Linux users there.


Sorry, I think you've lost me here. My only other comment is that Backroad Maps come from a third party and not Garmin. I have not used them, but you should probably contact them before purchasing, because they likely use a Windows based installer that will put the files into Basecamp/Mapsource and you would then need to use those programs to install them on the GPS.

Honestly, you're making things much too hard by your stubborn refusal to use either a Windows PC or a Mac. I "get" the whole linux thing - I was using RedHat when it first came out (late 90's?) myself and I go back to 1985 with unix. But consider the value of your time. If it's worth anything, then you have already wasted more than enough of it to pay for a cheap used Windows machine which could be used to manage your GPS.


Quote from: Boyd on August 02, 2012, 07:50:48 PM
Yeah, don't waste your time editing GarminDevice.xml. It is not read by the device and is regenerated everytime it starts up.


It seems that the GarminDevice.xml file is not regenerated EVERY time the unit starts up - mine is starting up just fine, though it has a few functional limitations - the contents of the internal memory got wiped [operator error]. I think the Dakota needs to read a version of the GarminDevice.xml in order to rewrite a possibly modified version.

And unfortunately, WebUpdater may need a good version of the file in order to recognize & identify the unit.

So I am trying to recreate just enough of the file that WebUpdater will recognize it & do an update (from 3.1 to 5.8). The warnings at regarding going past 4.6 suggest that enough may go on in that update to make my Dakota more functional.

As it is, BaseMap will install maps to either the internal memory or the SD card, and they work fine, so at least it is not bricked.

If anyone can give me guidance on how to get a minimally & momentarily useful GarminDevice.xml, I would greatly appreciate it.


On my Dakota I can delete GarminDevice.xml and it is restored at start. Check if you have free place in internal storage. And you can try to create empty xml.