Welcome, Guest. Please login or register.

Login with username, password and session length
Forums Search:  


Author Topic: Problem uploading an opensource map to an oregon GPS using a mac  (Read 9094 times)

pp

  • Jr. Member
  • **
  • Posts: 10
  • Karma: 0
    • View Profile
HELP!!!!
I have an oregon 450t.  I run a mac computer only.  I downloaded an open source map of Switzerland, and the attached instructions told me I just needed to copy the gmapsupp.img file to a directory called GARMIN on an SD card - and then the map would be seen by my GPS and visible on Basecamp.  Neither happened and I cant make it work.

Help??

Suggestions??

Thanks in advance

PP

Seldom

  • Expert Advisor
  • *****
  • Posts: 1852
  • Karma: 19
    • View Profile
Re: Problem uploading an opensource map to an oregon GPS using a mac
« Reply #1 on: June 03, 2012, 01:48:25 PM »
Those look like reasonable instructions.  Where'd you get the map? What kind of card did you copy it to?  Could be bad map, or bad card.

Boyd

  • Expert Advisor
  • *****
  • Posts: 3843
  • Karma: 43
    • View Profile
Re: Problem uploading an opensource map to an oregon GPS using a mac
« Reply #2 on: June 03, 2012, 02:22:15 PM »
Use the disk utility program (in the Utilities folder inside the Applications folder) to check that your card is formatted as FAT32. If not, then reformat. Also be certain that the card is correctly seated in the Oregon and the metal cover is in the latched position.

If that doesn't help, you should probably contact the author of the map because what you did sounds correct otherwise. Since the map didn't come from this site, there probably isn't much that we can do to help here.

pp

  • Jr. Member
  • **
  • Posts: 10
  • Karma: 0
    • View Profile
Re: Problem uploading an opensource map to an oregon GPS using a mac
« Reply #3 on: June 03, 2012, 03:19:52 PM »
I dont think it is a bad map of disc because I have had the same problem with maps from other sources.  I am wondering if it is because I am using a MAC.  I am formating my SD card w/FAT, and await the outcome with interest (FAT was the closest to FAT32 I could find in MAC disc utilities, unless I a,m missing the point somewhere

Boyd

  • Expert Advisor
  • *****
  • Posts: 3843
  • Karma: 43
    • View Profile
Re: Problem uploading an opensource map to an oregon GPS using a mac
« Reply #4 on: June 03, 2012, 03:42:58 PM »
Is your mac set to show filename extensions? In the Finder go to Finder > Preferences > Advanced and be sure that Show all filename extensions is checked. I have seen a case where the .img file extension was hidden, so the user added .img to the name. The result was a file that was actually named gmapsupp.img.img and that won't work.

If you have had the same problem with maps from other sources, why would you rule out a bad SD card? I would try another card, or try to copy the map to the Garmin folder in internal memory. Only caveat there is, if it's a corrupt map file it can prevent your Oregon from starting up.

Another idea: download/install Garmin Basecamp if you haven't already done so. Then try downloading one of the free maps from this site that has a Mac installer. You can then see if the map works in Basecamp on your computer. If so, use Basecamp/MapInstall to send it to your Oregon. If that works properly, then there must be a problem with the other map you're trying to install.

But really you should seek help from the site where you got this map.

pp

  • Jr. Member
  • **
  • Posts: 10
  • Karma: 0
    • View Profile
Re: Problem uploading an opensource map to an oregon GPS using a mac
« Reply #5 on: June 04, 2012, 04:25:05 PM »
Thanks.  I think I'm beginning to get through this.....

I downloaded a local map (of where I live) from this website and put it on an SD card and it worked on the device but would not show its content on basecamp either through the SD card reader on the computer or through the device - Basecamp did recognize the name of the card - just not the content.

So I wonder if the map (of Switzerland) that was causing the initial worry did so because in the device it was so far awayfrom where the device knows I am that I could not get it onto the screen (>3000 miles). (My scotland map - a garmin product - does something similar on the device - but this map is visible on basecamp)

So my question is - if all the above is correct, then how to I get an open source map (from your site or elsewhere) visible on basecamp?

Thanks as always for your input.....

PP 

SmugWimp

  • Mapper
  • ***
  • Posts: 54
  • Karma: 4
    • View Profile
    • SmugWimp's Site
Re: Problem uploading an opensource map to an oregon GPS using a mac
« Reply #6 on: June 04, 2012, 04:53:12 PM »
All 'properly installed' maps should appear in Basecamp/Mapsource regardless of your location. 

On the GPS, you might find it convenient to turn off the GPS 'mode' (tools > settings > system, on a Nuvi, not sure about a Oregon) and scroll/zoom to view a map that isn't in your area.

Each map found here (on this site) is created and submitted by an individual, so there may be differences between map 'appearance', but in the end they should all 'behave' the same once installed.

You may want to check out 'mapset toolkit' (found at http://sites.google.com/site/cypherman1/) as a way of getting your maps viewable in Basecamp, if they didn't come with an installer...

Hope this helps some...

Cheers!

-- Smug
In a nutshell, I get claustrophobic.

Boyd

  • Expert Advisor
  • *****
  • Posts: 3843
  • Karma: 43
    • View Profile
Re: Problem uploading an opensource map to an oregon GPS using a mac
« Reply #7 on: June 04, 2012, 04:57:13 PM »
You may want to check out 'mapset toolkit'

Not gonna happen on his Mac.  ;)

In Basecamp, do you see entries for these under the "Map menu"? On your Oregon, do you see them listed under Setup > Map > Map Info?


SmugWimp

  • Mapper
  • ***
  • Posts: 54
  • Karma: 4
    • View Profile
    • SmugWimp's Site
Re: Problem uploading an opensource map to an oregon GPS using a mac
« Reply #8 on: June 04, 2012, 05:27:03 PM »
Oh right. Mac. My bad.
In a nutshell, I get claustrophobic.

babj615

  • Expert Advisor
  • *****
  • Posts: 266
  • Karma: -4
  • The cache is a lie!
    • View Profile
    • Garmin Oregon 6xx Wiki
Re: Problem uploading an opensource map to an oregon GPS using a mac
« Reply #9 on: June 05, 2012, 12:56:01 AM »
If you want a Garmin format *.img map on an external SD card to be usable in BaseCamp on your host computer, you will need to do two things, and you are already half way there.

Try This:

First, format FAT32 the SD card, and make Garmin directory to copy your *.img map files to.

ALSO, you must copy the GarminDevice.xml file from your GPSr to the Garmin directory on your SD card.

OK, a third task, also add a BLANK notepad document titled GarminSDCard.txt to the root directory of your SD card.

Garmin GPSMap 60cs, Dakota 20, Colorado 400t, Oregon 300/400t/450/550t/650/650t, Montana 650, Lowrance Endura Sierra, nuvi 3790, iPhone 3G/4/4s
Geocaching ID: Atlas Cached
OpenCaching.com Ambassador

pp

  • Jr. Member
  • **
  • Posts: 10
  • Karma: 0
    • View Profile
Re: Problem uploading an opensource map to an oregon GPS using a mac
« Reply #10 on: June 05, 2012, 04:31:53 PM »
from babj16 - I did the three things you suggested.  Basecamp now thinks the sd cards are garmin 450t's - but the maps contained on them are not listed in the basecamp map list.

to boyd - the map names are visible on the map menu on the oregon, and the NC map appears to work on the oregon.  But the maps are not visible on the my garmin devices list on basecamp.  The SD cards appear but when I click on them nothing appears.  The installed basemap appears as does a map (of Scotland) I purchased from Garmin when installed on an SD card

Help!


Seldom

  • Expert Advisor
  • *****
  • Posts: 1852
  • Karma: 19
    • View Profile
Re: Problem uploading an opensource map to an oregon GPS using a mac
« Reply #11 on: June 05, 2012, 04:50:57 PM »
The only way I've been able to get my maps to load into BaseCamp from a card is to use JavaWA Device manager, and  "Make Map Visible in BaseCamp".   I thought otherwise, the only maps that could be seen in BC were made by Garmin.  Am I missing something?

pp

  • Jr. Member
  • **
  • Posts: 10
  • Karma: 0
    • View Profile
Re: Problem uploading an opensource map to an oregon GPS using a mac
« Reply #12 on: June 05, 2012, 05:38:24 PM »
what is javaWA Device manager?  How do you do this
PP

BTW I am glad !'m not the only one having the problem

pp

  • Jr. Member
  • **
  • Posts: 10
  • Karma: 0
    • View Profile
Re: Problem uploading an opensource map to an oregon GPS using a mac
« Reply #13 on: June 05, 2012, 06:16:05 PM »
found it!  It makes maps from this site visible in basecamp, but not my swiss map!  Interestingly tho', the swiss map is visible in javawa devicemanager....  Any ideas on why it still may not b visible in basecamp?

Thanks
pp

Indrid Cold

  • Moderator
  • Expert Advisor
  • *****
  • Posts: 919
  • Karma: 20
    • View Profile
Re: Problem uploading an opensource map to an oregon GPS using a mac
« Reply #14 on: June 05, 2012, 09:36:22 PM »
I downloaded an open source map of…
You have been asked a couple of times where you downloaded this map and have either dodged the question or not bothered to answer. I assume it wasn't from this site. Please provide a link so one of can see the same data you have or you're just playing pin the tail on the donkey.

 

anything