Welcome to GPSFileDepot!

Main Menu

Astro 320 Not Reading Maps

Started by RiverRatMatt, May 10, 2012, 04:17:57 AM

Previous topic - Next topic


I downloaded some maps from your site, installed BaseCamp and MapSource in order, and uploaded some maps.

For all of these uploads, I selected the whole area available. First I uploaded the Idaho topo map onto the unit, then the Arizona one. However, in the map list only the AZ map showed up.

I tried with a Micro SD card - loaded the following into one upload via MapSource:


Then loaded those onto the card.
Only ID came through when I select that map set.

Then I tried loading all of those individually onto the Micro SD card. I transfered them one at a time - none of them show on the map list now.



With your Astro connected to your computer, open the Garmin folder. What files with the .img extension do you see? How large are they? Now look in the Garmin folder on your SD card. What .img files are there?

When you use Mapsource, any maps you have selected will be combined into a single file named gmapsupp.img. The next time you send maps, a new gmapsupp.img is created and it replaces (erases) the earlier one. You could manually change the name of gmapsupp.img to anything.img to avoid this.

You can also select portions of multiple maps and send them all at the same time - I'm not clear as to whether you tried that. This was how you needed to send multiple maps to older GPS units because the only file they recognized was gmapsupp.img. But your Astro understands any file with a .img extension. Some of the new models will, in fact, not work properly when you send multiple maps at the same time with mapsource. Instead of seeing separate maps listed on the GPS, there will only be one map that groups everything together.

Now if you use Basecamp with Mapinstall 4.0, it will behave differently. On your unit, it should give unique names to each map you send so that old ones will not be erased. I have not used the new Mapinstall 4.0 myself, but others here are using it.

What do you mean by "Only ID came through when I select that map set."? The name you see displayed on the GPS may not be the same as what you expect because it comes from data embedded inside the file.


Thank you for your swift response. I was quite frustrated when I wrote it so I may not have been overly clear :p

By ID I meant Idaho :p

That makes sense about mapsource deleting the previously uploaded map data. Kinda weird.
I was able to upload all the image files for all the states I wanted to directly to the GPS last night, for some reason when I compiled all of them together earlier in the day it didn't work out.

I have a different problem now.... when I go to Find, then Addresses, it asks for the State/Province. No matter if I type ID or Idaho or IDAHO, it says No Results Found. Help?


I doubt that the Idaho map supports address search unless it's routable, and I doubt that it's routable.