Welcome to GPSFileDepot!

Main Menu

Garmin GPSmap 62

Started by Diogenese_1, April 16, 2012, 08:04:14 PM

Previous topic - Next topic



I just received my handheld GPS last week.  I don't know what I'm doing and find this experience frustrating!  I couldn't get Basecamp to load on my Vista machine, but was able to load Mapsource.  From there I downloaded the Minnesota topos from this site into Mapsource.  I selected the parts I wanted to transfer as per the tutorials and transferred it to the gps . . . it said it transferred it.  How do I find these maps on the GPS?  I just can't find them.  I select 'menu', 'setup map', 'select map', 'enter' and the only maps that are here are the default maps.  What am I missing?



I haven't used a 62 myself so I can't give specific help but hopefully somebody else will. But with the device connected to your computer, double-click to open it and look in the Garmin directory. Do you see a file named gmapsupp.img? How large is it? This should be the map that you sent. If you can't find that file, the map was not transferred for some reason.

Also, you will need to get Basecamp running somehow because Mapsource is not fully compatible with new units like yours. Mapsource will be fine for sending maps, waypoints, tracks and routes to your 62. However it will not correctly receive them from the GPS. The new units store tracks, waypoints and routes in a bunch of separate files and Mapsource doesn't know where to look for them. Garmin has discontinued Mapsource, so it will never have this capability.

I am running Basecamp on Windows Vista, so it definitely can be done.


Quote from: Diogenese_1 on April 16, 2012, 08:04:14 PM
  I select 'menu', 'setup map', 'select map', 'enter' and the only maps that are here are the default maps. 
That's the correct key sequence. How many default maps do you show?  The only map that came with my 62s was the Worldwide Basemap.  You need to look at your 62s on your computer and see if there's a gmapsupp.img where Boyd said it should be.


There is a file '' under the Garmin folder.  it is 13,204 KB.  The sections that I transferred are only the Boundary Waters Canoe area of Northern Minnesota and some way points.  So if it is there, why can't I see it through the Garmin Menu?

Thanks you for your help.


Here are my options under the 'setup map', 'map information Select Map' section:  Enabled- Worldwide DEM Basemap, NR; Enabled - Hancock (W), Pige; Enabled - Digital Globe Demo.jnx; Enabled - BirdsEye Select Kompass-Switzerland Brienzer Rothom.jnx; Enabled Birdseye Select ERIE Carrauntoohil.JNX; Enabled - Birdseye Select France Mont Blanc.JNX; Enabled - BirdsEye Select Great Britian Snowdon. JNX; Enabled -  BirdsEye Select Ko ZelamSee.jnx; Enabled - USGS Quads Grand Canyon National Park.JNX

I didn't put any of these files on the unit (at leat not on purpose).  Perhaps my GPS was returned?  I got it from Amazon.

Should I just return it?


Quote from: Diogenese_1 on April 17, 2012, 04:38:05 AMEnabled - Hancock (W)

That sounds like it could be the map that you sent. Note that the name displayed on the GPS device may not be what you expect. It comes from data inside the file. Maps consist of many individual "tiles" and the name that's displayed will come from these.

All that other stuff sounds like free samples that Garmin is now including on their new models. When I got my Montana there was only one of these samples, but others have also reported seeing these other BirdsEye samples.

I think Garmin is now making their devices "international" with only one version which would explain the EU maps. For example, my Montana included plugs for both EU and US power outlets.

If you look in the Garmin folder you will see a Birdseye folder inside. Unless you want all that other stuff, you could just delete the contents of the BirdsEye folder. But before you delete ANYTHING, make a full backup of your device. Just make a folder on your computer and drag or paste all the files/folders from the 62 into it.


Thanks you very much.  I did what you said.  Now I only have two files.  Enabled - Worldwide DEM Basemap, NR; Enabled - Hancock (W), pige.  The second is probably the one that I sent.  How do I open it and move around it with the GPSr?  I would like to make sure that it is functioning and that the Waypoints are there.  Again, I am a complete newbe to this.  Thanks for you patience!


If the map is enabled, and you are in the area of map coverage, you should see it when you turn on the 62.  I don't know that map, but you may need to zoom in to a mile or so for the detail to show.   If you are out of the coverage area, you'll need to pan to it, and zoom in.  Waypoints won't be on the device unless you have either created them in the field or sent them to it using BaseCamp or MapSource.


Sounds like my MN topo mapsets.
Unless you indicate otherwise, MapSource creates a 'secondary mapset name' using the name of one or more of the quads/segments sent to the GPSr.  In this instance the Hancock (w) quad and part of the Pigeon Point quad was included in the name MS created.
The primary mapset name should be something like MN topo 2011.


I just got a 62st, I have tried to use both mapsource and base camp to upload maps. I am unable to transfer maps from my PC to the GPS. once the transfer is complete it say done, but still cant see map on my GPS.

Any help?


Follow the key sequence Diogenese_1 describes above on this thread.  Also, connect your 62st to a computer and see if you see a gmapsupp.img in the Garmin folder.


No, Under devises, I have 100K us topo, and All data. under the all data, It shows Garmin Asia, USA and Europe, Birds eye demo and then tracking software.

Am I missing where to find the maps? I tried downloading 2 maps and transfering them to the GPS, on for Colorado and one for Minnesota. neither have worked so far.


I wasn't clear.  You don't use BaseCamp to view what's on the GPSr.  You need to use Windows Explorer.  You should see a Garmin Drive with a blue triangle and a second drive if you have a microSD card.  A gmapsupp.img file should be in the \Garmin folder of either the Garmin drive or the microSD drive.

What do you see on your GPSr (not connected to your computer) when you do 'menu'> 'setup map'> 'select map'> 'enter'? 


Correct. I have the file you talk about. gmapsupp.img. am I supposed to open that file? I see gmaptz.img gmapbmap. img and .sum gmapprom.img and .sum. so I have 5 total files on the GPS.

I have 4 maps available. worldwide DEM basemap.NR, topo us 100K, la junta (E) LAMA, and Birdseye

I noticed inside the GPS, there was a switch that said, open and locked. I just "opened" the switch. not sure what it does.


gmapsupp.img should appear as a map in the Select Map screen.  I suspect la junta (E) LAMA is the map you uploaded.  gmaptz is a time zone map.  gmapbmap is the basemap. gmapprom is probably the 100k topo, I don't own a 62st, but recognize those as standard Garmin IMG file names.  I suggest you try disabling the topo US 100k, and see if la junta is visible.  If not keep disabling until it is.  You can always enable the other maps once you've found what la junta is.