Welcome to GPSFileDepot!

Main Menu

Duplicate map entries on GPS?

Started by jbensman, October 27, 2011, 09:07:03 AM

Previous topic - Next topic


I thought I had something warning people about it on the description.  I checked and did not.  So now the description warns people about it. 


I had the same thing going on a couple of years ago with some of my custom maps that have I own here.  I discovered the problem before anyone else reported it to me; everything about the maps worked, but the double entry just bugged me.  I new I had changed some of the map properties in GPSMapEdit when the problem started.

I was getting double entries of the same map, just as being described here, for just a couple of my maps on the GPS when I would install multiple maps in the same MapSet that had different map properties.  This was a new problem I had not seen with my older maps until I created a couple of new maps. 

Here is what I had done that caused it.   When I originally started making Custom Maps, in GPSMapEdit in the Map Properties, under "Header" I had the "Code Schema" set to "European [Single-byte], at some point I started using "Code Schema" set to American [7-bit].  I was using Mapsource 6.13.7 to install multiple maps that had different "Code Schema".  When I went back to my old maps and recompiled ALL my maps to the same "Code Schema" the problem went away, no more double installs of the same map to the GPS.  So now all of my maps are made with "Code Schema" set to American [7-bit].

korey99 - there is not anything you can do yourself to correct it.  The map author for the maps you are using have used different "Code Schema", as I described above.  There is no standard "Code Schema" for map authors to use, thus some will use European and some will use American.  Until you load 2 or more maps into the same MapSet at the same time that have the different code schema you don't see this problem occur and from a usage stand point it doesn't matter which code was used until you try to load multiple maps that were compiled with a different code schema and then you get the double entry of the map name.

If you could open the .img file or .mp file in GPSMapEdit you could tell which maps are different in the code.

edit:  I did take a look at the .img files in the "MY Trails" map (I am using an older version than the latest one) and 2 different types are being used on the Code Page and in the Code Schema for the .img files making up the map... multiple names. 


Thanks.  I thought I had checked all of that and had everything the same.  So I will be checking again.  I will let you know if that is the problem.


I was looking at one of your older versions that had only 26 .img files; thought you might be using these same .img files in your latest version.   I sent you an email with the name of the .img files, for the version I looked at, that were different.


Well that fixed it.  BUt one of my maps (IL MO) keeps changing to 1252 and European whenever I reopen it.  I looked at the mp file and cannot see where this info is in it.  Anyone know why it would keep changing the settings?  I guess this explains how I thought I had everything the same. 

Now it is time to start looking at other mapsets.




Well this makes no sense, but it was not exactly what you said.  I had My POIs and Eastern land Ownership all set to 0 and European-everything was set to the same thing and they showed up 3 times each on the GPS.  I changed european to American and they only show up once.  That makes no sense, but it was not that they were different, it was because they were set to European, not American. 

I also noticed when I was messing with this stuff that I had the transparency set wrong on WI for My Trails.  I am suprised no one said anything about My Trails not showing up in WI!

I will be posting new versions of the maps in the next day or so. 


When I had duplicate names appearing I had 6 ATV Trail systems across the U.S. in 1 Mapset.  4 of the trails were in European and 2 were in American.  The Code page was the same "0" for all 6 maps.  The European's each appeared duplicated when I created/added the 2 new maps in American.  When I switched all to American no more duplicate names.  I quit looking at it once the problem was corrected, but am still curious as to what is actually going on causing this to happen?


When I had 4 .img files all/only European in the Mapset the map name would only appear 1 time.


I know if the transparency settings are not all the same, you get multiple entries-that's what lead me to my WI map being set to not transparent.  My Topos and CO Topos still show up twice since they have some maps transparent and some (hydrology polygons to trick City Navigator to draw roads on top of it) set to not transparent.

I also figured out why My Trails kept changing itself back to European.  I could never figure out why but when I would open the mp file in NotePad++, sometimes there were lines that had ; followed by bunches of null characters.  I've spent lots of time in the past trying to find the lines and delete them.  I finally determined that was what was causing the problem.  In the past I could never get search and replace to eliminate them-you could not select a nul character.  I tried opening it in Word and it would crash Word.  Then I found a tool in Notepad++ to turn unprintable characters to #.  I was then able to use search and replace to remove them.

I cannot find in the header where the coding scheme and language is listed.  Can anyone?  The dialogue box indicates the settings affect labels.  I don't understand what the different code pages mean, but perhaps they affect how something about labels that will cause Garmin to split them.  Its also interesting when I had all those nul characters in a comment line, it would set itself to European.  None of the nul characters were in a Label line


Quote from: jbensman on October 29, 2011, 09:12:21 AM
I cannot find in the header where the coding scheme and language is listed.  Can anyone?  The dialogue box indicates the settings affect labels.  I don't understand what the different code pages mean, but perhaps they affect how something about labels that will cause Garmin to split them. 

Is this what you are asking about?  From the manual. Both items go in the header:


6 􀃆 compressed label coding (smallest maps)
9 􀃆 full-byte (8-bit) coding (supports national characters, depending on the GPS firmware)
10 􀃆 Unicode / MBCS (depending on the GPS firmware)
􀀩 Default = 6

Also from the manual:

Code page for the index files. Has to be consistent with coding in all IMG files included into map-set. Important when global index file is created.

For US/Western European CodePage=1252


I went and checked my mp files and all but one that I checked did not have either of these entries in the header.  So I don't understand how gpsmapedit knows what was set.  It also does not make any sense that gpsmadedit is not saving this in the header.  I am even more confused, but I am glad its working!


Lblcoding=6 is the default so I assume you get that if nothing else is specified.
I'm pretty sure CodePage 1252 is also a default.  I know that Cpreview defaults to that when I run it with nothing else specified.


FWIW... I have never explicitly set either CodePage or LblCoding on my own maps. I use Globalmapper to export .mp files. When I open these files in GPSMapedit, they default to CodePage=1252 and Lblcoding=9.

As a test, I imported a shapefile into GPSMapEdit, then exported as an .mp file without changing anything. This also resulted in LblCoding=9, but no value for CodePage was defined at all.


It looks like GPSmapedit has different defaults than cgpsmapper.  After my shapefile import I see Coding Schema = European Single Byte (Lblcoding=9), but Code Page=0(7bit ASCII) on the first Properties page.  This appears on both the shapefile import and the MP saveas.

A code page of 0 is the same thing as Lblcoding=6 so GPSmapedit creates an internal conflict if you don't specify a Lblcoding AND CodePage.