Welcome, Guest. Please login or register.

Login with username, password and session length
Forums Search:  


Author Topic: Problem with cGPSMapper  (Read 13338 times)

savage

  • Mapper
  • ***
  • Posts: 113
  • Karma: 0
    • View Profile
Problem with cGPSMapper
« on: August 06, 2008, 02:14:20 PM »
Any ideas how to debug this one:


*******************************************************************************
          Garmin and MapSource are registered trademark or trademarks of
                     Garmin Ltd. or one of its subsidiaries.
*******************************************************************************
              cGPSMapper home page: http://cgpsmapper.com
*******************************************************************************
Importing and preprocessing data
Current import datum is: W84 :WGS 84 Global Definition II
Reading [DICTIONARY]

../MA/MAtopo01_A1.MP(139931) : Error E038: Type of element cannot be 0.

-Oz-

  • Map Maker!
  • Administrator
  • Expert Advisor
  • *****
  • Posts: 1579
  • Karma: 27
    • View Profile
    • GPSFileDepot
Re: Problem with cGPSMapper
« Reply #1 on: August 06, 2008, 02:42:06 PM »
i know what the issue is but at the same time I can't tell you.

Can you email me the .mp file? services @ gpsfiledepot.com (remove the spaces around the @)

There is an Unknown type on line 139931.  Once "we" know the name we can figure out where the error was.
Dan Blomberg
Administrator - GPSFileDepot
GPS Units: Garmin Dakota 20, Garmin GPSMap 60csx, Nuvi 255W, Nuvi 250W, ForeRunner 110, Fenix 2, Tactix Bravo, Foretrex 401
See/Download My Maps!

savage

  • Mapper
  • ***
  • Posts: 113
  • Karma: 0
    • View Profile
Re: Problem with cGPSMapper
« Reply #2 on: August 06, 2008, 03:57:48 PM »
Thanks for the tip. Here is the bad part:

[RGN80]
Type=Unknown Area Type
Label=Massachusetts
Data0=(42.5,-73),(42.5,-73.3560404),(42.500018,-73.356031),(42.510002,-73.352527),
(42.511139,-73.352064),(42.511594,-73.351892),(42.524154,-73.347303),

It looks like it is some sort of boundary (state or county). Let me know if you need the file.

-Oz-

  • Map Maker!
  • Administrator
  • Expert Advisor
  • *****
  • Posts: 1579
  • Karma: 27
    • View Profile
    • GPSFileDepot
Re: Problem with cGPSMapper
« Reply #3 on: August 06, 2008, 04:04:26 PM »
Did you convert the state to a line?  Because it seems like although you may have you left the polygon that the state border came from.

If that is the case maybe the tutorial needs a little bit more work.
Dan Blomberg
Administrator - GPSFileDepot
GPS Units: Garmin Dakota 20, Garmin GPSMap 60csx, Nuvi 255W, Nuvi 250W, ForeRunner 110, Fenix 2, Tactix Bravo, Foretrex 401
See/Download My Maps!

-Oz-

  • Map Maker!
  • Administrator
  • Expert Advisor
  • *****
  • Posts: 1579
  • Karma: 27
    • View Profile
    • GPSFileDepot
Re: Problem with cGPSMapper
« Reply #4 on: August 06, 2008, 04:24:25 PM »
side note: you won't be able to compile any segments because most likely the state continues into those segments.
Dan Blomberg
Administrator - GPSFileDepot
GPS Units: Garmin Dakota 20, Garmin GPSMap 60csx, Nuvi 255W, Nuvi 250W, ForeRunner 110, Fenix 2, Tactix Bravo, Foretrex 401
See/Download My Maps!

savage

  • Mapper
  • ***
  • Posts: 113
  • Karma: 0
    • View Profile
Re: Problem with cGPSMapper
« Reply #5 on: August 06, 2008, 06:03:27 PM »
Thanks. I will looked into the state and county lines tomorrow. I think I remember having difficulties in this area.

-Oz-

  • Map Maker!
  • Administrator
  • Expert Advisor
  • *****
  • Posts: 1579
  • Karma: 27
    • View Profile
    • GPSFileDepot
Re: Problem with cGPSMapper
« Reply #6 on: August 06, 2008, 06:10:40 PM »
if I can help you out let me know.  The key is to copy the line (not the polygon) and then paste it into a new file so you don't have the polygon.  (or open the control panel and close the polygon layer).
Dan Blomberg
Administrator - GPSFileDepot
GPS Units: Garmin Dakota 20, Garmin GPSMap 60csx, Nuvi 255W, Nuvi 250W, ForeRunner 110, Fenix 2, Tactix Bravo, Foretrex 401
See/Download My Maps!

savage

  • Mapper
  • ***
  • Posts: 113
  • Karma: 0
    • View Profile
Re: Problem with cGPSMapper
« Reply #7 on: August 07, 2008, 06:41:07 PM »
I am still getting quite a few of those "Unknown area type". I am going to make a bare bone map and add one layer at a time to see where they are coming from. I know I removed the border completely.

This could take a few days to figure out.

-Oz-

  • Map Maker!
  • Administrator
  • Expert Advisor
  • *****
  • Posts: 1579
  • Karma: 27
    • View Profile
    • GPSFileDepot
Re: Problem with cGPSMapper
« Reply #8 on: August 08, 2008, 04:18:55 AM »
very interesting.  let me know the results; perhaps I missed something in the tutorial.
Dan Blomberg
Administrator - GPSFileDepot
GPS Units: Garmin Dakota 20, Garmin GPSMap 60csx, Nuvi 255W, Nuvi 250W, ForeRunner 110, Fenix 2, Tactix Bravo, Foretrex 401
See/Download My Maps!

savage

  • Mapper
  • ***
  • Posts: 113
  • Karma: 0
    • View Profile
Re: Problem with cGPSMapper
« Reply #9 on: August 08, 2008, 12:18:59 PM »
I made some progress. The Unknown Area Type is coming from the nhd_waterbody.shp file. There maybe others. Here is an snippet of the associated MP file:

[RGN80]
Type=Unknown Area Type
Data0=(42.793154,-74.090861),(42.7932061,-74.0908459),(42.79324,-74.0908361),
(42.7932875,-74.0907875),(42.793332,-74.090742),(42.7933389,-74.0907009),
(42.793304,-74.0906521),(42.79331,-74.090539),(42.7932929,-74.09051),
(42.793251,-74.090521),(42.79318,-74.0906109),(42.7931169,-74.0906419),
(42.7929449,-74.090676),(42.792906,-74.0907061),(42.792895,-74.0907239),
(42.7928969,-74.0908009),(42.7929141,-74.090877),(42.7929359,-74.0909039),
(42.792976,-74.0909109),(42.793049,-74.090888),(42.793154,-74.090861)
[END]

I tried to track it down to the .sql file but unfortunately the lat/long are not easily readable in the SQL file and the SHP file is binary.

What next?

savage

  • Mapper
  • ***
  • Posts: 113
  • Karma: 0
    • View Profile
Re: Problem with cGPSMapper
« Reply #10 on: August 08, 2008, 12:42:08 PM »
I was looking inside the sql database and there are many mp_type that are null:

19432;"Unknown Area Type";159293933;"11/04/07";"High";0;"";0.004;0;2020006013018;"LakePond";39000;0.00266677692073;

The fcode is 39000 but those fcode are not updated by the sql query.

What is a 39000? Is it a pond?

-Oz-

  • Map Maker!
  • Administrator
  • Expert Advisor
  • *****
  • Posts: 1579
  • Karma: 27
    • View Profile
    • GPSFileDepot
Re: Problem with cGPSMapper
« Reply #11 on: August 08, 2008, 02:22:55 PM »
I've updated all the water queries to have a catch-all at the end where if the type isn't set it gets rid of it.

http://www.gpsfiledepot.com/tools/nhd_queries.zip

With that said; fcode 39000 is a "LAKE/POND" with no attributes. I've updated the queries to take this into account.  So your best bet is to download the new queries and rerun the waterbody stuff.  Sorry and I find it odd with my maps I've never caught that fcode.
Dan Blomberg
Administrator - GPSFileDepot
GPS Units: Garmin Dakota 20, Garmin GPSMap 60csx, Nuvi 255W, Nuvi 250W, ForeRunner 110, Fenix 2, Tactix Bravo, Foretrex 401
See/Download My Maps!

savage

  • Mapper
  • ***
  • Posts: 113
  • Karma: 0
    • View Profile
Re: Problem with cGPSMapper
« Reply #12 on: August 09, 2008, 06:06:19 PM »
Thanks. Those new queries fixed a lot of problems but I am still getting few "Unknown Are Type". Stay tuned!

-Oz-

  • Map Maker!
  • Administrator
  • Expert Advisor
  • *****
  • Posts: 1579
  • Karma: 27
    • View Profile
    • GPSFileDepot
Re: Problem with cGPSMapper
« Reply #13 on: August 09, 2008, 06:16:16 PM »
really; definitely let me know where, very odd since I just made most of new mexico and have yet to run into these issues; must be a new england thing :-D
Dan Blomberg
Administrator - GPSFileDepot
GPS Units: Garmin Dakota 20, Garmin GPSMap 60csx, Nuvi 255W, Nuvi 250W, ForeRunner 110, Fenix 2, Tactix Bravo, Foretrex 401
See/Download My Maps!

savage

  • Mapper
  • ***
  • Posts: 113
  • Karma: 0
    • View Profile
Re: Problem with cGPSMapper
« Reply #14 on: August 10, 2008, 03:26:10 AM »
I think some of the "Unknown Area" are coming from the nps_boundary.shp
Could you check it for MA?

 

anything