Welcome to GPSFileDepot!

Main Menu

Mapsource quit loading NE USA TOPO Part 1

Started by Quasind, July 04, 2011, 10:02:44 PM

Previous topic - Next topic


I can't find anything in the forums that addresses this problem.
I just purchased an Etrex Venture HC with MapSource 5.  I loaded NE USA TOPO PART 1 from GPSFILEDEPOT and it worked great.  The maps were a quantum leap better than the Garmin base map.  But after three days MapSource stopped completely despite many attempts to reload it as directed.  I downloaded MapSource 6.16.3 and that worked, but it prevents me from loading anymore of the NE USA TOPO PART 1 map sections.  Nothing shows up in the map window where the section list used to be when I select the correct map from the map list.  I can continue to use the four that were loaded into the Etrex earlier, but cannot continue to load anymore of  the topo map sections for the state of Michigan.
Is there any way to load your maps into the Venture with or without MapSource?
I use Windows 7 if that makes a difference.


Are you using Windows 7 64 bit? That might make a difference - there are a number of issues with the 64 bit version vs. the installer that is used for many of the maps on this site. It gets kind of complicated, so I'll let someone else run down the details...


If it's a Venture HC it only has 24 MB of memory.  How big are the 4 maps you already have loaded?


I am using Windows 32 bit.
I should have memory, I only loaded 4 sections of the map.
I just bought the Etrex,  I have saved very little.  how do I check the memory?


Check the size of the maps you select in MapSource.  There's a bar on the left of the screen with tabs for Maps, Waypoints, Routes, and Tracks.  Select the Maps tab and then select the areas you have sent to the Vista with the Map Select tool on the top menu bar.  The total memory used for the maps selected will show in the Maps Tab bar.  If its close to 24MB you are out of luck.


What do you mean by, "Nothing shows up in the map window where the section list used to be when I select the correct map from the map list."  If its what I think you mean, go to view menu and select show user data tabs