Downloaded, Ran Installer, Doesn't Show in MapSource

Started by GadgetBuilder, May 18, 2011, 01:12:49 PM

Previous topic - Next topic


I'm new at this and unfortunately have botched something as I try to come up to speed.

I'm running XP SP3. I installed the latest Mapsource and it seems to run.  

I downloaded the NE USA Topo Part 1 and ran its installer.  I had the installer use a folder on D: rather than the default since C: doesn't have much room.  The installer completed normally.  But Mapsource doesn't show a map in the left pane.  So I tried to use MapSetToolkit to install the map but after filling out the form its Install said: "Family ID exist".

I didn't install cgpsmapper because it isn't needed when using a map from GPSFileDepot.  Or at least it isn't used explicitly.  The tutorial says to load both MapsetToolkit and cgpsmapper before the flow splits and the path I took didn't need cgpsmapper.  But MapSetToolkit mentions cgpsmapper so now I'm not sure.  I prefer to install as few programs as possible but maybe I went too far here?

I expected the installer to make NE Topo show in Mapsource and wonder if this didn't happen because I installed in a non-standard place?

EDIT:  View/Switch to Product  showed NE Topo and selecting it made the map visible.
        View/Map Detail/Highest shows a nice Topo map

EDIT2:  Some areas of the map don't show roads.  The area around Lyndonville, VT has no roads, at 2mi scale there is a gray line around the area and roads end at that line -- Rt 91 is missing a section there.  Similarly for the area east of Lake Champlain & south of Rt 89.  Not sure if it was an install problem or the map is missing these details.

But Mapsource's left pane doesn't show it and it says 0 maps

How do I get Mapsource to recognize this map?

Thanks,  John


The MAPS tab in the left pane of MapSource is not for installed maps, they are displayed in a drop down menu just above.

Open any map in MapSource, zoom way out so you can see a large area, select the [MAP TOOL] from the tool bar, and start highlighting areas of the map you want to send to a GPSr unit or add to a map compilation, etc....

As you do this, these sections of installed maps will be listed in the MAPS tab in the left pane of MAPSOURCE.
Garmin GPSMap 60cs, Dakota 20, Colorado 400t, Oregon 300/400t/450/550t/650/650t, Montana 650, Lowrance Endura Sierra, nuvi 3790, iPhone 3G/4/4s
Geocaching ID: Atlas Cached Ambassador


Thanks for the response, it was very helpful.  I recently ordered a 60CSx via eBay so I'm trying to understand the tools prior to its arrival.

MapSource doesn't show a drop down menu on the left for me but the  View/Switch to Product seemed to make the map recognizable by MapSource.   It isn't clear whether Mapsource thinks this map is "installed" but it lets me work with it. Per your suggestion, I now see a list of files in the left pane after selecting an area.

Which leaves the question of whether the NE Topo installed incorrectly or there is an issue with the map itself.   In the St. Johnsbury/Lyndonville Vermont area of the map the roads are missing although the topography and some POIs are displayed.

Are the roads part of the Topo map or are they separate files that overlay the Topo map?

I expect to hike in the Lyndonville area this summer so this particular set of road details is of real interest to me.


If the map was not installed, MapSource/BaseCamp would not see/list it.

A topo map includes roads. 

The map author does not give data source information; however, I would expect it to have been the Census TIGER files.  These files are distributed by county.  If the entire county that the area is in is missing road/transportation data, it is likey he missed downloading or processing the data.

You might want to look at the New England Topo by savage - if 40 ft contours will work for you.

You might also consider using my US Planimetric - North East mapset and my New England contours20ft overlay mapset which together will display on the GPSr as a topo map.


Thanks for the additional info, I didn't know the data was processed by county.  I chose the "Northeast Topo United States Part 1 of 3" because it covered the area of interest and was an editors choice.  But roads aren't included for Addison and Caledonia counties in Vermont.

I don't have any prior experience with topo maps but "Northeast Topo United States Part 1 of 3" is very nice in that it shows rivers with some width rather than just a blue line plus it has more extensive POIs than the others I looked at.  What I attempted was to select mostly from this map and then substitute Caledonia county from the Savage topo.  This seemed to work, at least it generated appropriate files on a thumb drive.  I haven't figured out how to look at the result with the PC so when the GPSr arrives I'll copy these files to the microsd card and see whether it works.

Thanks for helping this newbie get started.


I do not know how he processed the data; what I was refering to was that the source files from Census are distributed by county with many type of seperate data files for each county.   The transportation and hydro line data come in the same file; he used USGS NHD data for hydro so would have had to seperate the two in the Census file; the roads, etc. may have got 'lost' in the processing.
I would guess the editor's choice rating was based on the source data used.  A detailed visual inspection of every mapset uploaded here would be very time consuming.   


Hi folks ..
I want to continue this topic a bit if we could...

1st ... thanks to Oz and others for these maps. The Az Topo is killer and a 100% must have if you are off the road in Az. I have also DL's the Az Topo to my Nuvi and it looks great there also.

I do have an issue with installing maps into Windoz 7 systems.
I have had completely uneven results with installing the maps into these systems.
I have used the MapSouce CD, done the Trainer trick and on some systems these maps refuse to install. I have yet to investigate the Garmin / Mapsource / Families registry issues with the systems that will not "take" the maps .. but that is the end of the rope as far as I know if that does not work.

Is it just me or is Windoz 7 a bit hostile?

Thanks in advance!


This has been discussed in a few threads in the mapmaking forum, and is related to registry issues with the standard installer script used by many of us. IIRC, the issues were specific to the 64 bit version of Windows 7. Here are a couple threads. Gets pretty technical and I'm not sure if they will help...,1022.0.html,1484.0.html


I thought the AZ topo had the 64 bit handling built in.  Windows 7 64 bit or 32 bit?  I am using win 7 on all my computers.
Dan Blomberg
Administrator - GPSFileDepot
GPS Units: Garmin Dakota 20, Garmin GPSMap 60csx, Nuvi 255W, Nuvi 250W, ForeRunner 110, Fenix 2, Tactix Bravo, Foretrex 401
See/Download My Maps!


AZ Topo is running on my 64 bit Win7 machine.  It installed in the (x86) folder.



Did you have to do anything special to get the AZ tppo running on your machine or it worked as the tutorials suggest?

Oz, does the NY topo have the updated installer for W7 64bit? I am having some trouble, I started a thread here:,2084.0.html


Indrid Cold

Quote from: ineedmaps1 on May 27, 2011, 04:09:44 PM
Oz, does the NY topo have the updated installer for W7 64bit? I am having some trouble, I started a thread here:,2084.0.html
Oz isn't the author of that map so he wouldn't be able to answer that.


Quote from: ineedmaps1 on May 27, 2011, 04:09:44 PM

Did you have to do anything special to get the AZ tppo running on your machine or it worked as the tutorials suggest?

Just downloaded it, and ran the EXE.

MapSource/Basecamp should be closed when you do the installation.


If you downloaded the NY Topo after the new version was uploaded on May 6, 2011 it should ? be compatable with a 64-bit machine.  I followed the instructions in the tutorial for topo maps part 9.
From the NSIS site version 2.46 (dated 12/05/09) was downloaded on March 11, 2011 as was the setup template file referenced in the tutorial - updated 7 Mar, 2010.  These were used for mapsets (11 so far) I have been recently uploading.

Anyone else having a problem with my recently uploaded mapsets?
NSIS, etc. was run on a 32-bit computer; could this be causing a problem?  


I just downloaded your NY Topo, ran the installer and it shows up fine and as I said above I'm running Win7 64.