Welcome, Guest. Please login or register.

Login with username, password and session length
Forums Search:  


Author Topic: Downloaded Maps don't show in MapSource  (Read 37877 times)

Boonieman

  • Jr. Member
  • **
  • Posts: 5
  • Karma: 0
    • View Profile
Re: Downloaded Maps don't show in MapSource
« Reply #30 on: January 02, 2011, 08:14:35 PM »
Boyd - I looked at the thread you mentioned earlier. It's not exactly the same problem, but I think in their attempt to fix one problem, they may have inadvertently created the one we're faced with now. Hard coding the Wow6432 key into the registry path is probably a bad idea. I suspect the NSIS installer is confused as to which registry it's working with (32-bit or 64-bit). Normally you would tell it by using the SetRegView command. My advice would be to go back to the old script. It seemed to work just fine for both Windows XP and Windows 7 64-bit when I tried it. Maybe we should bring -Oz- into the discussion. I think he was the one that made the changes.

mrcyogi

  • Jr. Member
  • **
  • Posts: 19
  • Karma: 0
    • View Profile
Re: Downloaded Maps don't show in MapSource
« Reply #31 on: January 03, 2011, 05:15:00 AM »
jbensman, I think you've missed an important detail. The OP has tried to install the same GPSFileDepot maps on TWO DIFFERENT COMPUTERS. They work as expected on Vista and MSTK lists all the maps, including City Navigator. But on his Win 7 64 machine, the installer has not worked correctly and neither mapsource nor MSTK show any maps other than the real Garmin City Navigator.


THE ABOVE IS CORRECT.

In response to all the comments so far, while you guys work on the "installer" and "registry" possibilities, I will try to install the "My Trails" map suggested by ibensman and try and check the registry on my new laptop for that doubling of part of the locational coding. I'l wait for using MapKit to upload via the .img files and the tutorial at GPSFileDepot until I here from yousss. Thanks again for your continued attention.

Marshall

Just downloaded My Trails and it worked; it showed in MapSource. But==the files of My Trails had not extensions as apposed to the files for the FL topo: it had .img.idx files and next to each of the many was a file called "Disc Image File"  Hopefully this will be info that will help solve my downloading problem with this laptop for all the topos I've tried to download and have show in MapSource.


« Last Edit: January 03, 2011, 05:50:52 AM by mrcyogi »

Boyd

  • Expert Advisor
  • *****
  • Posts: 3811
  • Karma: 43
    • View Profile
Re: Downloaded Maps don't show in MapSource
« Reply #32 on: January 03, 2011, 07:04:43 AM »
the files of My Trails had not extensions as apposed to the files for the FL topo: it had .img.idx files and next to each of the many was a file called "Disc Image File"  Hopefully this will be info that will help solve my downloading problem with this laptop for all the topos I've tried to download and have show in MapSource.

Well that's another problem then. Garmin map files must have a .img extension. Unfortunately, that same extension is used for Mac disk image files - see http://www.fileinfo.com/extension/img

Somehow it sounds like your computer has added the .idx extension to the .img files, if I understand what you're saying. In other words, in the mapset folder are you seeing something similar to this?

12345601.img.idx
12345602.img.idx
12345603.img.idx

jbensman

  • Expert Advisor
  • *****
  • Posts: 422
  • Karma: 7
    • View Profile
Re: Downloaded Maps don't show in MapSource
« Reply #33 on: January 03, 2011, 08:15:37 AM »
This is really weird.  What happens when you look at My Trails in MapSource?

Which Topo Maps are the ones that would not install?

I am attaching the install script for My Trails in case it will shed any light on this. 

mrcyogi

  • Jr. Member
  • **
  • Posts: 19
  • Karma: 0
    • View Profile
Re: Downloaded Maps don't show in MapSource
« Reply #34 on: January 03, 2011, 08:38:00 AM »
Those sample file names are correct as they appear in the Fl Topo folder on my laptop

I didn't try loading the My Trails in MapSource--I was so pleased they were there. I will do it now.......Now My Trails doesn't show in Mapsource. I checked the folder and the files, like 00000124 don't have extensions--don't know if this is a (the) problem.  So frustraing!!

jbensman

  • Expert Advisor
  • *****
  • Posts: 422
  • Karma: 7
    • View Profile
Re: Downloaded Maps don't show in MapSource
« Reply #35 on: January 03, 2011, 09:15:03 AM »
Maybe there is somethng wrong with your computer.  Try installing some other program and see if it installs correctly. 

Boyd

  • Expert Advisor
  • *****
  • Posts: 3811
  • Karma: 43
    • View Profile
Re: Downloaded Maps don't show in MapSource
« Reply #36 on: January 03, 2011, 01:18:38 PM »
I think I know the solution for you. Buy a new computer with a different version of Windows!  ;D

mrcyogi

  • Jr. Member
  • **
  • Posts: 19
  • Karma: 0
    • View Profile
Re: Downloaded Maps don't show in MapSource
« Reply #37 on: January 12, 2011, 05:50:19 AM »
Well, here's what finally solved the download problems. Start downloading with no other programs running. If you are unsuccessful choosing to "Run" the program, in other words it doesn't download properly, then try "Save" to "Programs (86X) folder on your computer. If there is a separate installer indicated for the download, remember you have to go to the downloaded folder and open it and use the installer file. The most important part of the solution to my problem(s) was to restart my computer after each download--before trying to downloand another map.

Thanks everyone for the help. I have no idea why it worked this way.
Regards,
Marshall

Al Warren

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
Re: Downloaded Maps don't show in MapSource
« Reply #38 on: January 12, 2011, 04:42:10 PM »
We are having the same problem - We downloaded several maps and they installed properly (a wizard appeared after the download was complete).  However, when I downloaded Wisconsin topo, we never received the install wizard & the map did not install into Base Camp.  Did it again with the same results.  Tried the link mentioned in an earlier post but am totally lost!

maps4gps

  • Expert Advisor
  • *****
  • Posts: 1524
  • Karma: 17
    • View Profile
Re: Downloaded Maps don't show in MapSource
« Reply #39 on: January 12, 2011, 05:29:43 PM »
Did you try running/executing the .exe file which was downloaded?
Are you using 64bit Widows7?