Welcome, Guest. Please login or register.

Login with username, password and session length
Forums Search:  


Author Topic: TBD issue?  (Read 7076 times)

-Oz-

  • Map Maker!
  • Administrator
  • Expert Advisor
  • *****
  • Posts: 1579
  • Karma: 27
    • View Profile
    • GPSFileDepot
TBD issue?
« on: March 06, 2010, 01:18:20 PM »
Okay, so compiled a new arizona map and although it appears to have gone well each time I create the .tbd, .mdx, and .img files for the preview it crashes in mapsource.

it is only occuring with the new Arizona img files because i recompiled the preview stuff for another of my maps and it worked just fine.

here is the error Mapsource spits out:
Quote
<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<ErrorReport xmlns="http://www.garmin.com/xmlschemas/ApplicationErrors/v1">

  <Error>
    <Exception>
      <SourceCodeLocation>
        <SourceFileName>TDB_REGIONDIR.CPP</SourceFileName>
        <SourceFileLine>164</SourceFileLine>
      </SourceCodeLocation>
      <Extra>
Product ID: 213778433
Region ID: 0</Extra>
    </Exception>
    <Application>
      <Name>MapSource</Name>
      <Build>
        <Version>
          <VersionMajor>6</VersionMajor>
          <VersionMinor>15</VersionMinor>
          <BuildMajor>11</BuildMajor>
          <BuildMinor>0</BuildMinor>
        </Version>
        <Type>Release</Type>
        <Time>Jan 26 2010, 11:31:06</Time>
        <Builder>sqa</Builder>
      </Build>
      <LanguageID>1033</LanguageID>
      <PartNumber>006-A0041-00</PartNumber>
    </Application>
    <Computer>
      <OperatingSystem>WIN32 Windows Platform, Major Version: 6, Minor Version: 1 </OperatingSystem>
      <Processor>x86, Processor Level: 6, Processors:2, Model: 15 Stepping: 13</Processor>
      <RamSize>2086928</RamSize>
    </Computer>
    <Time>2010-03-06T21:15:52Z</Time>
  </Error>

</ErrorReport>

Ever seen it before?

The .img files were compiled with cgpsmapper shareware 0100a on windows 7 64bit
Dan Blomberg
Administrator - GPSFileDepot
GPS Units: Garmin Dakota 20, Garmin GPSMap 60csx, Nuvi 255W, Nuvi 250W, ForeRunner 110, Fenix 2, Tactix Bravo, Foretrex 401
See/Download My Maps!

-Oz-

  • Map Maker!
  • Administrator
  • Expert Advisor
  • *****
  • Posts: 1579
  • Karma: 27
    • View Profile
    • GPSFileDepot
Re: TBD issue?
« Reply #1 on: March 06, 2010, 10:51:52 PM »
I wonder why that is; perhaps because its running as a 32bit program since there is no 64 bit version.

the error occurs on 32bit and 64bit OS.  I'm trying to narrow it down to what by recompiling old maps and seeing if I can force the error.  So far it appears to generate preview files fine for old .img and even recompile the old .img and that works.

I'm remaking a .mp file of an old map now to try and narrow this down.
Dan Blomberg
Administrator - GPSFileDepot
GPS Units: Garmin Dakota 20, Garmin GPSMap 60csx, Nuvi 255W, Nuvi 250W, ForeRunner 110, Fenix 2, Tactix Bravo, Foretrex 401
See/Download My Maps!

bob_piper

  • Jr. Member
  • **
  • Posts: 6
  • Karma: 0
    • View Profile
Re: TBD issue?
« Reply #2 on: March 07, 2010, 05:27:26 PM »
I'm having this same error message. Any idea how to resolve it? There is another post on the forum,  "Mapsettoolkit help - install results in Mapsource error in TDB_REGIONDIR.CPP" that shows the exact same error message from MapSource. They suggest that the problem might be a registry setting?

Thanks,
Bob

-Oz-

  • Map Maker!
  • Administrator
  • Expert Advisor
  • *****
  • Posts: 1579
  • Karma: 27
    • View Profile
    • GPSFileDepot
Re: TBD issue?
« Reply #3 on: March 07, 2010, 05:43:00 PM »
Okay; try this:
Originally I was working in this folder: C:\gps_maps\ArizonaTopo\release_version_2.00\final

So then i tried working in just
C:\gps_maps\State

And I haven't had that error again.
Dan Blomberg
Administrator - GPSFileDepot
GPS Units: Garmin Dakota 20, Garmin GPSMap 60csx, Nuvi 255W, Nuvi 250W, ForeRunner 110, Fenix 2, Tactix Bravo, Foretrex 401
See/Download My Maps!

masdangkolo

  • Jr. Member
  • **
  • Posts: 16
  • Karma: 0
    • View Profile
Re: TBD issue?
« Reply #4 on: March 07, 2010, 10:39:25 PM »
Yeah, I was fighting with the very same issue. After upgrading everything and no success, I turned to the web. Looks like you posted around the time I started upgrading things.  Moved my maps to a shorter directory path (C:\maps) and all is better now.

-Oz-

  • Map Maker!
  • Administrator
  • Expert Advisor
  • *****
  • Posts: 1579
  • Karma: 27
    • View Profile
    • GPSFileDepot
Re: TBD issue?
« Reply #5 on: March 08, 2010, 02:35:58 PM »
That is so weird but good to know.
Dan Blomberg
Administrator - GPSFileDepot
GPS Units: Garmin Dakota 20, Garmin GPSMap 60csx, Nuvi 255W, Nuvi 250W, ForeRunner 110, Fenix 2, Tactix Bravo, Foretrex 401
See/Download My Maps!

hntr

  • Mapper
  • ***
  • Posts: 68
  • Karma: 0
    • View Profile
Re: TBD issue?
« Reply #6 on: March 10, 2010, 08:50:05 AM »
Maybe Garmin changed something in their newest versions of MapSource 6.15.9 to 6.15.11

I know they changed their locking mechanism in these versions.  Did you notice this error start to occur after you updated your MapSource?

-Oz-

  • Map Maker!
  • Administrator
  • Expert Advisor
  • *****
  • Posts: 1579
  • Karma: 27
    • View Profile
    • GPSFileDepot
Re: TBD issue?
« Reply #7 on: March 10, 2010, 10:13:08 AM »
I still had 6.15.9 installed on one of the computers that was throwing the error.
Dan Blomberg
Administrator - GPSFileDepot
GPS Units: Garmin Dakota 20, Garmin GPSMap 60csx, Nuvi 255W, Nuvi 250W, ForeRunner 110, Fenix 2, Tactix Bravo, Foretrex 401
See/Download My Maps!

bob_piper

  • Jr. Member
  • **
  • Posts: 6
  • Karma: 0
    • View Profile
Re: TBD issue?
« Reply #8 on: March 11, 2010, 06:51:47 PM »
I tried moving everything to a directory with a shorter path and I recompiled all of my map information but I'm still getting this error in MapSource:

    <Exception>
      <SourceCodeLocation>
        <SourceFileName>TDB_REGIONDIR.CPP</SourceFileName>
        <SourceFileLine>164</SourceFileLine>
      </SourceCodeLocation>
      <Extra>
Product ID: 3650224129
Region ID: 0</Extra>

I'm running Windows Vista 32bit and MapSource 6.15.11. I've been able to successfully install the NY Topo map from GPSFileDepot without any troubles. I'm trying to create a topo map for Vermont and I'll gladly add it to the collection if I can get it to work.

Thanks for your great work OZ,
Bob

bob_piper

  • Jr. Member
  • **
  • Posts: 6
  • Karma: 0
    • View Profile
Re: TBD issue?
« Reply #9 on: March 11, 2010, 06:58:05 PM »
I guess if I was looking closer I would've seen that Savage has done ALL of New England, so I don't really need to do a Vermont map. However, I've gotten this far and I'd like to finish it.

Thanks,
Bob

-Oz-

  • Map Maker!
  • Administrator
  • Expert Advisor
  • *****
  • Posts: 1579
  • Karma: 27
    • View Profile
    • GPSFileDepot
Re: TBD issue?
« Reply #10 on: March 11, 2010, 09:30:16 PM »
Which directory are you using?  Like where are the .img files?
Dan Blomberg
Administrator - GPSFileDepot
GPS Units: Garmin Dakota 20, Garmin GPSMap 60csx, Nuvi 255W, Nuvi 250W, ForeRunner 110, Fenix 2, Tactix Bravo, Foretrex 401
See/Download My Maps!

bob_piper

  • Jr. Member
  • **
  • Posts: 6
  • Karma: 0
    • View Profile
Re: TBD issue?
« Reply #11 on: March 11, 2010, 09:46:09 PM »
C:\Vermont\release_version_1.01\

I had moved my first release to C:\Vermont\ but I still got the error.
« Last Edit: March 11, 2010, 10:06:14 PM by bob_piper »

-Oz-

  • Map Maker!
  • Administrator
  • Expert Advisor
  • *****
  • Posts: 1579
  • Karma: 27
    • View Profile
    • GPSFileDepot
Re: TBD issue?
« Reply #12 on: March 12, 2010, 09:05:45 AM »
Oaky, that is interesting because that is shorter than I am using.

Someone else was saying that there are issues in the registry.

I hate to say but I would email cgpsmapper and see if he has any advice: [email protected]
Dan Blomberg
Administrator - GPSFileDepot
GPS Units: Garmin Dakota 20, Garmin GPSMap 60csx, Nuvi 255W, Nuvi 250W, ForeRunner 110, Fenix 2, Tactix Bravo, Foretrex 401
See/Download My Maps!

bob_piper

  • Jr. Member
  • **
  • Posts: 6
  • Karma: 0
    • View Profile
Re: TBD issue?
« Reply #13 on: March 12, 2010, 08:23:59 PM »
Okay, I sent an e-mail today and will let everyone know the result.

I'm tempted to go to an earlier version of Mapsettoolkit and see if that works. I'm using v.1.75. I don't know if that's really the problem but it would be worth a try.