Welcome, Guest. Please login or register.

Login with username, password and session length
Forums Search:  


Author Topic: registry error with installer  (Read 3396 times)

deepspace

  • Mapper
  • ***
  • Posts: 109
  • Karma: 0
    • View Profile
registry error with installer
« on: March 09, 2009, 06:50:07 AM »
I created a installer but am running into problems. For some reason its creating a different family ID.
The installer lines are:
  !define MAP_ID              C10C             ; Family ID = 360 (dec) = 0168 (hex) = 6801 (hex flipped) --> http://www.geocities.com/binary_converter/
;  !define MAP_TYPE            11224          ; only if using custom types
  !define DIRECTORY           "C:\washington\"
  !define EXE_FILE            "${DIRECTORY}nw-wa_install.exe"
The family id created is a completely different. If I manually correct it things open on map source correctly. Do I need to remove the ; and assign a custom MAP_TYPE to correct this?
Thanks

dhisum_dhisum

  • Mapper
  • ***
  • Posts: 71
  • Karma: 0
    • View Profile
Re: registry error with installer
« Reply #1 on: March 09, 2009, 08:34:19 AM »
Edit the registry file i.e. the '.reg' file from the directory where maptoolkitset created the preview files and make sure that the mapid in the reg file matches what you put in the nsi file. Registry files are just text files with a .reg extension, so you can open it in the notepad. If it does not match, edit the reg file to fix the issue and then try again. That should solve the problem.

deepspace

  • Mapper
  • ***
  • Posts: 109
  • Karma: 0
    • View Profile
Re: registry error with installer
« Reply #2 on: March 09, 2009, 11:34:53 AM »
Thanks for the help. Oz your right its keeps saying the FID is 3265.
Thanks again.

deepspace

  • Mapper
  • ***
  • Posts: 109
  • Karma: 0
    • View Profile
Re: registry error with installer
« Reply #3 on: March 09, 2009, 06:24:40 PM »
Interesting thing now. I did as stated just ran the install now it comes up again with the Map source warning there is a problem with the map and to correct it (of couse map source does not open) when I open map set tools it has everything but FID as 360, FID is listed as 3601. If I try to edit as before it will not let me, stating FID 360 already exists (which it did before). Maybe it will work correctly on another machine and not mine because I had the family already?

-Oz-

  • Map Maker!
  • Administrator
  • Expert Advisor
  • *****
  • Posts: 1577
  • Karma: 27
    • View Profile
    • GPSFileDepot
Re: registry error with installer
« Reply #4 on: March 09, 2009, 11:00:39 PM »
a three digit FID.  if you look at the .reg file that is created by cgpsmapper you can see what it should be and just copy that into the installer script (without the comma).
Dan Blomberg
Administrator - GPSFileDepot
GPS Units: Garmin Dakota 20, Garmin GPSMap 60csx, Nuvi 255W, Nuvi 250W, ForeRunner 110, Fenix 2, Tactix Bravo, Foretrex 401
See/Download My Maps!

deepspace

  • Mapper
  • ***
  • Posts: 109
  • Karma: 0
    • View Profile
Re: registry error with installer
« Reply #5 on: March 10, 2009, 08:50:32 AM »
fixed thanks for the help.