Welcome, Guest. Please login or register.

Login with username, password and session length
Forums Search:  


Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - nm_map_user

Pages: [1] 2 3
1
Map Making Support / Re: MapSetToolKit/cgpsmapper - can't parse coordinates
« on: February 23, 2014, 05:13:50 PM »
Look at my second post in this thread. The problem I was having was that my input was in *Universal* Transverse Mercator, but I was selecting (plain-vanilla) Transverse Mercator in the drop down list because I hadn't scrolled far enough to find the UTM entries.

Perhaps you're having the same problem

2
Map Making Support / Re: How to deal with x,y displacement
« on: June 20, 2013, 07:31:31 PM »
You might want to post your question on gis.stackexchange.com - this is really right up their alley. Some amazing knowledgeable people read and post to the forum.

3
Map Making Support / Re: GDAL ESRI shapefile driver, for ms windows?
« on: June 20, 2013, 05:37:22 AM »
gdal file drivers are not drivers in the same sense as windows device drivers. They are pieces of code that know how to understand a specific file format. If you've downloaded the full pre-built gdal package, it's in there buried in a dll. Just try running gdal_contour. If you're still having problems, give us the error messages.

4
Map Making Support / Re: How to deal with x,y displacement
« on: June 12, 2013, 07:40:13 AM »
I would try to figure out why the contours don't line up. My guess is that they don't have the same datum and when you imported the DEMs you selected the wrong datum.

Of course, your pragmatic solution is just fine.

5
IIRC it doesn't show if you are using non-transparent or semi-transparent maps.  I think the problem occurs because the basemap is showing.  It's pretty inaccurate, and, for some reason, transparent maps don't count with the accuracy reading.  Don't know how a map user can tell if his map's transparent or semi-transparent though.

I have the NM topo set from this site on the unit, plus a transparent map I made. However, even if I turn off the transparent map (but not remove it), the circle still shows.

6
It is the accuracy circle.  It is a combination of GPS accuracy and map accuracy.  There is a setting somewhere to turn it on and off.

I've been through every menu on the unit and can't find this. If you have any idea where to look, I'd be grateful.

7
I don't remember the circle being there before, but I also don't recall changing any settings. The circle can vary in diameter, but apparently is not the current ground accuracy. If I go to the Satellite page, my position is listed as +/- 12', but the circle is about 50' in radius.

More importantly, how do I get rid of it?
Thanks

8
Map Making Support / Are there instructions for contributing maps?
« on: April 30, 2013, 08:25:24 PM »
I looked, but couldn't find guidelines for contributing maps. Presumably they're here somewhere and I'm just not spotting the link.

Thanks

9
Map Making Support / Re: cgpsmapper - some polygons not imported
« on: April 30, 2013, 07:28:51 PM »
The whole processing message is rather cryptic and the manual says nothing about the steps. The example above says there are 544 elements to process, but the next line says 2304 were processed. Huh? I was just reading a document describing the .img file layout and my conjecture is that polygons are being split because they are not allowed to cross RGN boundaries, which in turn are influenced by TRE_SIZE. Perhaps that's the 297 split line. By dumb luck, some polygons split across RGN boundaries will be quite small and are thrown out by cgpsmapper.

Of course, all of this is conjecture from the flimsiest of evidence, so perhaps none of it makes any sense at all.

10
Map Making Support / cgpsmapper - some polygons not imported
« on: April 30, 2013, 11:31:48 AM »
When I run cgpsmapper on my map, the output for layer 0 contains this (along with other stuff):
  • ****polygons****
    Elements to process -->544
    100%
    Processed           -->2304
    Split               -->297
    100%
    Successfully imported: 2297 not imported: 7
    ****  END   ****
    Maximum error:    1.90085 meter
    Mean error:       0.403159 meter

If there any way to determine what polygons aren't being imported? And if I can find them, is there anything I can do to fix whatever is preventing them from being processed?

(I did a search of the manual for the term "imported", which occurs several times, but never in this context. Google didn't provide much better.)

11
Isn't it a label that you have defined in mp sources?

As I understand it, labels are per-object, eg, some polygon is Yosemite National Park, a polygon of type 0x14. If there is no label, then the type name is displayed. This is how it works for the default Garmin types. Based on a suggestion by the author of TypWiz (who is really supportive, so make your donation if you're using the program!), I went ahead and loaded my map onto my GPS (map76csx) and indeed the type names appear when I mouse over them, as expected. Why this doesn't work in MapSource is a mystery, but then all kinds of MapSource behavior is a mystery. Garmin seems to make pretty decent hardware (it sure is popular enough), but their software design and implementation leave something to be desired, to put it charitably.

So, bottom line is that all the problems related to this mapset seem to be solved.

12
I originally had the map laid out at levels 24, 20, 18, 16. When it looked jaggy I tried upping the 24 to 26 (which GPSMapEdit seems willing to support, even if it's wrong). Didn't help. After your comment, I set the 0 level back to 24 and changed the others to 22, 20, and 16. The jaggies are pretty much gone.

The only remaining issue is the tool-tips on polygons. The mouse over text is "unknown area", not the string I entered in TypWiz.   I'm using types 0x5100 and 0x5200. With the default types, these appear as wetlands and tundra, and tool tips work. With my custom .typ file, the polygons are painted, but no tool tips.

Here's what the .typ entries look like in text format (minus the bitmap)
[_polygon]
Type=0x5100
;421 DBlk:&4CF
String1=0x00,Private Land
String2=0x04,Private Land
;polygon type: 8
ExtendedLabels=N
Xpm="32 32 2 1"
"0 c #FF6F6F"
"1 c #000000"
....
[end]

[_polygon]
Type=0x5200
ExtendedLabels=N
String1=0x00,Camping
String2=0x04,Camping
Xpm="32 32 2 1"
"0 c #00FF40"
"1 c #000000"
...
[end]

13
Are they still jaggy when you zoom in close?  It looks like you might be seeing multiple levels of objects superimposed.   I've seen this before, but it's not common.

I think the problem is the opposite of what you're suggesting. While zooming in closer and closer, I noticed that the MapSource scale said "overzoom". I then backed out until the "overzoom" message disappeared. That occurs when the scalebar is .7 miles. For the NM Topo Maps, overzoom occurs at 300 ft. Apparently my map is being written at too coarse a level. As noted above, I've set the zoom level 0 to 26 bits (in a text editor).

Could TreSize have anything to do with it? I set it to 1000, based on the cgpsmapper manual. RgnLimit is set to 1024 as the manual states.

14
I'm getting pretty close. I renumbered my line types into the lower range, over-writing some standard values I didn't need. I had never gone through the end of the cgsmapper manual to find the Appendices with the type ranges. Seems 0x30 and above are not valid lines, so that's why they didn't appear. Now I've got my lines appearing, houndstooth is gone.

The lines show their types on mouse-over, but the polygons still don't. Any suggestions?
Also, the lines are jagged, whether I use bitmap lines or non-bitmap lines.
Here are the lines in GPSMapEdit:



and here are the same lines in MapSource:



They're jagged like that even when I don't use the custom .typ file, but I know I've sen and made other maps with smoother lines. Might this have something to do with my zoom levels? Level zero was 24 bits. I changed it to 26, but that made no visual difference. (GPSMapEdit allows a setting of 26 bits, but the cgpsmapper manual stops at 24 bits).

15
I don't think there is any problem with tile size, many maps use bigger tiles.

To clear cache in Mapsource or BaseCamp press Ctrl-G twice.

That's a huge help. Now I'm pretty confident that I'm seeing the map I just generated. From that, I now think my problem lies in my custom .typ file. If I build with no custom typ file, I get a sane background and only the items that coincide with standard Garmin types appear on the map. When I build with my custom .typ file, I don't see all the objects, although all are mapped to types. I'm using roads (polylines) with types 0x30, 0x31, 0x32, 0x33. I'm using polygons with types 0x5100 and 0x5200, in a type file designed using TypWiz.  The houndstooth is a polygon fill "left-over" from a .typ file I started with, and is somehow being used to fill empty space. (It's code is 0x4b00).  Once I deleted that entry, the houndstooth is now gone.

None of the roads are appearing on the map, perhaps these type codes aren't valid?
The polygons appear, but when I mouse over the polygons in MapSource, it says "Unknown area", even though the type is set to "Private Land" for the string.

The .typ file is attached.

Thanks for all the help.

Pages: [1] 2 3
anything