Welcome to GPSFileDepot!

Main Menu

eTrex 20 Problem

Started by gpsbill, March 05, 2024, 09:14:16 AM

Previous topic - Next topic


Been having problems with my old eTrex 20. Thought it might be time to buy a new one and discovered it is no longer for sale, and the 22X is almost $200. So, it seemed wise to check this forum for help. The problem is that I can't load tracks onto the unit. When I copy a track (GDB or GPX) it doesn't recognize the new track and waypoints. Tried that several times. Even saved my new track as current.gpx but my eTrex keeps activating the existing (old) current.gpx. Tried saving my new track as current.gdb too with the same results. Would appreciate any help you folks could offer. Maybe I need to update the software on it? Is that even possible? Thanks!



Garmin used something called webupdater in the past, but AFAIK that is no longer supported by browsers or by Garmin. If you go to the download page, it tells you to use Garmin Express

I am fully settled into my "post Garmin" period and haven't updated any of my old devices for quite awhile. But here's Garmin Express. In theory, you can just plug the eTrex into your computer and run Express. It should tell you whether any updates are available.

AFAIK, Current.gpx is a special filename reserved for system use, so I'm not surprised you had problems there. That file is normally created automatically each time a Garmin GPS starts up. I would try a different filename. I believe that Garmin software uses the name Temp.gpx when it sends files from Basecamp/Mapsource.

Have you tried using Basecamp and/or Mapsource to send your waypoints instead of directly copying the file?