Welcome, Guest. Please login or register.

Login with username, password and session length
Forums Search:  


Author Topic: DrawPriority and Nuvi basemap DEMs  (Read 2561 times)

Seldom

  • Expert Advisor
  • *****
  • Posts: 1852
  • Karma: 19
    • View Profile
DrawPriority and Nuvi basemap DEMs
« on: April 27, 2012, 09:36:24 AM »
Using default DrawPriority=25, my nuvi 1490's background DEM map overroad my map.

Setting DrawPriority=30 fixed it:

« Last Edit: May 01, 2012, 07:59:11 AM by Seldom »

Seldom

  • Expert Advisor
  • *****
  • Posts: 1852
  • Karma: 19
    • View Profile
Re: DrawPriority and Nuvi basemap DEMs
« Reply #1 on: May 05, 2012, 08:03:36 AM »
DrawPriority wasn't the problem, the tile drew correctly with no DrawPriority set, as described here.
There must have been some error in the overall mapset that the nuvi didn't like however because the error occurred with the install of the full mapset, but not the single tile.

It seems that the problem occurs when:
1) I send a map to the GPSr using MapSource.
2) I select the entire mapset from the first selection screen in MapInstall.

It doesn't occur when I select ALL the tiles together from the tile selector screen in MapInstall.
« Last Edit: May 05, 2012, 08:39:11 PM by Seldom »

Seldom

  • Expert Advisor
  • *****
  • Posts: 1852
  • Karma: 19
    • View Profile
Re: DrawPriority and Nuvi basemap DEMs
« Reply #2 on: May 23, 2012, 03:10:08 PM »
MapInstall 4.0.1 gives me the DEM screen on my 1490 from both ways of loading.  DrawPriority is 31. A single 0x4b polygon the size of the tile is drawn on level 0 with endlevel 3.  The map works fine on all my handhelds.   Am I missing something? 

I notice that the OpenFietsMap I downloaded has both an 0x4b polygon and an 0x10200 polygon, that GPSmapedit doesn't recognize.  OpenFietsMap shows correctly on the Nuvi, however.