Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
Forums Search:  


Author Topic: Hate to start another one on BaseCamp, and not seeing maps...  (Read 6455 times)

jayrees

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
Hate to start another one on BaseCamp, and not seeing maps...
« on: October 17, 2013, 10:27:38 PM »
I'm having a slightly different BaseCamp issue. I see the trails map, The Utah topo 2011 map is what I need, The southwest USA topo loaded, and the trails loaded, but the Utah topo doesn't show. In my case I think that the installer doesn't seem to trip the admin controls on the PC windows 7, or it is then an incomplete a corrupt file. Any help is appreciated.

dbperry

  • Mapper
  • ***
  • Posts: 56
  • Karma: 3
    • View Profile
Re: Hate to start another one on BaseCamp, and not seeing maps...
« Reply #1 on: October 18, 2013, 06:19:02 AM »
What do you mean "trails" map? Do you mean "My Trails" as in this map:
http://www.gpsfiledepot.com/maps/view/53/

Are you running Windows 7 64 bit? If so, did you do this:
http://forums.gpsfiledepot.com/index.php/topic,3158.msg18533.html#msg18533

Your guess at 'installer' problems leads me to think you hit the Win7 64-bit issue.

Dave

jayrees

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
Re: Hate to start another one on BaseCamp, and not seeing maps...
« Reply #2 on: October 18, 2013, 07:22:11 AM »
I haave loaded, and caan use the 'My Trails' as in the post you suggested, then - loaded and used. the 'southwest USA topo'. This seems to be more off an issue with the 'Utah Topo 2011' file. The 2 first files asked for administrator rights to modify before installing, the Utah topo did not, and doesn't show in the program list in windows, it only shows as a file in the folder. I'm beginning to think it is a file issue, but the other files that use the same installer also go 'missing'.  I do not think this is the 32 vs 64 bit issue.

MountainWoods

  • Jr. Member
  • **
  • Posts: 31
  • Karma: 1
    • View Profile
Re: Hate to start another one on BaseCamp, and not seeing maps...
« Reply #3 on: November 06, 2013, 12:29:53 PM »
So now I've got a Windows 7 / 64bit machine and I'm reading through the forums and all of the links; but it's a bit difficult finding what is the exact answer to the problem that BaseCamp doesn't "see" the installed maps.  Is it to just download and run the mytrails installer and that somehow fixes things?

Thanks!

MountainWoods

  • Jr. Member
  • **
  • Posts: 31
  • Karma: 1
    • View Profile
Re: Hate to start another one on BaseCamp, and not seeing maps...
« Reply #4 on: November 06, 2013, 12:37:46 PM »
Got it.  So that's what you have to do.  Whether or not you want it or are going to use it, the MyTrails installer "fixes" something in Win7/64.  I assume that eventually the other installers (in years to come) will do the same thing.  But for now, we only need one installer to do the magic for the others.

Then you have to reinstall anything that you had tried to install before using MyTrails.  I did this with the motopo11 and got both of them to show up in BaseCamp.

Not a big issue.  But I wasn't sure that that's what I was reading when each forum post kept linking to yet another forum post, ad libitum.

Thanks!

maps4gps

  • Expert Advisor
  • *****
  • Posts: 1480
  • Karma: 17
    • View Profile
Re: Hate to start another one on BaseCamp, and not seeing maps...
« Reply #5 on: November 06, 2013, 01:10:50 PM »
When I got a machine with 64-bit software, I installed one of my older 32-bit installer mapsets from external hard drive.  I was able to install mapsets made with the 'bad' 64-bit installer even after the 32-bit mapset was removed.  To me it appears running a 32-bit installer 'fixes' whatever glitch 64-bit Windows initially has with the 64-bit installer we were using at that time.  "My trails ...' was suggested as it is small and many users download it for the trail info.

Has anyone installed one of the mapsets (Oz's etc) using the newer 64-bit installer before installing one of my state topos? 

popej

  • Sr. Member
  • ****
  • Posts: 166
  • Karma: 20
    • View Profile
Re: Hate to start another one on BaseCamp, and not seeing maps...
« Reply #6 on: November 06, 2013, 02:22:42 PM »
I'm just guessing, but problem could exist due registry virtualization:
http://msdn.microsoft.com/en-us/library/windows/desktop/aa965884%28v=vs.85%29.aspx

Mapsource and BaseCamp look for registry records in Wow6432Node branch, which is dedicated to 32-bit programs. Install program can do both, look for 64-bit registry branch or for 32-bit branch. Maybe it search both and use the first found. But if there is no map records in registry, it have to create them. And can create registry input in 64-bit branch, which then could mess subsequent installation.

Proper registry branches for Garmin maps are:
32-bit Windows: HKEY_LOCAL_MACHINE\SOFTWARE\Garmin\Mapsource
64-bit Windows: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Garmin\Mapsource

If there exist 32-bit branch on 64-bit Windows, it could suggest some install problems.

Boyd

  • Expert Advisor
  • *****
  • Posts: 2840
  • Karma: 27
    • View Profile
Re: Hate to start another one on BaseCamp, and not seeing maps...
« Reply #7 on: November 07, 2013, 10:27:21 AM »
I wonder... would GMTK identify and fix maps that have this old installer regristry problem? Has anyone ever tried that?